summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Freise <dennis.freise@final-frontier.org>2012-01-26 16:46:58 +0100
committerDennis Freise <dennis.freise@final-frontier.org>2012-01-26 16:46:58 +0100
commitf7a44c02d7a309ffdf8cf20238035a5f1de114b4 (patch)
tree066b05f5b5151c37f634b945d78a249dadd44b83
parentAdded changelog entry for todays work. (diff)
downloaddfreise-f7a44c02d7a309ffdf8cf20238035a5f1de114b4.tar.gz
dfreise-f7a44c02d7a309ffdf8cf20238035a5f1de114b4.tar.bz2
dfreise-f7a44c02d7a309ffdf8cf20238035a5f1de114b4.zip
*fcpci-0.1-r7 (26 Jan 2012)
26 Jan 2012; Dennis Freise <dennis.freise@final-frontier.org> Revision bump, added patch for kernel >= 3.2 (thx to Arnd Feldmueller)
-rw-r--r--net-dialup/fcpci/fcpci-0.1-r7.ebuild80
-rw-r--r--net-dialup/fcpci/files/fcpci-kernel-3.2.0.patch10
2 files changed, 90 insertions, 0 deletions
diff --git a/net-dialup/fcpci/fcpci-0.1-r7.ebuild b/net-dialup/fcpci/fcpci-0.1-r7.ebuild
new file mode 100644
index 0000000..d16f4a1
--- /dev/null
+++ b/net-dialup/fcpci/fcpci-0.1-r7.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6/3.0+ modules for Fritz!Card PCI"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/11_2/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+RESTRICT="primaryuri"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is ge 2 6 ; then
+ die "This package works only with 2.6/3.0+ kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ local BIT="" PAT="012345"
+ if use amd64; then
+ BIT="64bit-" PAT="1234"
+ fi
+
+ if kernel_is ge 2 6 31 ; then
+ PAT="${PAT}67"
+ fi
+
+ rpm_unpack "${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-suse[0-9][0-9]-${BIT}[0-9].[0-9]*-[0-9]*.tar.gz
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[${PAT}]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+
+ if kernel_is ge 2 6 34 ; then
+ epatch "${FILESDIR}"/fcpci-kernel-2.6.34.patch
+ fi
+
+ if kernel_is ge 2 6 39 ; then
+ if use amd64; then
+ epatch "${FILESDIR}"/fcpci-kernel-2.6.39-amd64.patch
+ else
+ epatch "${FILESDIR}"/fcpci-kernel-2.6.39.patch
+ fi
+ fi
+
+ if kernel_is ge 3 2 0 ; then
+ epatch "${FILESDIR}"/fcpci-kernel-3.2.0.patch
+ fi
+
+ convert_to_m src/Makefile
+
+ for i in lib/*-lib.o; do
+ einfo "Localize symbols in ${i##*/} ..."
+ objcopy -L memcmp -L memcpy -L memmove -L memset -L strcat \
+ -L strcmp -L strcpy -L strlen -L strncmp -L strncpy "${i}"
+ done
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc CAPI*.txt
+ dohtml *.html
+}
diff --git a/net-dialup/fcpci/files/fcpci-kernel-3.2.0.patch b/net-dialup/fcpci/files/fcpci-kernel-3.2.0.patch
new file mode 100644
index 0000000..45b9b09
--- /dev/null
+++ b/net-dialup/fcpci/files/fcpci-kernel-3.2.0.patch
@@ -0,0 +1,10 @@
+--- fritz/src/driver.c_old 2012-01-10 17:10:26.000000000 +0100
++++ fritz/src/driver.c 2012-01-10 17:10:35.000000000 +0100
+@@ -28,6 +28,7 @@
+ #include <linux/ioport.h>
+ #include <linux/sched.h>
+ #include <linux/interrupt.h>
++#include <linux/export.h>
+ #include <linux/spinlock.h>
+ #include <linux/netdevice.h>
+ #include <linux/skbuff.h>