summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Ulyanov <disinbox@gmail.com>2019-11-09 12:43:52 +0300
committerIgor Ulyanov <disinbox@gmail.com>2020-01-05 13:18:42 +0300
commit183a5d03c4f4d58ae1e05a8fa77582882a4eecea (patch)
treec77c26dbf7185a3384c1575aed60a58d24c4aa2f
parentinstall-enabled patch (diff)
downloaddisplacer-183a5d03c4f4d58ae1e05a8fa77582882a4eecea.tar.gz
displacer-183a5d03c4f4d58ae1e05a8fa77582882a4eecea.tar.bz2
displacer-183a5d03c4f4d58ae1e05a8fa77582882a4eecea.zip
install headers
Signed-off-by: Igor Ulyanov <disinbox@gmail.com>
-rw-r--r--dev-libs/openxlsx/files/install-headers.patch28
-rw-r--r--dev-libs/openxlsx/openxlsx-9999.ebuild4
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-libs/openxlsx/files/install-headers.patch b/dev-libs/openxlsx/files/install-headers.patch
new file mode 100644
index 0000000..04c421b
--- /dev/null
+++ b/dev-libs/openxlsx/files/install-headers.patch
@@ -0,0 +1,28 @@
+From 0707b750c5d922ce5b835d00ba247101723373b7 Mon Sep 17 00:00:00 2001
+From: Igor Ulyanov <disinbox@gmail.com>
+Date: Sat, 9 Nov 2019 13:35:53 +0300
+Subject: [PATCH] install headers
+
+---
+ library/openxlsx/CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/library/openxlsx/CMakeLists.txt b/library/openxlsx/CMakeLists.txt
+index be94a6b..4577658 100644
+--- a/library/openxlsx/CMakeLists.txt
++++ b/library/openxlsx/CMakeLists.txt
+@@ -210,7 +210,10 @@ file(REMOVE_RECURSE ${OPENXLSX_INSTALLDIR}/include/)
+ file(COPY ${CMAKE_CURRENT_LIST_DIR}/interfaces/c++/headers/ DESTINATION ${OPENXLSX_INSTALLDIR}/include/OpenXLSX)
+ file(COPY ${CMAKE_CURRENT_BINARY_DIR}/openxlsx_export.h DESTINATION ${OPENXLSX_INSTALLDIR}/include/OpenXLSX)
+
+-
++set(OPENXLSX_HEADERS
++ ${OPENXLSX_CXX_INTERFACE_HEADERS}
++ ${CMAKE_CURRENT_BINARY_DIR}/openxlsx_export.h
++ )
+
+ #=======================================================================================================================
+ # Install OpenXLSX Library
+--
+2.23.0
+
diff --git a/dev-libs/openxlsx/openxlsx-9999.ebuild b/dev-libs/openxlsx/openxlsx-9999.ebuild
index e8100a7..8fea393 100644
--- a/dev-libs/openxlsx/openxlsx-9999.ebuild
+++ b/dev-libs/openxlsx/openxlsx-9999.ebuild
@@ -18,6 +18,8 @@ RDEPEND="dev-libs/pugixml
dev-libs/libzip"
DEPEND=""
-PATCHES="${FILESDIR}/install-enabled.patch"
+PATCHES=("${FILESDIR}/install-enabled.patch"
+ "${FILESDIR}/install-headers.patch"
+ )
EGIT_REPO_URI="https://github.com/troldal/OpenXLSX.git"