summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Ulyanov <disinbox@gmail.com>2014-08-02 15:16:14 +0400
committerIgor Ulyanov <disinbox@gmail.com>2014-08-02 15:16:14 +0400
commit1bfd7109aee14d51da614354f9dec7800801f8eb (patch)
treeece935b6d48cacde0897329022bb428dfe911db8
parentMerge branch 'master' of git+ssh://git.overlays.gentoo.org/user/displacer (diff)
downloaddisplacer-1bfd7109aee14d51da614354f9dec7800801f8eb.tar.gz
displacer-1bfd7109aee14d51da614354f9dec7800801f8eb.tar.bz2
displacer-1bfd7109aee14d51da614354f9dec7800801f8eb.zip
tox-core added
-rw-r--r--net-im/tox-core/Manifest1
-rw-r--r--net-im/tox-core/tox-core-20131029.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/tox-core/Manifest b/net-im/tox-core/Manifest
new file mode 100644
index 0000000..947ee20
--- /dev/null
+++ b/net-im/tox-core/Manifest
@@ -0,0 +1 @@
+EBUILD tox-core-20131029.ebuild 1283 SHA256 40f31fc0508fb617a560fcfb2c72ed9179fe4541ecb7f1c1e355f10a33b83634 SHA512 6ed850cbdfa5eaf62f0d01c9d8c8e8e15ba56ccb3775d7542439c16db6e88d8075fe2673c4b5eaac32337f9236271b030d20114560064280f2fb5fe03331e6d3 WHIRLPOOL 7730857757c1a10f679656fbbcb575be3d817d07cc706177c133e2c5a2e194b0b604dd68680f8c389f3fac82fd66b1bc1f10782b6d06efa949f56b1d9eaf8fcc
diff --git a/net-im/tox-core/tox-core-20131029.ebuild b/net-im/tox-core/tox-core-20131029.ebuild
new file mode 100644
index 0000000..82eecfa
--- /dev/null
+++ b/net-im/tox-core/tox-core-20131029.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit autotools flag-o-matic git-r3 multilib
+
+DESCRIPTION="Free as in freedom Skype replacement"
+HOMEPAGE="http://tox.im/"
+EGIT_REPO_URI="git://github.com/irungentoo/ProjectTox-Core.git
+ https://github.com/irungentoo/ProjectTox-Core.git"
+EGIT_COMMIT="e2e168920960632a6e908ab02c1cd3b4510093cd"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="-nacl ncurses server +sodium static-libs test"
+REQUIRED_USE="^^ ( nacl sodium )"
+
+RDEPEND="virtual/ffmpeg
+ nacl? ( virtual/nacl )
+ ncurses? ( sys-libs/ncurses )
+ sodium? ( dev-libs/libsodium )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+DOCS="README.md"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf \
+ $(use_enable nacl) \
+ $(use_enable server dht-bootstrap-daemon) \
+ $(use_enable test tests) \
+ $(use_enable ncurses ntox) \
+ $(use_enable static-libs static) \
+ --with-nacl-headers=/usr/include/nacl \
+ --with-nacl-libs=/usr/$(get_libdir)/nacl
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
+
+pkg_postinst() {
+ elog "DHT node list is available via https://gist.github.com/Proplex/6124860"
+ elog "or in #tox @ irc.freenode.org"
+}