summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Ulyanov <disinbox@gmail.com>2023-10-17 19:33:50 +0300
committerIgor Ulyanov <disinbox@gmail.com>2024-03-13 19:56:18 +0300
commit25bd9ea42afce0d3c01168b1b08ee0ffca6b96cf (patch)
tree8e700482652f3a88cae6186ed869df9bbc1de22d
parentnew mailio ebuild (diff)
downloaddisplacer-25bd9ea42afce0d3c01168b1b08ee0ffca6b96cf.tar.gz
displacer-25bd9ea42afce0d3c01168b1b08ee0ffca6b96cf.tar.bz2
displacer-25bd9ea42afce0d3c01168b1b08ee0ffca6b96cf.zip
tgbot-cpp added
Signed-off-by: Igor Ulyanov <disinbox@gmail.com>
-rw-r--r--dev-cpp/tgbot-cpp/Manifest4
-rw-r--r--dev-cpp/tgbot-cpp/tgbot-cpp-1.6.ebuild33
-rw-r--r--dev-cpp/tgbot-cpp/tgbot-cpp-1.7.2.ebuild33
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-cpp/tgbot-cpp/Manifest b/dev-cpp/tgbot-cpp/Manifest
new file mode 100644
index 0000000..0749ee7
--- /dev/null
+++ b/dev-cpp/tgbot-cpp/Manifest
@@ -0,0 +1,4 @@
+DIST tgbot-cpp-1.6.tar.gz 158699 BLAKE2B 50965c6fc65e78663a044ad359227200a3dc83768c7560c1d84bef05bfedfd080dd65a132dd33020196696d8233af48cbaeb5bd4e07c01e6baed4fe3d0421fea SHA512 c7dd9efb1b0edfe34de06205ed26ad076d0e61a48be22df440290478ab55917c7d926af0ea7d1c76b82b5859f4f2454217feb6dc5b7c7680e6f6177f063242a0
+DIST tgbot-cpp-1.7.2.tar.gz 162819 BLAKE2B ea03a962089eba0c52abc1ced72fce521cb4f25c5c6a19fff1f6b5ceb3e9e7b37cf4cf016d3c9aae53a7b7958fd3b387a5bb871a67316ddc89a9e84a258f691a SHA512 44f16e2cef6ea6407f6a707885734cd0e850d89553a35c12b63c0864ea952377f07553c9cbf5ee464a1e8390723cd9fff867caafa725c97612a664d13ca87ec1
+EBUILD tgbot-cpp-1.6.ebuild 748 BLAKE2B eb5341b9ece666355b8bfaad51b5c4b40253b998227e2f7e83738170e7ede0d46e88f53b1aa8307bd8e6ef67ca105a49234f85a86e5cebbdc612f7b7d3f2b8a8 SHA512 332f66c1cf71d5061549ef37bdd20848cbcce7ea7ca94768b3b4d2df883c3afe503d077a5cc78c3d663bf128bfb62d61ebea32d9c402ae4d3b110972a5135630
+EBUILD tgbot-cpp-1.7.2.ebuild 748 BLAKE2B eb5341b9ece666355b8bfaad51b5c4b40253b998227e2f7e83738170e7ede0d46e88f53b1aa8307bd8e6ef67ca105a49234f85a86e5cebbdc612f7b7d3f2b8a8 SHA512 332f66c1cf71d5061549ef37bdd20848cbcce7ea7ca94768b3b4d2df883c3afe503d077a5cc78c3d663bf128bfb62d61ebea32d9c402ae4d3b110972a5135630
diff --git a/dev-cpp/tgbot-cpp/tgbot-cpp-1.6.ebuild b/dev-cpp/tgbot-cpp/tgbot-cpp-1.6.ebuild
new file mode 100644
index 0000000..de8d848
--- /dev/null
+++ b/dev-cpp/tgbot-cpp/tgbot-cpp-1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ library for Telegram bot API"
+HOMEPAGE="https://github.com/reo7sp/tgbot-cpp"
+SRC_URI="https://github.com/reo7sp/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+shared doc test"
+RESTRICT="mirror !test? ( test )"
+
+DEPEND="
+ sys-libs/zlib
+ dev-libs/openssl
+ >=net-misc/curl-7.56.0
+ >=dev-libs/boost-1.59.0"
+RDEPEND="${DEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_TESTS=$(usex test ON OFF)
+ -DBUILD_SHARED_LIBS=$(usex shared ON OFF)
+ -DBUILD_DOCUMENTATION=$(usex doc ON OFF)
+ )
+ cmake_src_configure
+}
diff --git a/dev-cpp/tgbot-cpp/tgbot-cpp-1.7.2.ebuild b/dev-cpp/tgbot-cpp/tgbot-cpp-1.7.2.ebuild
new file mode 100644
index 0000000..de8d848
--- /dev/null
+++ b/dev-cpp/tgbot-cpp/tgbot-cpp-1.7.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ library for Telegram bot API"
+HOMEPAGE="https://github.com/reo7sp/tgbot-cpp"
+SRC_URI="https://github.com/reo7sp/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+shared doc test"
+RESTRICT="mirror !test? ( test )"
+
+DEPEND="
+ sys-libs/zlib
+ dev-libs/openssl
+ >=net-misc/curl-7.56.0
+ >=dev-libs/boost-1.59.0"
+RDEPEND="${DEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_TESTS=$(usex test ON OFF)
+ -DBUILD_SHARED_LIBS=$(usex shared ON OFF)
+ -DBUILD_DOCUMENTATION=$(usex doc ON OFF)
+ )
+ cmake_src_configure
+}