summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/libv8-juice/libv8-juice-20101126.ebuild')
-rw-r--r--dev-lang/libv8-juice/libv8-juice-20101126.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-lang/libv8-juice/libv8-juice-20101126.ebuild b/dev-lang/libv8-juice/libv8-juice-20101126.ebuild
new file mode 100644
index 0000000..8f9ccf9
--- /dev/null
+++ b/dev-lang/libv8-juice/libv8-juice-20101126.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="C++ toolkit for extending the Google v8 JavaScript engine"
+HOMEPAGE="http://code.google.com/p/v8-juice/"
+SRC_URI="http://v8-juice.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/v8"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf
+}
+
+src_prepare() {
+ mkdir doc/doxygen
+ echo -e "install:\n\ttrue" > doc/doxygen/Makefile # little work around
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}