summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/cpp-netlib/cpp-netlib-0.9.4.ebuild')
-rw-r--r--net-libs/cpp-netlib/cpp-netlib-0.9.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/cpp-netlib/cpp-netlib-0.9.4.ebuild b/net-libs/cpp-netlib/cpp-netlib-0.9.4.ebuild
new file mode 100644
index 0000000..cdc73da
--- /dev/null
+++ b/net-libs/cpp-netlib/cpp-netlib-0.9.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools cmake-utils
+
+DESCRIPTION="The ${PN} is a library that provides application layer protocol support using modern C++ techniques."
+HOMEPAGE="http://cpp-netlib.github.com/"
+SRC_URI="https://github.com/downloads/${PN}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND="dev-libs/boost"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/0001-cmake-fixes.patch
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ # emake DESTDIR="${D}" install || die "install failed"
+ mkdir -p "${D}"/usr/include/boost
+ cp -r boost/* "${D}"/usr/include/boost/
+ mkdir -p "${D}"/usr/lib64
+ cp ${CMAKE_BUILD_DIR}/libs/network/src/*.so "${D}"/usr/lib64/
+}