summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon <russ@eatnumber1.com>2009-12-31 18:48:31 -0500
committerRussell Harmon <russ@eatnumber1.com>2009-12-31 18:48:31 -0500
commit869e1183f464dab5013419a2bf7915c0836feb22 (patch)
tree695e17845ea5be83e27d4c7abf073b87029596ab
parentFix bugs in xdotool and keynav ebuilds. (diff)
downloadeatnumber1-869e1183f464dab5013419a2bf7915c0836feb22.tar.gz
eatnumber1-869e1183f464dab5013419a2bf7915c0836feb22.tar.bz2
eatnumber1-869e1183f464dab5013419a2bf7915c0836feb22.zip
Remove old ebuilds.
-rw-r--r--app-emulation/crossover-games-bin/crossover-games-bin-7.1.2.ebuild48
-rw-r--r--net-fs/mount-cifs/files/user-unmount-ioctl-fix-bug4784.diff23
-rw-r--r--net-fs/mount-cifs/mount-cifs-3.0.28.ebuild40
-rw-r--r--net-misc/dhcp-fwd/dhcp-fwd-0.8.ebuild57
-rw-r--r--net-misc/dhcp-fwd/files/dhcp-fwd-0.8-gentoo.patch24
-rw-r--r--net-misc/dhcp-fwd/files/dhcp-fwd.confd6
-rw-r--r--net-misc/dhcp-fwd/files/dhcp-fwd.initd22
-rw-r--r--sys-block/compcache/compcache-0.3.ebuild47
-rw-r--r--sys-block/compcache/compcache-9999.ebuild42
9 files changed, 0 insertions, 309 deletions
diff --git a/app-emulation/crossover-games-bin/crossover-games-bin-7.1.2.ebuild b/app-emulation/crossover-games-bin/crossover-games-bin-7.1.2.ebuild
deleted file mode 100644
index 0baf12e..0000000
--- a/app-emulation/crossover-games-bin/crossover-games-bin-7.1.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit eutils
-
-DESCRIPTION="simplified/streamlined version of wine geared towards games"
-HOMEPAGE="http://www.codeweavers.com/products/cxgames/"
-SRC_URI="install-crossover-games-${PV}.sh"
-
-LICENSE="CROSSOVER"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE="nas"
-RESTRICT="fetch strip"
-
-RDEPEND="sys-libs/glibc
- x11-libs/libXrandr
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXxf86dga
- x11-libs/libXxf86vm
- dev-util/desktop-file-utils
- nas? ( media-libs/nas )
- amd64? ( app-emulation/emul-linux-x86-xlibs )"
-
-S=${WORKDIR}
-
-pkg_nofetch() {
- einfo "Please visit ${HOMEPAGE}"
- einfo "and place ${A} in ${DISTDIR}"
-}
-
-src_unpack() {
- unpack_makeself
-}
-
-src_install() {
- dodir /opt/cxgames
- cp -r * "${D}"/opt/cxgames || die "cp failed"
- rm -r "${D}"/opt/cxgames/setup.{sh,data}
- insinto /opt/cxgames/etc
- doins share/crossover/data/cxgames.conf
-}
-
-pkg_postinst() {
- elog "Run /opt/cxgames/bin/cxsetup as normal user to create"
- elog "bottles and install Windows applications."
-}
diff --git a/net-fs/mount-cifs/files/user-unmount-ioctl-fix-bug4784.diff b/net-fs/mount-cifs/files/user-unmount-ioctl-fix-bug4784.diff
deleted file mode 100644
index 7be08ff..0000000
--- a/net-fs/mount-cifs/files/user-unmount-ioctl-fix-bug4784.diff
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Jeremy Allison <jra@samba.org>
-Date: Thu, 13 Dec 2007 02:45:20 +0000 (-0800)
-Subject: Fix bug #4784. Patch from Steve Langasek <vorlon@debian.org>.
-X-Git-Url: http://gitweb.samba.org/?p=samba.git;a=commitdiff_plain;h=244230eb619c6699e962bb24f8f6e4dd2a1235c7
-
-Fix bug #4784. Patch from Steve Langasek <vorlon@debian.org>.
-Jeremy.
----
-
-diff --git a/source/client/umount.cifs.c b/source/client/umount.cifs.c
-index 47ddd1e..70829eb 100644
---- a/source/client/umount.cifs.c
-+++ b/source/client/umount.cifs.c
-@@ -131,7 +131,7 @@ static int umount_check_perm(char * dir)
- printf("user unmounting via %s is an optional feature of",thisprogram);
- printf(" the cifs filesystem driver (cifs.ko)");
- printf("\n\tand requires cifs.ko version 1.32 or later\n");
-- } else if (rc > 0)
-+ } else if (rc != 0)
- printf("user unmount of %s failed with %d %s\n",dir,errno,strerror(errno));
- close(fileid);
-
-
diff --git a/net-fs/mount-cifs/mount-cifs-3.0.28.ebuild b/net-fs/mount-cifs/mount-cifs-3.0.28.ebuild
deleted file mode 100644
index 46d7acf..0000000
--- a/net-fs/mount-cifs/mount-cifs-3.0.28.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/mount-cifs/mount-cifs-3.0.28.ebuild,v 1.6 2008/02/01 14:07:27 armin76 Exp $
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="cifs filesystem mount helper split from Samba"
-HOMEPAGE="http://linux-cifs.samba.org/cifs/cifs_download.html"
-SRC_URI="http://dev.gentooexperimental.org/~jakub/distfiles/${P}.tar.bz2
- mirror://gentoo/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="suid"
-
-DEPEND="!<net-fs/samba-3.0.25"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/user-unmount-ioctl-fix-bug4784.diff
-}
-
-src_compile() {
- cd "${S}/source/client"
- $(tc-getCC) ${CFLAGS} mount.cifs.c -o mount.cifs || die "make mount.cifs failed"
- $(tc-getCC) ${CFLAGS} umount.cifs.c -o umount.cifs || die "make umount.cifs failed"
-}
-
-src_install() {
- dobin source/client/{mount,umount}.cifs
- dosym /usr/bin/mount.cifs /sbin/mount.cifs
-
- docinto html
- dohtml docs/htmldocs/*
- doman docs/manpages/{mount,umount}.cifs.8
-
- use suid && chmod u+s "${D}/${PREFIX}"/usr/bin/{mount,umount}.cifs
-}
diff --git a/net-misc/dhcp-fwd/dhcp-fwd-0.8.ebuild b/net-misc/dhcp-fwd/dhcp-fwd-0.8.ebuild
deleted file mode 100644
index d5a0368..0000000
--- a/net-misc/dhcp-fwd/dhcp-fwd-0.8.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils
-
-MY_PN="dhcp-forwarder-${PV}"
-DESCRIPTION="Forwards DHCP messages between subnets with different sublayer broadcast domains"
-HOMEPAGE="http://www.nongnu.org/dhcp-fwd/"
-SRC_URI="http://savannah.nongnu.org/download/${PN}/${MY_PN}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="diet logging"
-RESTRICT="primaryuri"
-
-DEPEND="diet? ( dev-libs/dietlibc )"
-
-S="${WORKDIR}/${PSRC}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-gentoo.patch"
-}
-
-pkg_setup() {
- enewgroup dhcp-fwd
- enewuser dhcp-fwd -1 -1 -1 dhcp-fwd
-}
-
-src_compile() {
- local myconf="--target=${CHOST}"
-
- #prefers dietlibc by default
- if ! use diet ; then
- myconf="${myconf} --disable-dietlibc"
- fi
-
- if use logging ; then
- myconf="${myconf} --enable-logging"
- fi
-
- econf ${myconf} || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- newinitd "${FILESDIR}/dhcp-fwd.initd" dhcp-fwd
- newconfd "${FILESDIR}/dhcp-fwd.confd" dhcp-fwd
- insinto /etc
- newins contrib/dhcp-fwd.conf dhcp-fwd.conf
-}
-
-
diff --git a/net-misc/dhcp-fwd/files/dhcp-fwd-0.8-gentoo.patch b/net-misc/dhcp-fwd/files/dhcp-fwd-0.8-gentoo.patch
deleted file mode 100644
index ab0946a..0000000
--- a/net-misc/dhcp-fwd/files/dhcp-fwd-0.8-gentoo.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- dhcp-fwd-0.8-orig/contrib/dhcp-fwd.conf 2008-12-30 04:26:22.000000000 -0600
-+++ dhcp-fwd-0.8/contrib/dhcp-fwd.conf 2009-05-14 23:51:27.000000000 -0500
-@@ -29,18 +29,18 @@
- group dhcp-fwd
-
- ## chroot() path
--chroot /var/lib/dhcp-fwd
-+chroot /chroot/dhcp-fwd
-
- ## Logfile and loglevel. The logfile-location is relatively to the
- ## directory where dhcp-fwd was started and not to the chroot-directory.
- ##
- ## The loglevel option is not supported yet.
- logfile /var/log/dhcp-fwd.log
--loglevel 1
-+#loglevel 1
-
- ## SysV pidfile; contains the PID of the daemon-process and will be
- ## written with root-privileges
--pidfile /var/run/dhcp-fwd.pid
-+pidfile $PIDFILE
-
-
- ## Set limit for resources. When using much interfaces or servers
diff --git a/net-misc/dhcp-fwd/files/dhcp-fwd.confd b/net-misc/dhcp-fwd/files/dhcp-fwd.confd
deleted file mode 100644
index 8f03671..0000000
--- a/net-misc/dhcp-fwd/files/dhcp-fwd.confd
+++ /dev/null
@@ -1,6 +0,0 @@
-# /etc/conf.d/dhcp-fwd: config file for /etc/init.d/dhcp-fwd
-
-CONFIG=/etc/dhcp-fwd.conf
-
-PIDFILE=/var/run/dhcp-fwd.pid
-
diff --git a/net-misc/dhcp-fwd/files/dhcp-fwd.initd b/net-misc/dhcp-fwd/files/dhcp-fwd.initd
deleted file mode 100644
index 0f64901..0000000
--- a/net-misc/dhcp-fwd/files/dhcp-fwd.initd
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting dhcp-fwd"
- export PIDFILE=${PIDFILE}
- /usr/sbin/dhcp-fwd -c ${CONFIG}
- eend $?
-}
-
-stop() {
- ebegin "Stopping dhcp-fwd"
- start-stop-daemon --stop --quiet --pidfile ${PIDFILE}
- eend $?
-}
diff --git a/sys-block/compcache/compcache-0.3.ebuild b/sys-block/compcache/compcache-0.3.ebuild
deleted file mode 100644
index 4800fa5..0000000
--- a/sys-block/compcache/compcache-0.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils linux-mod
-
-MY_PV=${PV/_/}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="RAM based block device which acts as swap disk."
-HOMEPAGE="http://code.google.com/p/compcache"
-SRC_URI="http://compcache.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="GPL"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-S="${WORKDIR}/$MY_P"
-
-DEPEND=""
-
-MODULE_NAMES="compcache(block/compcache)"
-
-BUILD_TARGETS="all"
-
-pkg_setup() {
- get_version
-
- if ! linux_chkconfig_present LZO_COMPRESS; then
- MODULE_NAMES="lzo1x_compress(block/compcache:${S}/sub-projects/compression/lzo-kmod) ${MODULE_NAMES}"
- fi
-
- if ! linux_chkconfig_present LZO_DECOMPRESS; then
- MODULE_NAMES="lzo1x_decompress(block/compcache:${S}/sub-projects/compression/lzo-kmod) ${MODULE_NAMES}"
- fi
-
- if ! linux_chkconfig_present TLSF; then
- MODULE_NAMES="tlsf(block/compcache:${S}/sub-projects/allocators/tlsf-kmod ${MODULE_NAMES}"
- fi
-
- linux-mod_pkg_setup
-}
-
-src_install() {
- dodoc ${S}/README
- linux-mod_src_install
-}
diff --git a/sys-block/compcache/compcache-9999.ebuild b/sys-block/compcache/compcache-9999.ebuild
deleted file mode 100644
index 590404f..0000000
--- a/sys-block/compcache/compcache-9999.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils toolchain-funcs linux-mod subversion
-
-DESCRIPTION="RAM based block device which acts as swap disk."
-HOMEPAGE="http://code.google.com/p/compcache"
-ESVN_REPO_URI="http://compcache.googlecode.com/svn/trunk/"
-
-LICENSE="GPL"
-IUSE=""
-
-S="${WORKDIR}/$MY_P"
-
-DEPEND=""
-
-MODULE_NAMES="compcache(block/compcache)"
-
-BUILD_TARGETS="all"
-
-pkg_setup() {
- get_version
- if ! linux_chkconfig_present LZO_COMPRESS; then
- MODULE_NAMES="lzo1x_compress(block/compcache:${S}/sub-projects/compression/lzo-kmod) ${MODULE_NAMES}"
- fi
-
- if ! linux_chkconfig_present LZO_DECOMPRESS; then
- MODULE_NAMES="lzo1x_decompress(block/compcache:${S}/sub-projects/compression/lzo-kmod) ${MODULE_NAMES}"
- fi
-
- if ! linux_chkconfig_present TLSF; then
- MODULE_NAMES="tlsf(block/compcache:${S}/sub-projects/allocators/tlsf-kmod ${MODULE_NAMES}"
- fi
-
- linux-mod_pkg_setup
-}
-
-src_install() {
- dodoc ${S}/README
- linux-mod_src_install
-}