summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon <russ@eatnumber1.com>2009-12-14 18:39:40 -0500
committerRussell Harmon <russ@eatnumber1.com>2009-12-14 18:39:40 -0500
commitb2d3b883dd9475d40cfe87a59ae48a1a6e5d444b (patch)
treebf44f0f05ca768e0bc00b1e60b859f3c5d268822 /dev-libs
parentDelete manifests (diff)
downloadeatnumber1-b2d3b883dd9475d40cfe87a59ae48a1a6e5d444b.tar.gz
eatnumber1-b2d3b883dd9475d40cfe87a59ae48a1a6e5d444b.tar.bz2
eatnumber1-b2d3b883dd9475d40cfe87a59ae48a1a6e5d444b.zip
Remove idea and arch ebuilds
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/arch/arch-2.5a.ebuild35
-rw-r--r--dev-libs/arch/files/Makefile.am9
-rw-r--r--dev-libs/arch/files/arch.pc.in10
-rw-r--r--dev-libs/arch/files/arch_autotools.patch12
-rw-r--r--dev-libs/arch/files/arch_gcc.patch351
-rw-r--r--dev-libs/arch/files/configure.ac15
6 files changed, 0 insertions, 432 deletions
diff --git a/dev-libs/arch/arch-2.5a.ebuild b/dev-libs/arch/arch-2.5a.ebuild
deleted file mode 100644
index dd71169..0000000
--- a/dev-libs/arch/arch-2.5a.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit eutils autotools
-
-DESCRIPTION="RIT's computer architecture simulation library."
-HOMEPAGE=""
-SRC_URI="http://www.cs.rit.edu/~icsg720/pub/misc/${PN}${PV/./-}.tar.gz"
-
-LICENSE=""
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}_autotools.patch"
- epatch "${FILESDIR}/${PN}_gcc.patch"
- cp "${FILESDIR}/Makefile.am" .
- cp "${FILESDIR}/configure.ac" .
- cp "${FILESDIR}/${PN}.pc.in" .
- rm "Makefile"
- eautoreconf || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-}
diff --git a/dev-libs/arch/files/Makefile.am b/dev-libs/arch/files/Makefile.am
deleted file mode 100644
index 59e9a0d..0000000
--- a/dev-libs/arch/files/Makefile.am
+++ /dev/null
@@ -1,9 +0,0 @@
-AUTOMAKE_OPTIONS = foreign
-
-lib_LTLIBRARIES = libarch.la
-libarch_la_SOURCES = ArchLibError.C Bus.C BusALU.C COSet.C CPUObject.C Clearable.C Clock.C ClockedObject.C Connector.C Constant.C Counter.C Flow.C FlowSet.C InFlow.C Memory.C OutFlow.C PseudoInput.C PseudoOutput.C ShiftRegister.C StorageObject.C
-libarch_la_LDFLAGS = -release @VERSION@
-include_HEADERS = ArchLibError.h Bus.h BusALU.h COSet.h CPUObject.h Clearable.h Clock.h ClockedObject.h Connector.h Constant.h Counter.h Flow.h FlowSet.h InFlow.h Memory.h OutFlow.h PseudoInput.h PseudoOutput.h ShiftRegister.h StorageObject.h
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = arch.pc
diff --git a/dev-libs/arch/files/arch.pc.in b/dev-libs/arch/files/arch.pc.in
deleted file mode 100644
index 4ded19e..0000000
--- a/dev-libs/arch/files/arch.pc.in
+++ /dev/null
@@ -1,10 +0,0 @@
-prefix=@prefix@
-exec_prefix=@exec_prefix@
-libdir=@libdir@
-includedir=@includedir@
-
-Name: arch
-Description: RIT's computer architecture simulation library.
-Version: @VERSION@
-Libs: -L${libdir} -larch
-Cflags: -I${includedir}
diff --git a/dev-libs/arch/files/arch_autotools.patch b/dev-libs/arch/files/arch_autotools.patch
deleted file mode 100644
index 7a628f5..0000000
--- a/dev-libs/arch/files/arch_autotools.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Only in b: Makefile.am
-diff -ur a/Version.h b/Version.h
---- a/Version.h 2009-03-25 03:59:43.552211345 -0400
-+++ b/Version.h 2009-03-25 04:00:48.130243022 -0400
-@@ -12,6 +12,4 @@
-
- using namespace std;
-
--const char * VERSION = "2.5a";
--
- #endif
-Only in b: configure.ac
diff --git a/dev-libs/arch/files/arch_gcc.patch b/dev-libs/arch/files/arch_gcc.patch
deleted file mode 100644
index 0f29469..0000000
--- a/dev-libs/arch/files/arch_gcc.patch
+++ /dev/null
@@ -1,351 +0,0 @@
-diff -ur a/Bus.C b/Bus.C
---- a/Bus.C 2003-12-04 12:03:18.000000000 -0500
-+++ b/Bus.C 2009-03-25 03:57:45.885211654 -0400
-@@ -13,8 +13,8 @@
- using namespace std;
-
- Bus::Bus( const char *id, int numbits ):
-- Connector(id,numbits),
- CPUObject(id,numbits),
-+ Connector(id,numbits),
- input(id,numbits),
- output(id,numbits,*this) {
- }
-diff -ur a/BusALU.C b/BusALU.C
---- a/BusALU.C 2003-12-04 12:05:42.000000000 -0500
-+++ b/BusALU.C 2009-03-25 03:57:45.885211654 -0400
-@@ -17,8 +17,8 @@
- using namespace std;
-
- CarryConnector::CarryConnector( const char *id, BusALU &b ):
-- Connector(id,1),
- CPUObject(id,1),
-+ Connector(id,1),
- busALU(b),
- carry("Carry",1,*this) {
- }
-@@ -32,8 +32,8 @@
- }
-
- OverflowConnector::OverflowConnector( const char *id, BusALU &b ):
-- Connector(id,1),
- CPUObject(id,1),
-+ Connector(id,1),
- busALU(b),
- overflow("Overflow",1,*this) {
- }
-@@ -53,7 +53,7 @@
- };
-
- BusALU::BusALU( const char *id, int numbits ):
-- Connector(id,numbits), CPUObject(id,numbits),
-+ CPUObject(id,numbits), Connector(id,numbits),
- op1("OP1",numbits), op2("OP2",numbits),
- result("Result",numbits,*this), operation(op_none),
- carryConnector("Carry",*this),
-@@ -342,7 +342,7 @@
- unsigned long signBit = x & (1 << (get_bits()-1));
- unsigned long sh = (unsigned long)op2Copy;
-
-- for( long i=0; i<sh; i++ )
-+ for( unsigned long i=0; i<sh; i++ )
- x = (x >> 1) | signBit;
-
- value = x;
-diff -ur a/BusALU.h b/BusALU.h
---- a/BusALU.h 2003-12-04 12:05:42.000000000 -0500
-+++ b/BusALU.h 2009-03-25 03:57:45.888210663 -0400
-@@ -68,9 +68,9 @@
- ~CarryConnector();
-
- long computeValue();
-- OutFlow carry;
--
- BusALU &busALU;
-+
-+ OutFlow carry;
- };
-
- class OverflowConnector: public Connector {
-@@ -82,9 +82,9 @@
- ~OverflowConnector();
-
- long computeValue();
-- OutFlow overflow;
--
- BusALU &busALU;
-+
-+ OutFlow overflow;
- };
-
- class BusALU : public Connector {
-@@ -138,10 +138,10 @@
- void rshiftFunction();
- void rashiftFunction();
-
-- Operation operation;
- InFlow op1;
- InFlow op2;
- OutFlow result;
-+ Operation operation;
- friend class CarryConnector;
- CarryConnector carryConnector;
- friend class OverflowConnector;
-diff -ur a/CPUObject.C b/CPUObject.C
---- a/CPUObject.C 2003-12-04 12:04:08.000000000 -0500
-+++ b/CPUObject.C 2009-03-25 03:57:45.886211743 -0400
-@@ -64,7 +64,7 @@
- cout << "Object " << myName << " created\n";
- }
-
-- if( (numBits<1) || (numBits > (8*sizeof(long))) ) {
-+ if( (numBits<1) || (numBits > (int)(8*sizeof(long))) ) {
- cout << id << ": " << numBits << " bits is out of range\n";
- throw ArchLibError( "CPUObject size out of range" );
- }
-diff -ur a/CPUObject.h b/CPUObject.h
---- a/CPUObject.h 2009-03-25 03:59:43.551211326 -0400
-+++ b/CPUObject.h 2009-03-25 03:57:45.888210663 -0400
-@@ -59,17 +59,17 @@
- trace_ticks = 16 };
-
- static int debug;
-+ void set_name( const char *id );
-
- protected:
- int get_bits() const;
- unsigned long get_mask() const;
- void set_mask( unsigned long m );
-- void set_name( const char *id );
-
- private:
-- char *myName;
--
- int bits;
-+
-+ char *myName;
- unsigned long mask; // mask representing above data (right-justified)
-
- private:
-diff -ur a/Clearable.C b/Clearable.C
---- a/Clearable.C 2003-12-04 12:04:08.000000000 -0500
-+++ b/Clearable.C 2009-03-25 03:57:45.886211743 -0400
-@@ -18,8 +18,8 @@
- using namespace std;
-
- Clearable::Clearable ( const char *id, int numBits, long value ):
-- StorageObject(id,numBits,value),
- CPUObject(id,numBits),
-+ StorageObject(id,numBits,value),
- change(none) {
- }
-
-diff -ur a/Clock.C b/Clock.C
---- a/Clock.C 2009-03-25 03:59:43.551211326 -0400
-+++ b/Clock.C 2009-03-25 03:57:45.886211743 -0400
-@@ -54,7 +54,7 @@
- trace2 = CPUObject::debug & CPUObject::trace_ticks;
-
- if( trace1 ) {
-- long old = cout.setf( ios::dec, ios::basefield );
-+ std::_Ios_Fmtflags old = cout.setf( ios::dec, ios::basefield );
- cout << " ________\n_____/" << setw(7) << time
- << " \\_____\n" << flush;
- (void)cout.flags( old );
-diff -ur a/Constant.C b/Constant.C
---- a/Constant.C 2003-12-04 12:03:19.000000000 -0500
-+++ b/Constant.C 2009-03-25 03:57:45.886211743 -0400
-@@ -13,8 +13,8 @@
- using namespace std;
-
- Constant::Constant( const char *id, int numbits, long value ):
-- Connector(id,numbits),
- CPUObject(id,numbits),
-+ Connector(id,numbits),
- output(id,numbits,*this),
- v(value) {
- }
-diff -ur a/Constant.h b/Constant.h
---- a/Constant.h 2003-12-04 12:03:19.000000000 -0500
-+++ b/Constant.h 2009-03-25 03:57:45.888210663 -0400
-@@ -34,8 +34,8 @@
- OutFlow &OUT() { return output; }
-
- private:
-- const long v;
- OutFlow output;
-+ const long v;
- };
-
- #endif
-diff -ur a/Counter.C b/Counter.C
---- a/Counter.C 2003-12-04 12:03:19.000000000 -0500
-+++ b/Counter.C 2009-03-25 03:57:45.886211743 -0400
-@@ -17,8 +17,8 @@
- using namespace std;
-
- Counter::Counter ( const char *id, int numBits, long value ):
-- StorageObject(id,numBits,value),
- CPUObject(id,numBits),
-+ StorageObject(id,numBits,value),
- change(none),
- oflow(0),
- newOflow(0) {
-Only in b: Makefile.am
-diff -ur a/Memory.C b/Memory.C
---- a/Memory.C 2003-12-04 12:08:26.000000000 -0500
-+++ b/Memory.C 2009-03-25 03:57:45.887210994 -0400
-@@ -71,9 +71,9 @@
- bool littleEndian
- // set if LSB is first (e.g., PDP-11)
- ):
-+ CPUObject( id, unitsInDataPath*bitsPerUnit ),
- Connector( id, unitsInDataPath*bitsPerUnit ),
- ClockedObject( id, unitsInDataPath*bitsPerUnit ),
-- CPUObject( id, unitsInDataPath*bitsPerUnit ),
- mar( "MAR", bitsInAddr ),
- writeFlow( "MemoryWrite", unitsInDataPath*bitsPerUnit ),
- readFlow( "MemoryRead", unitsInDataPath*bitsPerUnit, *this ),
-@@ -193,7 +193,7 @@
- break;
-
- case readOp:
-- if( rangeError = (highPoint < lastAddr) ) {
-+ if( ( rangeError = (highPoint < lastAddr) ) ) {
- return 0;
- }
- tempStore = 0;
-@@ -240,7 +240,7 @@
- // lowest address
- tempStore = newValue;
- lastAddr = currentAddr+dataPathWidth-1;
-- if( rangeError = (highPoint < lastAddr) ) {
-+ if( ( rangeError = (highPoint < lastAddr) ) ) {
- return;
- }
-
-diff -ur a/Memory.h b/Memory.h
---- a/Memory.h 2003-12-04 12:07:30.000000000 -0500
-+++ b/Memory.h 2009-03-25 03:57:45.889210473 -0400
-@@ -44,8 +44,8 @@
- void allocate( long sz );
- long get( long index );
- void put( long index, long value );
-- long size;
- long *data;
-+ long size;
- };
-
- class Memory : public Connector, public ClockedObject {
-@@ -99,10 +99,12 @@
- private:
- long computeValue();
-
-- Operation op;
- StorageObject mar;
- InFlow writeFlow;
- OutFlow readFlow;
-+ int unitSize;
-+ int dataPathWidth;
-+ Operation op;
-
- unsigned long currentAddr;
- long newValue;
-@@ -110,11 +112,9 @@
- LongArray mem;
-
- unsigned long highPoint;
-- int unitSize;
- int rangeError;
- unsigned long address_mask;
- unsigned long unit_mask;
-- int dataPathWidth;
-
- int addressFieldWidth;
- int dataFieldWidth;
-diff -ur a/PseudoInput.C b/PseudoInput.C
---- a/PseudoInput.C 2003-12-04 12:04:09.000000000 -0500
-+++ b/PseudoInput.C 2009-03-25 03:57:45.887210994 -0400
-@@ -17,8 +17,8 @@
- using namespace std;
-
- PseudoInput::PseudoInput( const char *id, int numBits ):
-- StorageObject(id,numBits),
- CPUObject(id,numBits),
-+ StorageObject(id,numBits),
- latestTime(-1) {
- }
-
-diff -ur a/PseudoOutput.C b/PseudoOutput.C
---- a/PseudoOutput.C 2003-12-04 12:03:20.000000000 -0500
-+++ b/PseudoOutput.C 2009-03-25 03:57:45.887210994 -0400
-@@ -15,8 +15,8 @@
- using namespace std;
-
- PseudoOutput::PseudoOutput( const char *id, int numBits ):
-- StorageObject(id,numBits),
-- CPUObject(id,numBits) {
-+ CPUObject(id,numBits),
-+ StorageObject(id,numBits) {
- }
-
- PseudoOutput::~PseudoOutput() {
-diff -ur a/ShiftRegister.C b/ShiftRegister.C
---- a/ShiftRegister.C 2003-12-04 12:04:09.000000000 -0500
-+++ b/ShiftRegister.C 2009-03-25 03:57:45.887210994 -0400
-@@ -18,8 +18,8 @@
- using namespace std;
-
- ShiftRegister::ShiftRegister ( const char *id, int numBits, long initVal ) :
-- StorageObject( id, numBits, initVal ),
- CPUObject( id, numBits ),
-+ StorageObject( id, numBits, initVal ),
- change( none ),
- lefterly( 0 ),
- righterly( 0 ) {
-diff -ur a/StorageObject.C b/StorageObject.C
---- a/StorageObject.C 2009-03-25 03:59:43.552211345 -0400
-+++ b/StorageObject.C 2009-03-25 03:57:45.887210994 -0400
-@@ -26,8 +26,8 @@
- using namespace std;
-
- StorageObject::StorageObject ( const char *id, int numBits, long initVal ):
-- ClockedObject( id, numBits ),
- CPUObject( id, numBits ),
-+ ClockedObject( id, numBits ),
- contents( initVal ),
- newContents( initVal ),
- update( 0 ),
-@@ -39,7 +39,7 @@
-
- if( get_contents() != initVal ) {
- // switch to hex, but remember old settings
-- long k = cout.setf( ios::hex, ios::basefield );
-+ std::_Ios_Fmtflags k = cout.setf( ios::hex, ios::basefield );
- cout << "StorageObject " << id
- << ": initial value of " << initVal
- << " does not fit in " << numBits
-diff -ur a/StorageObject.h b/StorageObject.h
---- a/StorageObject.h 2003-12-04 12:07:30.000000000 -0500
-+++ b/StorageObject.h 2009-03-25 03:57:45.889210473 -0400
-@@ -114,16 +114,16 @@
- // is anyone updating my value?
-
- private:
-- OutFlow *newValueSource; // ...if from the outside
- unsigned long contents; // current visible value
-- int update;
- unsigned long newContents; // new value, not yet visible
-+ int update;
-+ FlowSet flows; // to what am I permanently connected?
-+ OutFlow *newValueSource; // ...if from the outside
- // (pre - phase 2)
-
- static int storObjCount;
- static int backDoorUsed;
-
-- FlowSet flows; // to what am I permanently connected?
- };
-
- inline void StorageObject::hello() {
-Only in b: configure.ac
diff --git a/dev-libs/arch/files/configure.ac b/dev-libs/arch/files/configure.ac
deleted file mode 100644
index 7e9f256..0000000
--- a/dev-libs/arch/files/configure.ac
+++ /dev/null
@@ -1,15 +0,0 @@
-AC_INIT(arch,2.5a)
-
-AM_INIT_AUTOMAKE(arch,2.5a)
-
-AC_PROG_CC
-AC_PROG_CXX
-
-AC_PROG_INSTALL
-
-CFLAGS+=" -Wall "
-CXXFLAGS+=" -Wall "
-
-AM_PROG_LIBTOOL
-AC_OUTPUT( Makefile \
- arch.pc )