summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/ps2emu-usbnull/ps2emu-usbnull-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-usbnull/ps2emu-usbnull-9999.ebuild b/games-emulation/ps2emu-usbnull/ps2emu-usbnull-9999.ebuild
new file mode 100644
index 0000000..57a71df
--- /dev/null
+++ b/games-emulation/ps2emu-usbnull/ps2emu-usbnull-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ESVN_REPO_URI="https://pcsx2.svn.sourceforge.net/svnroot/pcsx2/plugins/usb/USBnull"
+inherit eutils games subversion
+
+DESCRIPTION="PS2Emu null USB plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+DEPEND=">=x11-libs/gtk+-2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/USBnull"
+
+src_unpack() {
+ subversion_src_unpack
+ S="${S}/Linux"
+ cd "${S}"
+
+ sed -i \
+ -e '/^CC =/d' \
+ -e '/\bstrip\b/d' \
+ -e 's/-O[0-9]\b//g' \
+ -e 's/-fomit-frame-pointer\b//g' \
+ Makefile || die
+}
+
+src_install() {
+ exeinto "$(games_get_libdir)/ps2emu/plugins"
+ doexe libUSBnull.so || die
+ exeinto "$(games_get_libdir)/ps2emu/plugins/cfg"
+ doexe cfgUSBnull || die
+ use doc && dodoc ../ReadMe.txt || die
+ prepgamesdirs
+}