aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Fish <gentoo@seaofdirac.net>2019-07-09 09:34:17 +0200
committerNicholas Fish <gentoo@seaofdirac.net>2019-07-09 09:35:38 +0200
commita97007fa73b573e77935dc587288f7a217163cd6 (patch)
tree4fe165ebd764a0cb10a9255efc9b7263fe91f231
parentx11-libs/gtk+: Add with patch to disable atk-bridge dependency (i.e. no DBus ... (diff)
downloadennui-a97007fa73b573e77935dc587288f7a217163cd6.tar.gz
ennui-a97007fa73b573e77935dc587288f7a217163cd6.tar.bz2
ennui-a97007fa73b573e77935dc587288f7a217163cd6.zip
net-misc/eventd: Add version 0.25
Signed-off-by: Nicholas Fish <gentoo@seaofdirac.net>
-rw-r--r--net-misc/eventd/Manifest3
-rw-r--r--net-misc/eventd/eventd-0.25.0.ebuild126
-rw-r--r--net-misc/eventd/metadata.xml25
3 files changed, 154 insertions, 0 deletions
diff --git a/net-misc/eventd/Manifest b/net-misc/eventd/Manifest
new file mode 100644
index 0000000..f37f990
--- /dev/null
+++ b/net-misc/eventd/Manifest
@@ -0,0 +1,3 @@
+DIST eventd-0.25.0.tar.xz 184552 BLAKE2B d3972437484653a44a6d87c987ab20f5887a869aedc3682f5f30eceaad0805758282ed81deacc0639a76e8ae587e83be6482e3dfd63c5ca187a60985af3e2f1f SHA512 d59b4d9c331a63e10396a5b2a311ea117431242bb06eeddbbdb9688e18232cd66f65f019d36547d4220fb0c417f01a2680bca5d53a8ad0dd4073830fe80061e0
+EBUILD eventd-0.25.0.ebuild 3250 BLAKE2B 96c4c0d032c71677cbbf8dff44fe6f59853d363ce6320c6800da9687c8eb94a4f7ecc1bfd0d46113bce2f5a10eb0dc82e3db8d764cd7ed8bdd32565013b695ee SHA512 29f552fa6939ae1b611d544c15a25ed00c7a8e344fdc46b150bee206ba6b7e806a621896a07ceab4d95b49ed71f107106476a4d2f0c050915b85b6a38fb7d82f
+MISC metadata.xml 1106 BLAKE2B 659cbf6ddc00f8b32c3d4f028f461579bce6388ea62198575863e596207d791a7048a01cd5d8be1b6b8bdbcaa281cd14f5c2c65566e9dfe716524d3075a75455 SHA512 24381bc7069e34eeeb10e3e5c967da13f155ca2a785d04f144f658c97f8734f16fc2f72fa57874b7da4495b24eced2d2607b0f3f8b52bc9d124da29a11c4f254
diff --git a/net-misc/eventd/eventd-0.25.0.ebuild b/net-misc/eventd/eventd-0.25.0.ebuild
new file mode 100644
index 0000000..c8e5274
--- /dev/null
+++ b/net-misc/eventd/eventd-0.25.0.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info meson systemd xdg-utils
+
+DESCRIPTION="A small daemon to act on remote or local events"
+HOMEPAGE="https://www.eventd.org/"
+SRC_URI="https://www.eventd.org/download/eventd/${P}.tar.xz"
+
+LICENSE="GPL-3+ LGPL-3+ MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug fbcon +introspection ipv6 libcanberra libnotify +notification
+ pulseaudio purple speech systemd test upnp wayland webhook websocket +X zeroconf"
+
+REQUIRED_USE="
+ X? ( notification )
+ fbcon? ( notification )
+ notification? ( || ( X fbcon ) )
+ test? ( websocket )
+"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ sys-apps/util-linux
+ x11-libs/libxkbcommon
+ introspection? ( >=dev-libs/gobject-introspection-1.42 )
+ libcanberra? ( media-libs/libcanberra )
+ libnotify? ( x11-libs/gdk-pixbuf:2 )
+ notification? (
+ x11-libs/cairo
+ x11-libs/pango
+ x11-libs/gdk-pixbuf:2
+ X? (
+ x11-libs/cairo[xcb]
+ x11-libs/libxcb:=
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ )
+ )
+ pulseaudio? (
+ media-libs/libsndfile
+ media-sound/pulseaudio
+ )
+ purple? ( net-im/pidgin )
+ speech? ( >=app-accessibility/speech-dispatcher-0.8.7 )
+ systemd? ( sys-apps/systemd:= )
+ upnp? ( net-libs/gssdp:= )
+ webhook? ( >=net-libs/libsoup-2.42:2.4 )
+ websocket? ( >=net-libs/libsoup-2.50:2.4 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/meson-0.44.1
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+ fbcon? ( virtual/os-headers )
+"
+RDEPEND="${COMMON_DEPEND}
+ net-libs/glib-networking[ssl]
+"
+
+pkg_setup() {
+ if use ipv6; then
+ CONFIG_CHECK=$(usex test 'IPV6' '~IPV6')
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default_src_prepare
+
+ # Prevent access violations from introspection metadata generation.
+ xdg_environment_reset
+}
+
+eventd_use_feature() {
+ echo "-D${2:-${1}}=$(usex ${1} 'enabled' 'disabled')" || die
+}
+
+eventd_use_boolean() {
+ echo "-D${2:-${1}}=$(usex ${1} 'true' 'false')" || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ -Ddbussessionservicedir="${EPREFIX}/usr/share/dbus-1/services"
+ $(eventd_use_feature websocket)
+ $(eventd_use_feature zeroconf dns-sd)
+ $(eventd_use_feature upnp ssdp)
+ $(eventd_use_boolean ipv6)
+ $(eventd_use_boolean systemd)
+ $(eventd_use_boolean notification notification-daemon)
+ #broken, depends on wayland-wall (defunct project?)
+ #$(eventd_use_boolean wayland nd-wayland)
+ $(eventd_use_boolean X nd-xcb)
+ $(eventd_use_boolean fbcon nd-fbdev)
+ $(eventd_use_boolean purple im)
+ $(eventd_use_boolean pulseaudio sound)
+ $(eventd_use_boolean speech tts)
+ $(eventd_use_boolean webhook)
+ $(eventd_use_boolean libnotify)
+ $(eventd_use_boolean libcanberra)
+ $(eventd_use_boolean introspection gobject-introspection)
+ $(eventd_use_boolean debug debug-output)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ EVENTD_TESTS_TMP_DIR="${T}" meson_src_test
+}
+
+pkg_postinst() {
+ if { use notification || use libnotify; } && ! has_version 'gnome-base/librsvg'; then
+ elog
+ elog "For SVG icons in notifications, please install 'gnome-base/librsvg'."
+ elog
+ fi
+}
diff --git a/net-misc/eventd/metadata.xml b/net-misc/eventd/metadata.xml
new file mode 100644
index 0000000..03c186b
--- /dev/null
+++ b/net-misc/eventd/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>itumaykin+gentoo@gmail.com</email>
+ <name>Coacher</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="libcanberra">Enable plugin for sounds via <pkg>media-libs/libcanberra</pkg></flag>
+ <flag name="libnotify">Enable plugin to relay events to notification daemon
+ (Note: not required for local notifications via <pkg>net-misc/eventd</pkg>)</flag>
+ <flag name="notification">Enable plugin to display on-screen notifications</flag>
+ <flag name="purple">Enable plugin for IM notifications via libpurple</flag>
+ <flag name="speech">Enable plugin for Text-To-Speech support</flag>
+ <flag name="webhook">Enable plugin to send payloads to webhook handlers</flag>
+ <flag name="websocket">Enable support for WebSocket protocol</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">sardemff7/eventd</remote-id>
+ </upstream>
+</pkgmetadata>