summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen@falcon.eroen.eu>2014-12-12 11:32:05 +0100
committereroen <eroen@falcon.eroen.eu>2014-12-14 11:06:51 +0100
commit3f994e18c164c94c9c84b9b17fa1751a6ca63be2 (patch)
treef41357f46f8cba12cd57a2e74553e3a7194248d9 /games-action
parentunepic - use linguas_* for voice files (diff)
downloaderoen-3f994e18c164c94c9c84b9b17fa1751a6ca63be2.tar.gz
eroen-3f994e18c164c94c9c84b9b17fa1751a6ca63be2.tar.bz2
eroen-3f994e18c164c94c9c84b9b17fa1751a6ca63be2.zip
unepic - unbundle libs
Diffstat (limited to 'games-action')
-rw-r--r--games-action/unepic/metadata.xml3
-rw-r--r--games-action/unepic/unepic-15005.ebuild11
2 files changed, 13 insertions, 1 deletions
diff --git a/games-action/unepic/metadata.xml b/games-action/unepic/metadata.xml
index 7de7ddf..a69496e 100644
--- a/games-action/unepic/metadata.xml
+++ b/games-action/unepic/metadata.xml
@@ -4,4 +4,7 @@
<longdescription lang="en">
User configuration goes in '~/.local/share/Unepic/unepic'.
</longdescription>
+ <use>
+ <flag name="bundled-libs">Use the bundled SDL2 libraries</flag>
+ </use>
</pkgmetadata>
diff --git a/games-action/unepic/unepic-15005.ebuild b/games-action/unepic/unepic-15005.ebuild
index 70804d8..75be30c 100644
--- a/games-action/unepic/unepic-15005.ebuild
+++ b/games-action/unepic/unepic-15005.ebuild
@@ -17,13 +17,20 @@ HOMEPAGE="http://www.unepicgame.com/en/game.html"
# 940824c4de6e48522845f63423e87783
SRC_URI="${P}-bin-installer-32.run"
S=${WORKDIR}
+RESTRICT="mirror fetch bindist"
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64" # ~x86
-IUSE="linguas_en linguas_es"
+IUSE="bundled-libs linguas_en linguas_es"
+
+LIBDEPEND_BUNDLED="
+ media-libs/libsdl2[X,alsa,joystick,opengl,sound,threads,video]
+ media-libs/sdl2-mixer[vorbis]
+ "
LIBDEPEND="
+ !bundled-libs? ( ${LIBDEPEND_BUNDLED} )
sys-libs/zlib
virtual/opengl
sys-devel/gcc[cxx]
@@ -67,6 +74,8 @@ src_prepare() {
chrpath -d "${S}"/data/unepic${bitness} || die
chrpath -d "${S}"/data/lib${bitness}/libSDL2-2.0.so.0 || die
+ use !bundled-libs && rm -rf "${S}"/data/lib*
+
use linguas_en || rm -rf data/voices/english
use linguas_es || rm -rf data/voices/spanish
}