summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Mavrinac <mavrinac@gmail.com>2012-02-20 11:38:31 -0500
committerAaron Mavrinac <mavrinac@gmail.com>2012-02-20 11:38:31 -0500
commit5d34288aa1253085486eb1234ee20ddc77c05762 (patch)
treea93a585642afa63d1de1b519b64768207e2690ab
parentAdd GTK+ 1 dependency to dev-embedded/as31 ebuild. (diff)
downloadezod-5d34288aa1253085486eb1234ee20ddc77c05762.tar.gz
ezod-5d34288aa1253085486eb1234ee20ddc77c05762.tar.bz2
ezod-5d34288aa1253085486eb1234ee20ddc77c05762.zip
Add slotted Python 3.x version of dev-python/polygon.
-rw-r--r--dev-python/polygon/Manifest4
-rw-r--r--dev-python/polygon/polygon-2.0.4.ebuild4
-rw-r--r--dev-python/polygon/polygon-3.0.4a.ebuild24
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-python/polygon/Manifest b/dev-python/polygon/Manifest
index 8cf092e..b596dbf 100644
--- a/dev-python/polygon/Manifest
+++ b/dev-python/polygon/Manifest
@@ -1,2 +1,4 @@
DIST Polygon-2.0.4.zip 73544 RMD160 dfb26325998f3e8b44ac36f6ef2c0be30b8d9fd9 SHA1 aa734572c911c0ddb4b39d1bf21f8ecbfa3685c8 SHA256 a9a85d81cc9faabba398001b1e9d32444e98147ac6e31cbdc5ef512c4f7c43dd
-EBUILD polygon-2.0.4.ebuild 576 RMD160 cff8df85a4248227228cc089d21ecb7b8db89583 SHA1 0799eefdd2a0b1835a110dc7ba95157d227a4a51 SHA256 16774f7626d1a8c93b9e3b4715eea82d97da629fff76831eee6b37765c06aa0e
+DIST Polygon-3.0.4a-src.zip 163024 RMD160 be1fca82612a7f70d0da70a217b1b7ec4c9a1c9a SHA1 5030b2c687b2d5b70437d6d5fc341fac818c99dd SHA256 2ebef747544660a17a4aefc5a5a8429b6c64af8e0044130f98ed241b48e8fd9d
+EBUILD polygon-2.0.4.ebuild 576 RMD160 8d3d973c3afdd692caa83bae675d385378a76671 SHA1 eb4a262d4841d2901cb4cc3fee70017f7cf7f800 SHA256 ae856cd649fd2da0270ac6a1120bc695b627af5766297b940f68366bb06b4a17
+EBUILD polygon-3.0.4a.ebuild 583 RMD160 cd2f5b40afc2cef581eec35382b90d41f12a831d SHA1 8110a1c6f41746666639df4a757e85a77632d25e SHA256 011af6f2eceb09a02aeb34fc320c1f8bb6e2022e63be7a3b5f70f58d8a41c499
diff --git a/dev-python/polygon/polygon-2.0.4.ebuild b/dev-python/polygon/polygon-2.0.4.ebuild
index 35942ae..2cc26ba 100644
--- a/dev-python/polygon/polygon-2.0.4.ebuild
+++ b/dev-python/polygon/polygon-2.0.4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=4
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython"
@@ -14,7 +14,7 @@ HOMEPAGE="http://www.j-raedler.de/projects/polygon/"
SRC_URI="https://github.com/downloads/jraedler/Polygon2/Polygon-${PV}.zip"
LICENSE="LGPL"
-SLOT="0"
+SLOT="2"
KEYWORDS="amd64 x86"
IUSE=""
diff --git a/dev-python/polygon/polygon-3.0.4a.ebuild b/dev-python/polygon/polygon-3.0.4a.ebuild
new file mode 100644
index 0000000..978434b
--- /dev/null
+++ b/dev-python/polygon/polygon-3.0.4a.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_DEPEND="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.* *-jython"
+
+inherit distutils eutils
+
+DESCRIPTION="Polygon is a python package that handles polygonal shapes in 2D."
+HOMEPAGE="http://www.j-raedler.de/projects/polygon/"
+SRC_URI="https://github.com/downloads/jraedler/Polygon3/Polygon-${PV}-src.zip"
+
+LICENSE="LGPL"
+SLOT="3"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Polygon-${PV/a/}"