aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregory M. Tuner <gmt@be-evil.net>2014-01-11 06:19:40 -0800
committerGregory M. Tuner <gmt@be-evil.net>2014-01-11 06:19:40 -0800
commit43ea91fe3c20bbb374412c1250a3a134f85bd62e (patch)
treec59e360572ead9aff3a73d775ed7698358dd05c5 /dev-libs/gobject-introspection/gobject-introspection-1.38.0-r1.ebuild
parenteclass/python-multilib-single-r1: fix some bugs (diff)
downloadgmt-43ea91fe3c20bbb374412c1250a3a134f85bd62e.tar.gz
gmt-43ea91fe3c20bbb374412c1250a3a134f85bd62e.tar.bz2
gmt-43ea91fe3c20bbb374412c1250a3a134f85bd62e.zip
dev-libs/gobject-introspection: new revbump version which, although still quite ugly, is muchmuchmuchmuch less so
Signed-off-by: Gregory M. Tuner <gmt@be-evil.net>
Diffstat (limited to 'dev-libs/gobject-introspection/gobject-introspection-1.38.0-r1.ebuild')
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-1.38.0-r1.ebuild106
1 files changed, 106 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection/gobject-introspection-1.38.0-r1.ebuild b/dev-libs/gobject-introspection/gobject-introspection-1.38.0-r1.ebuild
new file mode 100644
index 0000000..5c27852
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-1.38.0-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_MULTILIB_SINGLE_MODE=simple
+PYTHON_REQ_USE="xml"
+
+inherit python-multilib-single-r1 gtk-doc toolchain-funcs gnome2-multilib
+
+DESCRIPTION="Introspection infrastructure for generating gobject library bindings for various languages"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+IUSE="cairo doctool test"
+REQUIRED_USE="
+ ${PYTHON_MULTILIB_REQUIRED_USE}
+ test? ( cairo )
+"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-libs/gobject-introspection-common-${PV}
+ >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
+ doctool? ( dev-python/mako )
+ virtual/libffi:=[${MULTILIB_USEDEP}]
+ !<dev-lang/vala-0.20.0
+ ${PYTHON_MULTILIB_DEPS}
+"
+# Wants real bison, not virtual/yacc
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.15
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+# PDEPEND to avoid circular dependencies, bug #391213
+PDEPEND="cairo? ( x11-libs/cairo[glib,${MULTILIB_USEDEP}] )"
+
+src_configure() {
+ if ! has_version "x11-libs/cairo[glib,${MULTILIB_USEDEP}]"; then
+ # Bug #391213: enable cairo-gobject support even if it's not installed
+ # We only PDEPEND on cairo to avoid circular dependencies
+ export CAIRO_LIBS="-lcairo -lcairo-gobject"
+ export CAIRO_CFLAGS="-I${EPREFIX}/usr/include/cairo"
+ fi
+
+ # To prevent crosscompiling problems, bug #414105
+ gnome2-multilib_src_configure \
+ --disable-static \
+ YACC=$(type -p yacc) \
+ $(use_with cairo) \
+ $(use_enable doctool)
+}
+
+ehook gnome2-multilib-per-abi-pre_src_configure abi_src_configure
+abi_src_configure() {
+ G2CONF+=( "CC=${CC:-$(tc-getCC)}" )
+}
+
+
+ehook gnome2-multilib-per-abi-pre_src_configure py_pre
+ehook gnome2-multilib-per-abi-pre_src_compile py_pre
+ehook gnome2-multilib-per-abi-pre_src_install py_pre
+ehook gnome2-multilib-per-abi-pre_src_test py_pre
+py_pre() {
+ SAVE_PATH=${PATH}
+ SAVE_PKG_CONFIG_PATH=${PKG_CONFIG_PATH}
+ SAVE_CFLAGS=${CFLAGS}
+ SAVE_CXXFLAGS=${CXXFLAGS}
+ saveepython() { _saved_epython=${EPYTHON} ; }
+ local _saved_epython=
+ EPYTHON= python_multilib_single_with_abi_python saveepython
+ einfo "for ABI ${ABI} using pyabi=${_saved_epython}"
+ python_export ${_saved_epython} PYTHON PYTHON PYTHON_CFLAGS
+ export CFLAGS="${CFLAGS} ${PYTHON_CFLAGS}"
+ export CXXFLAGS="${CXXFLAGS} ${PYTHON_CXXFLAGS}"
+ python_wrapper_setup
+ return 0
+}
+
+ehook gnome2-multilib-per-abi-post_src_configure py_post
+ehook gnome2-multilib-per-abi-post_src_compile py_post
+ehook gnome2-multilib-per-abi-post_src_install py_post
+ehook gnome2-multilib-per-abi-post_src_test py_post
+py_post() {
+ export PATH=${SAVE_PATH}
+ export PKG_CONFIG_PATH=${SAVE_PKG_CONFIG_PATH}
+ export EPYTHON=
+ export PYTHON=
+ export CFLAGS=${SAVE_CFLAGS}
+ export CXXFLAGS=${SAVE_CXXFLAGS}
+}
+
+src_install() {
+ gnome2-multilib_src_install
+
+ dodoc AUTHORS CONTRIBUTORS ChangeLog NEWS README TODO
+ # Prevent collision with gobject-introspection-common
+ rm -v "${ED}"usr/share/aclocal/introspection.m4 \
+ "${ED}"usr/share/gobject-introspection-1.0/Makefile.introspection || die
+ rmdir "${ED}"usr/share/aclocal || die
+}