summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2022-11-21 13:32:21 +0100
committerhaarp <main.haarp@gmail.com>2022-11-21 13:32:21 +0100
commite5df9a525de473060f4ff177f28650b18e59eb52 (patch)
treeeb741e29b8e17acb8c28f2c265d9f9cabb94f5e4 /games-arcade/SpaceCadetPinball/SpaceCadetPinball-9999.ebuild
parentxed 3.2.8 (diff)
downloadhaarp-e5df9a525de473060f4ff177f28650b18e59eb52.tar.gz
haarp-e5df9a525de473060f4ff177f28650b18e59eb52.tar.bz2
haarp-e5df9a525de473060f4ff177f28650b18e59eb52.zip
Upgrade Space Cadet to 9999
Signed-off-by: haarp <main.haarp@gmail.com>
Diffstat (limited to 'games-arcade/SpaceCadetPinball/SpaceCadetPinball-9999.ebuild')
-rw-r--r--games-arcade/SpaceCadetPinball/SpaceCadetPinball-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-arcade/SpaceCadetPinball/SpaceCadetPinball-9999.ebuild b/games-arcade/SpaceCadetPinball/SpaceCadetPinball-9999.ebuild
new file mode 100644
index 0000000..a05aecd
--- /dev/null
+++ b/games-arcade/SpaceCadetPinball/SpaceCadetPinball-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake git-r3 xdg
+
+DESCRIPTION="Reverse engineering of '3D Pinball for Windows - Space Cadet', a game bundled with Windows"
+HOMEPAGE="https://github.com/k4zmu2a/SpaceCadetPinball"
+EGIT_REPO_URI="https://github.com/k4zmu2a/${PN}.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/libsdl2
+ media-libs/sdl2-mixer[midi]
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst(){
+ ewarn "This game is distributed without the data files."
+ ewarn "To play, copy the original DAT and SOUND files from a Windows or"
+ ewarn 'Full Tilt! installation and place them in $XDG_DATA_HOME/'"${PN}/"
+ ewarn "(usually: ~/.local/share/${PN}/)"
+
+ xdg_pkg_postinst
+}