summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2015-03-09 13:02:24 +0100
committerhaarp <main.haarp@gmail.com>2015-03-09 13:02:24 +0100
commit668b5c8d011a2e77f521dada397d17e2084124bd (patch)
treec7bc559e7e51257ba6cc231bb775ab646a5b1b3f /sys-power
downloadhaarp-668b5c8d011a2e77f521dada397d17e2084124bd.tar.gz
haarp-668b5c8d011a2e77f521dada397d17e2084124bd.tar.bz2
haarp-668b5c8d011a2e77f521dada397d17e2084124bd.zip
populate overlay
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/gapcmon/Manifest2
-rw-r--r--sys-power/gapcmon/gapcmon-0.9.0.ebuild38
-rw-r--r--sys-power/turbostat/Manifest1
-rw-r--r--sys-power/turbostat/turbostat-9999.ebuild27
4 files changed, 68 insertions, 0 deletions
diff --git a/sys-power/gapcmon/Manifest b/sys-power/gapcmon/Manifest
new file mode 100644
index 0000000..40530ae
--- /dev/null
+++ b/sys-power/gapcmon/Manifest
@@ -0,0 +1,2 @@
+DIST apcupsd-3.14.8.tar.gz 1317601 SHA256 8e7f2574d3abaf6637da3e790860c3f9ba64fab1ec7e50bb080de4439441c5a7 SHA512 07e6a15538bf1824b5063a1a93f33231639cf962e658c0dada1b244f2554af81824825d807ea81fd0388e25ed8fac0957621bfded96e3faeb7b594548fc4d418 WHIRLPOOL e5a580afc4955a373f020cb6e4ccbf07f9f020d4c15eaae59b416499c25a00b9d4bbc6af012bd2529024e8a3668a1d7c47f19f1bcb99f5ba60dc0108fa13c4f2
+EBUILD gapcmon-0.9.0.ebuild 710 SHA256 3a1656aecdf8860cca2d250f81b6c7560ae5886c2d92484cc9b955a98873daa9 SHA512 f1d62cda241e59d81bc30d1a32b236a4af410cf085204da0b32a7457784fe0d5245f7d467ba8f2b1496717803daa5afb1c8e92eb74aeeff63854013aa25c1117 WHIRLPOOL 6f0074bca8e371d874d66273cc656c4513cc642af8a43adfc9370216ec2c29cdf44ae9834d94a58588195bbb69fc0d64708f88c1923d0f526103242b55b58597
diff --git a/sys-power/gapcmon/gapcmon-0.9.0.ebuild b/sys-power/gapcmon/gapcmon-0.9.0.ebuild
new file mode 100644
index 0000000..1b71daa
--- /dev/null
+++ b/sys-power/gapcmon/gapcmon-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+BASE=apcupsd-3.14.8
+
+DESCRIPTION="Linux GUI monitor for APCUPSD"
+HOMEPAGE="http://gapcmon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/apcupsd/$BASE.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.8
+ >=gnome-base/gconf-2.10
+ !sys-power/apcupsd[gnome]"
+
+S="$WORKDIR/$BASE"
+
+src_configure() {
+ econf --enable-gapcmon
+}
+
+src_compile() {
+ S="$WORKDIR/$BASE/src/gapcmon"
+ emake
+}
+
+src_install() {
+ S="$WORKDIR/$BASE/src/gapcmon"
+ emake DESTDIR="${D}" install-gapcmon
+ dodoc ChangeLog README
+}
diff --git a/sys-power/turbostat/Manifest b/sys-power/turbostat/Manifest
new file mode 100644
index 0000000..aba7244
--- /dev/null
+++ b/sys-power/turbostat/Manifest
@@ -0,0 +1 @@
+EBUILD turbostat-9999.ebuild 630 SHA256 201da9f784446284ae54e8863251f6ffb6e28510044c7eafbe33a8499e7c12a8 SHA512 3d22954bbfa4fb9d0b1fabbb1c06447311e3e46e721621af22cdac92248e68c1cd0533490daf0a498e8875b0c234585bac082ab836d127460a1282a081c15240 WHIRLPOOL 6def64a1682bf794d970c937be405b56269449c3c9162cdc6a941f9eadf9cffd979c040a8f7c5c434e9fa6dfe285e471c8c98940c5e77dbe6252e9d5ddb29bca
diff --git a/sys-power/turbostat/turbostat-9999.ebuild b/sys-power/turbostat/turbostat-9999.ebuild
new file mode 100644
index 0000000..659ecff
--- /dev/null
+++ b/sys-power/turbostat/turbostat-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Report processor frequency and idle statistics"
+HOMEPAGE="http://lwn.net/Articles/433002/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/glibc"
+DEPEND="${DEPEND}
+ >=sys-kernel/gentoo-sources-2.6.36"
+
+src_unpack() {
+ mkdir -p "${S}"
+ cp /usr/src/linux/tools/power/x86/turbostat/* "${S}/" || die "turbostat not found in kernel sources!"
+ cd "${S}"
+}
+
+src_prepare() {
+ sed -i -e 's:../../../../arch/x86/include/uapi/asm/msr-index.h:asm/msr-index.h:' Makefile
+}