summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhaarp <main.haarp@gmail.com>2015-03-30 16:06:27 +0200
committerhaarp <main.haarp@gmail.com>2015-03-30 16:06:27 +0200
commita939e47e546f1e5cd0c83e71d1d78454e3e8250d (patch)
tree08c25a0f0d7b1ffbecca8c1d302d5ab2ca3d97c7 /sys-power
parentMake Zandronum use the system sqlite (diff)
downloadhaarp-a939e47e546f1e5cd0c83e71d1d78454e3e8250d.tar.gz
haarp-a939e47e546f1e5cd0c83e71d1d78454e3e8250d.tar.bz2
haarp-a939e47e546f1e5cd0c83e71d1d78454e3e8250d.zip
Improve kernel search for turbostat
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/turbostat/Manifest2
-rw-r--r--sys-power/turbostat/turbostat-9999.ebuild4
2 files changed, 4 insertions, 2 deletions
diff --git a/sys-power/turbostat/Manifest b/sys-power/turbostat/Manifest
index aba7244..65f6506 100644
--- a/sys-power/turbostat/Manifest
+++ b/sys-power/turbostat/Manifest
@@ -1 +1 @@
-EBUILD turbostat-9999.ebuild 630 SHA256 201da9f784446284ae54e8863251f6ffb6e28510044c7eafbe33a8499e7c12a8 SHA512 3d22954bbfa4fb9d0b1fabbb1c06447311e3e46e721621af22cdac92248e68c1cd0533490daf0a498e8875b0c234585bac082ab836d127460a1282a081c15240 WHIRLPOOL 6def64a1682bf794d970c937be405b56269449c3c9162cdc6a941f9eadf9cffd979c040a8f7c5c434e9fa6dfe285e471c8c98940c5e77dbe6252e9d5ddb29bca
+EBUILD turbostat-9999.ebuild 651 SHA256 07c8c2c1a2fdd31da8179f990cca4507ca3f06c9821e000d79af9269332b6915 SHA512 5c603baacbbac5aa47ae398fbe85946616c9f7499bdff90d45622b8833aa598d36544a290576413750d65bcac88ab78982b1ee57aad1d21fd996538a020aebc1 WHIRLPOOL aadfc14db4a04a4e8d096c7e9d917ab5e4ab7a66b5fd4195d0c08dd60b0294e1dc4a80317183589563d7eb31a249aae725dc2c663d8434071c48717da604ae41
diff --git a/sys-power/turbostat/turbostat-9999.ebuild b/sys-power/turbostat/turbostat-9999.ebuild
index 659ecff..addd69b 100644
--- a/sys-power/turbostat/turbostat-9999.ebuild
+++ b/sys-power/turbostat/turbostat-9999.ebuild
@@ -4,6 +4,8 @@
EAPI=5
+inherit linux-info
+
DESCRIPTION="Report processor frequency and idle statistics"
HOMEPAGE="http://lwn.net/Articles/433002/"
@@ -18,7 +20,7 @@ DEPEND="${DEPEND}
src_unpack() {
mkdir -p "${S}"
- cp /usr/src/linux/tools/power/x86/turbostat/* "${S}/" || die "turbostat not found in kernel sources!"
+ cp "${KERNEL_DIR}/tools/power/x86/turbostat"/* "${S}/" || die "turbostat not found in kernel sources!"
cd "${S}"
}