summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild')
-rw-r--r--games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild b/games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild
new file mode 100644
index 0000000..d341b1c
--- /dev/null
+++ b/games-arcade/SpaceCadetPinball/SpaceCadetPinball-2.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Decompilation of 3D Pinball for Windows - Space Cadet"
+HOMEPAGE="https://github.com/k4zmu2a/SpaceCadetPinball"
+SRC_URI="https://github.com/k4zmu2a/${PN}/archive/refs/tags/Release_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/libsdl2
+ media-libs/sdl2-mixer[midi]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-Release_${PV}"
+
+src_prepare(){
+ # the paths should be relative
+ sed -i "s|/Platform|Platform|g" CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+pkg_postinst(){
+ ewarn "This game is distributed without the data files."
+ ewarn "To play, copy the original DAT and SOUND files from a Windows or"
+ ewarn 'Full Tilt! installation and place them in $XDG_DATA_HOME/'"${PN}/"
+ ewarn "(usually: ~/.local/share/${PN}/)"
+
+ xdg_pkg_postinst
+}