aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-05-15 22:31:26 +0800
committerIan Delaney <della5@iinet.com.au>2012-05-15 22:31:26 +0800
commit05d61f375ef479951133ec541a0e50e437b22f9d (patch)
treea4ca08e5068df4d7f8dd2403ccb42288c87616b1
parent[dev-python/django-evolution] removed accidental distutils_src_install (diff)
downloadimprovise-05d61f375ef479951133ec541a0e50e437b22f9d.tar.gz
improvise-05d61f375ef479951133ec541a0e50e437b22f9d.tar.bz2
improvise-05d61f375ef479951133ec541a0e50e437b22f9d.zip
[dev-python/django-auth-ldap] tidy up
(Portage version: 2.1.10.56/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild
index cf26fa0..6fd8e87 100644
--- a/dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild
+++ b/dev-python/django-auth-ldap/django-auth-ldap-1.1.ebuild
@@ -26,20 +26,16 @@ DEPEND="${RDEPEND} >=dev-python/django-1.0
src_compile() {
distutils_src_compile
+
# BuildDocs is not essential. just an extra 'touch'
- BuildDocs() {
- emake -C docs html
- }
- if use doc; then
- python_execute_function -f BuildDocs
- fi
+ use doc && emake -C docs html
}
src_test() {
export DJANGO_SETTINGS_MODULE="django.conf"
# Test && demo that the tests are run;
- # Python.[56] trigger a hramless depracation warning
+ # Python.[56] trigger a harmless depracation warning
testing() {
local exit_status=0
PYTHONPATH=build-${PYTHON_ABI}/lib