aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-06-04 17:19:58 +0800
committerIan Delaney <della5@iinet.com.au>2012-06-04 17:19:58 +0800
commit582d618b8b321c10e388db136b99624a37dce461 (patch)
treed814f475ceb05d0083f97e7c64528d0e8b6bcb9b
parent[dev-python/cookbook] new ebuild for xhtml2pdf version bump (diff)
downloadimprovise-582d618b8b321c10e388db136b99624a37dce461.tar.gz
improvise-582d618b8b321c10e388db136b99624a37dce461.tar.bz2
improvise-582d618b8b321c10e388db136b99624a37dce461.zip
[dev-python/bunch] Add new ebuild
(Portage version: 2.1.10.63/git/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/bunch/Manifest1
-rw-r--r--dev-python/bunch/bunch-1.0.1.ebuild32
-rw-r--r--dev-python/bunch/metadata.xml10
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/bunch/Manifest b/dev-python/bunch/Manifest
new file mode 100644
index 0000000..0a8cd91
--- /dev/null
+++ b/dev-python/bunch/Manifest
@@ -0,0 +1 @@
+DIST bunch-1.0.1.tar.gz 6577 SHA256 50c77a0fc0cb372dfe48b5e11937d5f70e743adbf42683f3a6d2857645a76aaa SHA512 4423afd0f8704e47c72c87f858599677734b9f49be9c1f8a68e0a671a35a5423428901c0ab235af88854979fd9377eb10f5ec05805b9a24a67c894dd9a3559cf WHIRLPOOL 8de3089009e31c74c3fa76694f75f3d49beed736506805d62f1634e8c2b96df2ad7803a75ccf347fd4ea6b74d0ff58a9e86644cfd0462fa3419c48af05eeda93
diff --git a/dev-python/bunch/bunch-1.0.1.ebuild b/dev-python/bunch/bunch-1.0.1.ebuild
new file mode 100644
index 0000000..1dd845b
--- /dev/null
+++ b/dev-python/bunch/bunch-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+PYTHON_depend="2:2.6"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
+inherit distutils
+
+DESCRIPTION="A dictionary that supports attribute-style access, a la JavaScript"
+HOMEPAGE="http://pypi.python.org/pypi/bunch http://github.com/dsc/bunch/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64"
+IUSE="doc"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+src_test() {
+ testing() {
+ local exit_status=0
+ PYTHONPATH=. "$(PYTHON)" -d ${PN}/test.py || exit_status=1
+ einfo testing completed by python${PYTHON_ABI}
+ return $exit_status
+ }
+ python_execute_function testing
+}
diff --git a/dev-python/bunch/metadata.xml b/dev-python/bunch/metadata.xml
new file mode 100644
index 0000000..988266a
--- /dev/null
+++ b/dev-python/bunch/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer><email>tampakrap@gentoo.org</email></maintainer>
+ <maintainer>
+ <email>johneed@hotmail.com</email>
+ <name>Ian idella4 Delaney proxy maintainer</name>
+ </maintainer>
+</pkgmetadata>