aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2014-08-29 15:11:32 +0800
committerIan Delaney <della5@iinet.com.au>2014-08-29 15:11:32 +0800
commit69d5fc40f4278b1df447845e9392e23151095ba1 (patch)
treee33d6f48e73800f3d3fa191081347529d6b83b2f
parentmass purge of old ebuilds mostly in portage (diff)
downloadimprovise-69d5fc40f4278b1df447845e9392e23151095ba1.tar.gz
improvise-69d5fc40f4278b1df447845e9392e23151095ba1.tar.bz2
improvise-69d5fc40f4278b1df447845e9392e23151095ba1.zip
note for websocket-client in a diff file, add working service_identity, characteristic and some others
-rw-r--r--dev-python/catbox/Manifest1
-rw-r--r--dev-python/catbox/catbox-1.6.2.ebuild36
-rw-r--r--dev-python/certifi/Manifest1
-rw-r--r--dev-python/certifi/certifi-14.05.14.ebuild20
-rw-r--r--dev-python/certifi/metadata.xml5
-rw-r--r--dev-python/characteristic/Manifest1
-rw-r--r--dev-python/characteristic/characteristic-14.1.0.ebuild42
-rw-r--r--dev-python/characteristic/metadata.xml5
-rw-r--r--dev-python/characteristic/note.txt9
-rw-r--r--dev-python/flask-cors/Manifest2
-rw-r--r--dev-python/flask-cors/flask-cors-1.3.1.ebuild34
-rw-r--r--dev-python/flask-cors/flask-cors-1.6.1.ebuild47
-rw-r--r--dev-python/flask-cors/metadata.xml14
-rw-r--r--dev-python/http-parser/Manifest1
-rw-r--r--dev-python/http-parser/http-parser-0.7.5.ebuild32
-rw-r--r--dev-python/http-parser/metadata.xml11
-rw-r--r--dev-python/service_identity/Manifest1
-rw-r--r--dev-python/service_identity/metadata.xml5
-rw-r--r--dev-python/service_identity/service_identity-14.0.0.ebuild44
-rw-r--r--dev-python/websocket-client/Manifest1
-rw-r--r--dev-python/websocket-client/metadata.xml5
-rw-r--r--dev-python/websocket-client/websocket-client-0.17.0.ebuild37
-rw-r--r--x11-misc/service-discovery-applet/Manifest2
-rw-r--r--x11-misc/xac/Manifest1
-rw-r--r--x11-misc/xac/files/x86-biosfix.patch40
-rw-r--r--x11-misc/xac/metadata.xml11
-rw-r--r--x11-misc/xac/xac-0.6_pre4.ebuild58
27 files changed, 311 insertions, 155 deletions
diff --git a/dev-python/catbox/Manifest b/dev-python/catbox/Manifest
new file mode 100644
index 0000000..1d3c9c6
--- /dev/null
+++ b/dev-python/catbox/Manifest
@@ -0,0 +1 @@
+DIST catbox-1.6.2.tar.gz 16711 SHA256 fe56def25af3c583a96986b47c396d91f46953425a942174fa6d77e3dcb97ca8 SHA512 e3eccc9257c051fc7acd6b13587cea2da61265e2aee2ad3b72efb30653b6f19ffd769a81228209db20cba979c1123b20c0cb8f833fb007c107f8eac917a863ff WHIRLPOOL acfcca72061b1627b1ba9f5c88792e92285fee41f81b787fd9cddc850d069ef703330d3690f143b34c00534193132ba573b59a7d66a7e4ad772b3f253ba40e06
diff --git a/dev-python/catbox/catbox-1.6.2.ebuild b/dev-python/catbox/catbox-1.6.2.ebuild
new file mode 100644
index 0000000..0980071
--- /dev/null
+++ b/dev-python/catbox/catbox-1.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Fast sandbox implementation for Python"
+HOMEPAGE=" https://github.com/Pardus-Linux/catbox"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/testify[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ testify tests || die "Tests failed under ${EPYTHON}"
+}
+
+# Circular dep of testify to run the testsuite
+pkg_post_inst() {
+ elog "To run the testsuite, emerge testify spearately,"
+ elog, "then re-run using FEATURES=test"
+}
diff --git a/dev-python/certifi/Manifest b/dev-python/certifi/Manifest
new file mode 100644
index 0000000..4a87a65
--- /dev/null
+++ b/dev-python/certifi/Manifest
@@ -0,0 +1 @@
+DIST certifi-14.05.14.tar.gz 168608 SHA256 1e1bcbacd6357c151ae37cf0290dcc809721d32ce21fd6b7339568f3ddef1b69 SHA512 5edba0cc432c27212e31085fb3c2f2ded6fa177d716116111517c25b980d9fc206a9a6d47e2c001762e951ff50203b269d0eb245a039df20188b1136f3b700b2 WHIRLPOOL 54c3f7a8da25693f5df890c5bc348242350a7a63bc0094d5fbb08a4f89c79fcc3ce0bbf0cdeac7d2dfca5ebe5601a7ae5ec4fef492a6cf9afe6ecf5119d47f8b
diff --git a/dev-python/certifi/certifi-14.05.14.ebuild b/dev-python/certifi/certifi-14.05.14.ebuild
new file mode 100644
index 0000000..3f11774
--- /dev/null
+++ b/dev-python/certifi/certifi-14.05.14.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package for providing Mozilla's CA Bundle"
+HOMEPAGE="http://python-requests.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/certifi/metadata.xml b/dev-python/certifi/metadata.xml
new file mode 100644
index 0000000..301d220
--- /dev/null
+++ b/dev-python/certifi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/characteristic/Manifest b/dev-python/characteristic/Manifest
new file mode 100644
index 0000000..e05842c
--- /dev/null
+++ b/dev-python/characteristic/Manifest
@@ -0,0 +1 @@
+DIST characteristic-14.1.0.tar.gz 24612 SHA256 91e254948180678dd69e6143202b4686f2fa47cce136936079bb4d9a3b82419d SHA512 21bb40814f405c73471a83e15d1cfb07f74ebd157e647799bedffffd3909271145347eaec8ec09470dddad7224d1a15e8984a75f1fce00bbe20f9e1cb385f9b9 WHIRLPOOL d8044dfcbb7d75a383834bee842bd619b4bec65c8a0f467a563b9a80ee908bcf5c7de791eb220f9ba3b35a259a9ea6c6985f743518e2677d8a03a62db70ad98c
diff --git a/dev-python/characteristic/characteristic-14.1.0.ebuild b/dev-python/characteristic/characteristic-14.1.0.ebuild
new file mode 100644
index 0000000..40de764
--- /dev/null
+++ b/dev-python/characteristic/characteristic-14.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python attributes without the boilerplate"
+HOMEPAGE="https://characteristic.readthedocs.org/ https://github.com/hynek/characteristic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test -a "--cov characteristic --cov-report term-missing"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/characteristic/metadata.xml b/dev-python/characteristic/metadata.xml
new file mode 100644
index 0000000..301d220
--- /dev/null
+++ b/dev-python/characteristic/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/characteristic/note.txt b/dev-python/characteristic/note.txt
new file mode 100644
index 0000000..b09742e
--- /dev/null
+++ b/dev-python/characteristic/note.txt
@@ -0,0 +1,9 @@
+Once transferred to this overlay, repoman f groans over pytest-cov in service_identity and pyasn1-modules in
+charcteristic. They PASS FINE in my local portage tree.
+Something to do with portage accesses eclasses of something beyond which either interests me or I care
+about.
+The other way of doing this is for me to git push them in my pverlay which is called
+improvise.
+I pondered terrorise but decided to go 'nice'.
+The final test is to pass repoman full in the local portage tree so these groans to me are
+nothing but a nuisance, brown noise.
diff --git a/dev-python/flask-cors/Manifest b/dev-python/flask-cors/Manifest
new file mode 100644
index 0000000..0de7990
--- /dev/null
+++ b/dev-python/flask-cors/Manifest
@@ -0,0 +1,2 @@
+DIST Flask-Cors-1.3.1.tar.gz 9988 SHA256 351c1be901e7b16f533ad1c11ba7e86911270620ad7ec5f8c01b622d2b05f91a SHA512 5922b5ef89e6e9b6ddca176a666ac8727246f301b86ebe58edec4f5204aae66a92f57321dd343307bbed619295a6d13dc77a39c6bea7d8e6a45950520a8038bc WHIRLPOOL 248e26d4858e1292dfb016a32ed5174d0f6d9d2f560214b96924d7b18e634e77b52166473ef403a4d0319ce9d73e3f113cfe01758a6dc09b5a422c48b7c0f2a0
+DIST Flask-Cors-1.6.1.tar.gz 13263 SHA256 24ae9e068d92963116ef3854e105b9840f42ddd759c1da836c2b86a3fb510736 SHA512 03db71cd13986b135e2170ef880d697c6bd9a2eac007d36cbf5f24685d21b4d7aaaac798ba5086126e0cf186184a4ab46b137d1ae06e4daa838960da3afcc69c WHIRLPOOL 36ee538096680efc443e2dd7bac9fd0a3ffc8daca960bb240ac0583d4a36468b258a257a28f0e7184b85978bc4b99673010bede363d31af8f435896efcb6820d
diff --git a/dev-python/flask-cors/flask-cors-1.3.1.ebuild b/dev-python/flask-cors/flask-cors-1.3.1.ebuild
new file mode 100644
index 0000000..41c874b
--- /dev/null
+++ b/dev-python/flask-cors/flask-cors-1.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-Cors"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Flask extension adding a decorator for CORS support"
+HOMEPAGE="https://github.com/wcdolphin/flask-cors https://pypi.python.org/pypi/Flask-Cors"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ esetup.py test
+# nosetests || die "Testing failed with ${EPYTHON}"
+}
+
diff --git a/dev-python/flask-cors/flask-cors-1.6.1.ebuild b/dev-python/flask-cors/flask-cors-1.6.1.ebuild
new file mode 100644
index 0000000..a1a2b38
--- /dev/null
+++ b/dev-python/flask-cors/flask-cors-1.6.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-Cors"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Flask extension adding a decorator for CORS support"
+HOMEPAGE="https://github.com/wcdolphin/flask-cors https://pypi.python.org/pypi/Flask-Cors"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-cors/metadata.xml b/dev-python/flask-cors/metadata.xml
new file mode 100644
index 0000000..4ffdee1
--- /dev/null
+++ b/dev-python/flask-cors/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>wking@tremily.us</email>
+ <name>W. Trevor King</name>
+ <description>Proxy maintainer</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/http-parser/Manifest b/dev-python/http-parser/Manifest
deleted file mode 100644
index e6fa436..0000000
--- a/dev-python/http-parser/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST http-parser-0.7.5.tar.gz 131576 SHA256 282b5e4d61bb3b97416afb5f92328a51da7c39a9ff35e3757f287c66ec0a95da SHA512 5f7c6997296353fed65063ec7d99ae0163cd948f66e9b1dc1aa6416a5f11f9f69b5a9a7c70ba6569d535a1fcb7dde8ea88f51a6fe8e11d7270519fabc352f8d4 WHIRLPOOL 613d64b0bd9a9452e0aacc1e10493c59d53b97ae1be6de6471941fba02a335a93132b9897d4f82f775ec1582668d30d9abbab38ecfa42652299acf20f1af4ea3
diff --git a/dev-python/http-parser/http-parser-0.7.5.ebuild b/dev-python/http-parser/http-parser-0.7.5.ebuild
deleted file mode 100644
index d71543c..0000000
--- a/dev-python/http-parser/http-parser-0.7.5.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="*-jython"
-inherit distutils
-
-DESCRIPTION="http-parser is a http-parser"
-HOMEPAGE="http://github.com/benoitc/http-parser"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~amd64"
-IUSE="examples"
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools
- dev-python/cython"
-
-src_install() {
- distutils_src_install
- if use examples; then
- docompress -x usr/share/doc/${P}/examples
- insinto usr/share/doc/${P}
- doins -r examples/
- fi
-}
diff --git a/dev-python/http-parser/metadata.xml b/dev-python/http-parser/metadata.xml
deleted file mode 100644
index 62940a8..0000000
--- a/dev-python/http-parser/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>python</herd>
- <maintainer><email>tampakrap@gentoo.org</email></maintainer>
- <maintainer>
- <email>johneed@hotmail.com,della5@iinet.com.au</email>
- <name>Ian Delaney aka idella4 proxy maintainer</name>
- </maintainer>
-
-</pkgmetadata>
diff --git a/dev-python/service_identity/Manifest b/dev-python/service_identity/Manifest
new file mode 100644
index 0000000..4d5625d
--- /dev/null
+++ b/dev-python/service_identity/Manifest
@@ -0,0 +1 @@
+DIST service_identity-14.0.0.tar.gz 26033 SHA256 3105a319a7c558490666694f599be0c377ad54824eefb404cde4ce49e74a4f5a SHA512 d504ad388defb38a86ca82c8ff9582dbb664a929e4b4ee7f6732b2da5326c33b1764384a8d849972f83ae7800c775daf90c1f3fbc61b8d2c29294f44c7cd36d2 WHIRLPOOL bc6f3cba3e3bec83c527df60dc3cd4387d74baab5a88b5c2cb731661804139c78c86074902060b64e402364ac641b4b2617c98448d4a9e6b367dc0f9d6cd5dac
diff --git a/dev-python/service_identity/metadata.xml b/dev-python/service_identity/metadata.xml
new file mode 100644
index 0000000..301d220
--- /dev/null
+++ b/dev-python/service_identity/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/service_identity/service_identity-14.0.0.ebuild b/dev-python/service_identity/service_identity-14.0.0.ebuild
new file mode 100644
index 0000000..ec5a9d9
--- /dev/null
+++ b/dev-python/service_identity/service_identity-14.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Service identity verification for pyOpenSSL"
+HOMEPAGE="https://github.com/pyca/service_identity"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.12[${PYTHON_USEDEP}]
+ >=dev-python/characteristic-14.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test --cov service_identity --cov-report term-missing || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/websocket-client/Manifest b/dev-python/websocket-client/Manifest
new file mode 100644
index 0000000..947ae10
--- /dev/null
+++ b/dev-python/websocket-client/Manifest
@@ -0,0 +1 @@
+DIST websocket-client-0.17.0.tar.gz 187176 SHA256 94ab783bf67c91e46c9f97134a37c2d583e377864ffec493b2eb76b3ba30c8e4 SHA512 2462f9128e41955e3c1c1cfefbe5a25bd25ee37ddf8675ec6d5f9984a254b90412f6ffab9b242eb268d16b0cd9421f92c1c0d8a38bdc67cba2d722f5c37a4492 WHIRLPOOL e2f00be1374d3d889a9743cd40bc64f85ee1abdc8ae8352d928e675c159eb58752369ed6b8d3a5788b82fb9d24c1d0b520499bb78e6b57b61a7e682525e8cfa6
diff --git a/dev-python/websocket-client/metadata.xml b/dev-python/websocket-client/metadata.xml
new file mode 100644
index 0000000..0eca95e
--- /dev/null
+++ b/dev-python/websocket-client/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/websocket-client/websocket-client-0.17.0.ebuild b/dev-python/websocket-client/websocket-client-0.17.0.ebuild
new file mode 100644
index 0000000..e780fe8
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-0.17.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A WebSocket client for python that provides the low level APIs for WebSocket"
+HOMEPAGE="https://github.com/liris/websocket-client https://pypi.python.org/pypi/websocket-client"
+SRC_URI="https://github.com/liris/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Required to avoid file collisions at install
+ sed -e 's:"tests", ::' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" tests/test_websocket.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/x11-misc/service-discovery-applet/Manifest b/x11-misc/service-discovery-applet/Manifest
index f8d1217..dcffd25 100644
--- a/x11-misc/service-discovery-applet/Manifest
+++ b/x11-misc/service-discovery-applet/Manifest
@@ -1 +1 @@
-DIST service-discovery-applet-0.4.3.tar.gz 184000 RMD160 cba4b82d424cfbf591479b9b143d3ca918de1562 SHA1 6b1bf72b57a1a0bb34bc3e78f29e8e9227013b09 SHA256 b3704a067f5541a0f73f54a09f93d2f053e5c8d0344f6d5d809bc96eab152b1a
+DIST service-discovery-applet-0.4.3.tar.gz 184000 SHA256 b3704a067f5541a0f73f54a09f93d2f053e5c8d0344f6d5d809bc96eab152b1a
diff --git a/x11-misc/xac/Manifest b/x11-misc/xac/Manifest
deleted file mode 100644
index dc418c4..0000000
--- a/x11-misc/xac/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST xac-0.6_pre4.tar.bz2 37409 RMD160 ecc98ef512c52f793cbaf1e1f8ed5497e108a2d3 SHA1 5ab11f5f859d9a635b4c59d4b75ec6ac66665ad6 SHA256 ff34e1e6e7027a22e712307e3832423b512af894e8ad9678e2f5d022a699a4d4
diff --git a/x11-misc/xac/files/x86-biosfix.patch b/x11-misc/xac/files/x86-biosfix.patch
deleted file mode 100644
index 918cdf1..0000000
--- a/x11-misc/xac/files/x86-biosfix.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -u -B -r1.1 -r1.2
---- src/bioscall.h 25 Aug 2006 19:48:26 -0000 1.1
-+++ src/bioscall.h 30 Sep 2009 15:05:49 -0000 1.2
-@@ -1,6 +1,8 @@
- #ifndef bioscall_h
- #define bioscall_h
-
-+#include "int10defs.h"
-+
- /* Print some of the interesting parts of a vm86_regs structure. */
- void dump_regs(struct vm86_regs *regs);
-
-diff -u -B -r1.1 -r1.2
---- src/lrmi.h 25 Aug 2006 19:48:26 -0000 1.1
-+++ src/lrmi.h 30 Sep 2009 15:05:49 -0000 1.2
-@@ -26,6 +26,8 @@
- #ifndef LRMI_H
- #define LRMI_H
-
-+#include "int10defs.h"
-+
- #if defined(__i386__) && (defined(__linux__) || defined(__NetBSD__) \
- || defined(__FreeBSD__) || defined(__OpenBSD__))
-
-diff -Naur
---- src/int10defs.h
-+++ src/int10defs.h 30 Sep 2009 15:05:49 -0000
-@@ -0,0 +1,12 @@
-+/* Fix missing INT10 defines */
-+#ifndef IF_MASK
-+#define TF_MASK 0x00000100
-+#define IF_MASK 0x00000200
-+#define IOPL_MASK 0x00003000
-+#define NT_MASK 0x00004000
-+#define VM_MASK 0x00020000
-+#define AC_MASK 0x00040000
-+#define VIF_MASK 0x00080000 /* virtual interrupt flag */
-+#define VIP_MASK 0x00100000 /* virtual interrupt pending */
-+#define ID_MASK 0x00200000
-+#endif
diff --git a/x11-misc/xac/metadata.xml b/x11-misc/xac/metadata.xml
deleted file mode 100644
index 487b7c3..0000000
--- a/x11-misc/xac/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer>
-<email>josejx@gentoo.org</email>
-<name>Joseph Jezak</name>
-</maintainer>
-<longdescription lang="en">
-X.org autoconfiguration tool written in python.
-</longdescription>
-</pkgmetadata>
diff --git a/x11-misc/xac/xac-0.6_pre4.ebuild b/x11-misc/xac/xac-0.6_pre4.ebuild
deleted file mode 100644
index aa18ddf..0000000
--- a/x11-misc/xac/xac-0.6_pre4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xac/xac-0.6_pre4.ebuild,v 1.6 2009/09/30 15:52:20 josejx Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2"
-inherit toolchain-funcs eutils distutils multilib
-
-DESCRIPTION="Xorgautoconfig (xac) generates configuration files for X.org"
-HOMEPAGE="http://dev.gentoo.org/~josejx/xac.html"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ppc ppc64 ~x86"
-SLOT="0"
-IUSE="livecd"
-DEPEND="sys-apps/pciutils"
-RDEPEND=">=dev-lang/python-2.3
- x11-base/xorg-server"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-DISTUTILS_SETUP_FILES=("src|setup.py")
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- ### Replace /usr/lib/xac with libdir version
- sed -i "s:/usr/lib/xac:/usr/$(get_libdir)/xac:" xac
-
- ### Fix the x86 bios call with newer glibc
- epatch "${FILESDIR}/x86-biosfix.patch"
-}
-
-src_install() {
- distutils_src_install
- local xac_base="/usr/$(get_libdir)/xac"
-
- dosbin "${S}"/xac
-
- dodir "${xac_base}"
- insinto ${xac_base}
- doins "${S}"/py/*
-
- ### Only install the init scripts if livecd is enabled
- if use livecd; then
- newinitd "${S}"/xac.init xac
- newconfd "${S}"/xac.conf xac
- fi
-
-}
-
-pkg_postinst() {
- python_mod_optimize /usr/$(get_libdir)/xac
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/xac
-}