aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <della5@iinet.com.au>2012-05-21 00:35:11 +0800
committerIan Delaney <della5@iinet.com.au>2012-05-21 00:35:11 +0800
commit704abe03c7f069a2240b74980acb4ca0f1a66357 (patch)
treecfdcecda79ccf1f3802c5b6bb4ccd1e4b95fbcb8 /dev-python/workerpool/workerpool-0.9.2.ebuild
parent[dev-python/testfixtures] final cleanup(sed) (diff)
downloadimprovise-704abe03c7f069a2240b74980acb4ca0f1a66357.tar.gz
improvise-704abe03c7f069a2240b74980acb4ca0f1a66357.tar.bz2
improvise-704abe03c7f069a2240b74980acb4ca0f1a66357.zip
[dev-python/workerpoo] New ebuild
Diffstat (limited to 'dev-python/workerpool/workerpool-0.9.2.ebuild')
-rw-r--r--dev-python/workerpool/workerpool-0.9.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/workerpool/workerpool-0.9.2.ebuild b/dev-python/workerpool/workerpool-0.9.2.ebuild
new file mode 100644
index 0000000..6d3720c
--- /dev/null
+++ b/dev-python/workerpool/workerpool-0.9.2.ebuild
@@ -0,0 +1,61 @@
+#Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+EAPI="4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+DISTUTILS_SRC_TEST=nosetests
+# package supports python3, tests don't
+#PYTHON_TESTS_RESTRICTED_ABIS="3.*"
+inherit distutils
+
+DESCRIPTION="Module for distributing jobs to a pool of worker threads."
+HOMEPAGE="http://github.com/shazow/workerpool"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptool"
+
+src_prepare() {
+ # python3 can be used but not with tests
+ checkabi() {
+ local exit_status=0
+ if use test && [[ $(python_get_version --major) == 3 ]]; then
+ # Green from einfo more readable than in red from eerror.
+ einfo ""
+ einfo "tests do not support python3"
+ einfo "tests can be run with python2"
+ einfo ""
+ exit_status=1
+ return $exit_status
+ fi
+ }
+ python_execute_function checkabi
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_test() {
+ # point distutils_src_test to tests
+ distutils_src_test -v test
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ docompress -x usr/share/doc/${P}/samples
+ insinto usr/share/doc/${P}/
+ doins -r samples
+ fi
+}