summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/lsyncd/lsyncd-1.37.ebuild')
-rw-r--r--app-admin/lsyncd/lsyncd-1.37.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/lsyncd/lsyncd-1.37.ebuild b/app-admin/lsyncd/lsyncd-1.37.ebuild
new file mode 100644
index 0000000..6fb66c4
--- /dev/null
+++ b/app-admin/lsyncd/lsyncd-1.37.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/lsyncd/lsyncd-1.33.ebuild,v 1.3 2010/07/22 14:40:16 darkside Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="Live Syncing (Mirror) Daemon"
+HOMEPAGE="http://code.google.com/p/lsyncd/"
+SRC_URI="http://lsyncd.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="xml"
+
+DEPEND="xml? ( dev-libs/libxml2 )"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+
+src_configure() {
+ econf \
+ $(use_enable xml)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README TODO ChangeLog || die
+}