summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/openssl/files/openssl-1.0.2_beta2-revert-alpha-perl-generation.patch')
-rw-r--r--dev-libs/openssl/files/openssl-1.0.2_beta2-revert-alpha-perl-generation.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-libs/openssl/files/openssl-1.0.2_beta2-revert-alpha-perl-generation.patch b/dev-libs/openssl/files/openssl-1.0.2_beta2-revert-alpha-perl-generation.patch
new file mode 100644
index 0000000..9c3dbb7
--- /dev/null
+++ b/dev-libs/openssl/files/openssl-1.0.2_beta2-revert-alpha-perl-generation.patch
@@ -0,0 +1,65 @@
+https://bugs.gentoo.org/499086
+https://rt.openssl.org/Ticket/Display.html?id=3333&user=guest&pass=guest
+
+when gcc is given a .s file and told to preprocess it, it outputs nothing
+
+This reverts commit d1cf23ac86c05b22b8780e2c03b67230564d2d34.
+---
+ Makefile | 4 +---
+ bn/Makefile | 4 +---
+ modes/Makefile | 4 +---
+ sha/Makefile | 4 +---
+ 4 files changed, 4 insertions(+), 12 deletions(-)
+
+--- openssl-1.0.2-beta2/crypto/bn/Makefile
++++ openssl-1.0.2-beta2/crypto/bn/Makefile
+@@ -135,9 +135,7 @@
+ ppc64-mont.s: asm/ppc64-mont.pl;$(PERL) asm/ppc64-mont.pl $(PERLASM_SCHEME) $@
+
+ alpha-mont.s: asm/alpha-mont.pl
+- (preproc=/tmp/$$$$.$@; trap "rm $$preproc" INT; \
+- $(PERL) asm/alpha-mont.pl > $$preproc && \
+- $(CC) -E $$preproc > $@ && rm $$preproc)
++ $(PERL) $< | $(CC) -E - | tee $@ > /dev/null
+
+ # GNU make "catch all"
+ %-mont.S: asm/%-mont.pl; $(PERL) $< $(PERLASM_SCHEME) $@
+--- openssl-1.0.2-beta2/crypto/Makefile
++++ openssl-1.0.2-beta2/crypto/Makefile
+@@ -77,9 +77,7 @@
+ ppccpuid.s: ppccpuid.pl; $(PERL) ppccpuid.pl $(PERLASM_SCHEME) $@
+ pariscid.s: pariscid.pl; $(PERL) pariscid.pl $(PERLASM_SCHEME) $@
+ alphacpuid.s: alphacpuid.pl
+- (preproc=/tmp/$$$$.$@; trap "rm $$preproc" INT; \
+- $(PERL) alphacpuid.pl > $$preproc && \
+- $(CC) -E $$preproc > $@ && rm $$preproc)
++ $(PERL) $< | $(CC) -E - | tee $@ > /dev/null
+
+ testapps:
+ [ -z "$(THIS)" ] || ( if echo $(SDIRS) | fgrep ' des '; \
+--- openssl-1.0.2-beta2/crypto/modes/Makefile
++++ openssl-1.0.2-beta2/crypto/modes/Makefile
+@@ -55,9 +55,7 @@
+ ghash-sparcv9.s: asm/ghash-sparcv9.pl
+ $(PERL) asm/ghash-sparcv9.pl $@ $(CFLAGS)
+ ghash-alpha.s: asm/ghash-alpha.pl
+- (preproc=/tmp/$$$$.$@; trap "rm $$preproc" INT; \
+- $(PERL) asm/ghash-alpha.pl > $$preproc && \
+- $(CC) -E $$preproc > $@ && rm $$preproc)
++ $(PERL) $< | $(CC) -E - | tee $@ > /dev/null
+ ghash-parisc.s: asm/ghash-parisc.pl
+ $(PERL) asm/ghash-parisc.pl $(PERLASM_SCHEME) $@
+ ghashv8-armx.S: asm/ghashv8-armx.pl
+--- openssl-1.0.2-beta2/crypto/sha/Makefile
++++ openssl-1.0.2-beta2/crypto/sha/Makefile
+@@ -60,9 +60,7 @@
+ $(PERL) $< $(PERLASM_SCHEME) $@
+
+ sha1-alpha.s: asm/sha1-alpha.pl
+- (preproc=/tmp/$$$$.$@; trap "rm $$preproc" INT; \
+- $(PERL) asm/sha1-alpha.pl > $$preproc && \
+- $(CC) -E $$preproc > $@ && rm $$preproc)
++ $(PERL) $< | $(CC) -E - | tee $@ > /dev/null
+
+ # Solaris make has to be explicitly told
+ sha1-x86_64.s: asm/sha1-x86_64.pl; $(PERL) asm/sha1-x86_64.pl $(PERLASM_SCHEME) > $@