summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2014-10-03 14:54:18 -0400
committerJustin Riley <justin.t.riley@gmail.com>2014-10-03 14:54:18 -0400
commit79b868ed7663bff7bbcce715f5e682d29a5f0eeb (patch)
tree4d3050973d03f4c5635ee8e118d44af2076912e5
parenthipchat: bump to latest 2.2.1196 version (diff)
downloadjtriley-79b868ed7663bff7bbcce715f5e682d29a5f0eeb.tar.gz
jtriley-79b868ed7663bff7bbcce715f5e682d29a5f0eeb.tar.bz2
jtriley-79b868ed7663bff7bbcce715f5e682d29a5f0eeb.zip
add ebuild for latest hal-flash v0.3.0
-rw-r--r--media-libs/hal-flash/ChangeLog13
-rw-r--r--media-libs/hal-flash/Manifest1
-rw-r--r--media-libs/hal-flash/hal-flash-0.3.0.ebuild35
-rw-r--r--media-libs/hal-flash/metadata.xml8
4 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/hal-flash/ChangeLog b/media-libs/hal-flash/ChangeLog
new file mode 100644
index 0000000..98a1113
--- /dev/null
+++ b/media-libs/hal-flash/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for media-libs/hal-flash
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hal-flash/ChangeLog,v 1.2 2013/09/11 11:45:26 ssuominen Exp $
+
+ 11 Sep 2013; Samuli Suominen <ssuominen@gentoo.org>
+ hal-flash-0.2.0_rc1.ebuild:
+ amd64/x86 stable
+
+*hal-flash-0.2.0_rc1 (06 Aug 2013)
+
+ 06 Aug 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +hal-flash-0.2.0_rc1.ebuild:
+ Initial commit wrt #478480 by Alex Busenius
diff --git a/media-libs/hal-flash/Manifest b/media-libs/hal-flash/Manifest
new file mode 100644
index 0000000..f28eea4
--- /dev/null
+++ b/media-libs/hal-flash/Manifest
@@ -0,0 +1 @@
+DIST libhal1-flash_0.3.0.tar.gz 20334 SHA256 1aa1ae4facddbf44db91c9dd14673ed9ea6687c91fd58c9c6548319686c77798 SHA512 988294704c1efc476720f9da5d98d8ecde5cf48c9266089db5f9c4218e110481503acc8cbcb47e3345791afbbc3925845f13d17d410beb144602a4d54ba226fb WHIRLPOOL 42ce26dabbe3bb140524471af29c4fa2ccf490f1eae185a457279477678c9c5cd2cf857edc08f532796a2fa48acfd966cc5a94f982a6dcdb9e8ffe7a28460e0d
diff --git a/media-libs/hal-flash/hal-flash-0.3.0.ebuild b/media-libs/hal-flash/hal-flash-0.3.0.ebuild
new file mode 100644
index 0000000..530ebc2
--- /dev/null
+++ b/media-libs/hal-flash/hal-flash-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/hal-flash/hal-flash-0.2.0_rc1.ebuild,v 1.2 2013/09/11 11:45:26 ssuominen Exp $
+
+EAPI=5
+inherit autotools eutils
+
+MY_P=${PN/hal/libhal1}_${PV/_}
+
+DESCRIPTION="A libhal stub library forwarding to UDisks for www-plugins/adobe-flash to play DRM content"
+HOMEPAGE="http://github.com/cshorler/hal-flash http://build.opensuse.org/package/show/devel:openSUSE:Factory/hal-flash"
+SRC_URI="http://build.opensuse.org/package/rawsourcefile/devel:openSUSE:Factory/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="sys-apps/dbus
+ !sys-apps/hal"
+RDEPEND="${COMMON_DEPEND}
+ sys-fs/udisks:0"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+DOCS="README"
+
+#S=${WORKDIR}/${MY_P}
+
+src_prepare() { eautoreconf; }
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/media-libs/hal-flash/metadata.xml b/media-libs/hal-flash/metadata.xml
new file mode 100644
index 0000000..5854c2c
--- /dev/null
+++ b/media-libs/hal-flash/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+</pkgmetadata>