summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2013-07-26 13:25:43 -0400
committerJustin Riley <justin.t.riley@gmail.com>2013-07-26 13:25:43 -0400
commit824d34d1cacb34b982aecf7c5dfc6a4487df33cb (patch)
tree09e151debf0dc2b7ec6871979602b8a2e27738b9
parentadd new pywapi 0.2.2 ebuild (diff)
downloadjtriley-824d34d1cacb34b982aecf7c5dfc6a4487df33cb.tar.gz
jtriley-824d34d1cacb34b982aecf7c5dfc6a4487df33cb.tar.bz2
jtriley-824d34d1cacb34b982aecf7c5dfc6a4487df33cb.zip
add new ebuild for smtube 1.2.1
-rw-r--r--media-video/smtube/Manifest1
-rw-r--r--media-video/smtube/smtube-1.2.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/media-video/smtube/Manifest b/media-video/smtube/Manifest
new file mode 100644
index 0000000..00f0cd7
--- /dev/null
+++ b/media-video/smtube/Manifest
@@ -0,0 +1 @@
+DIST smtube-1.2.1.tar.bz2 304813 SHA256 939ae5af80c5100b22a329e0f81faa557095cfb25104bf05f5dbf2b9855d570f SHA512 3217766e5f0e15ed7e27d52ed68824206fa742663b226598109bf14299f3a393051988cf248f2ead0a45933959c7a48eec86cea3ca479b2cfd04deaca99344c0 WHIRLPOOL d006d72c24d4a19d00c542b807b3c27013be2f7330a5c3a867128663fd638a3ee6c0bc279627e33587a6e23cc469681d24ed7c382a1c1ece0716f91b903ffb7b
diff --git a/media-video/smtube/smtube-1.2.1.ebuild b/media-video/smtube/smtube-1.2.1.ebuild
new file mode 100644
index 0000000..ab11c0b
--- /dev/null
+++ b/media-video/smtube/smtube-1.2.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/smtube/smtube-1.0.ebuild,v 1.1 2012/03/03 14:15:10 pesa Exp $
+
+EAPI=4
+LANGS="es ja it"
+LANGSLONG="ru_RU"
+
+inherit eutils qt4-r2
+
+# regular upstream release
+SRC_URI="mirror://sourceforge/smplayer/${P}.tar.bz2"
+
+IUSE=""
+DESCRIPTION="A youtube search and play add-on for smplayer."
+HOMEPAGE="http://smplayer.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Upstream Makefile sucks
+ sed -i -e "/^PREFIX=/s:/usr/local:/usr:" \
+ -e "/^DOC_PATH=/s:smtube:${PF}:" \
+ -e '/\.\/get_svn_revision\.sh/,+2c\
+ cd src && $(DEFS) $(MAKE)' \
+ "${S}"/Makefile || die "sed failed"
+}
+
+src_configure() {
+ cd "${S}"/src
+ echo "#define SVN_REVISION \"SVN-${PV} (Gentoo)\"" > svn_revision.h
+ eqmake4
+}
+
+gen_translation() {
+ ebegin "Generating $1 translation"
+ lrelease ${PN}_${1}.ts
+ eend $? || die "failed to generate $1 translation"
+}
+
+src_compile() {
+ emake
+
+ # Generate translations
+ cd "${S}"/src/translations
+ local lang= nolangs= x=
+ for lang in ${LINGUAS}; do
+ if has ${lang} ${LANGS}; then
+ gen_translation ${lang}
+ continue
+ elif [[ " ${LANGSLONG} " == *" ${lang}_"* ]]; then
+ for x in ${LANGSLONG}; do
+ if [[ "${lang}" == "${x%_*}" ]]; then
+ gen_translation ${x}
+ continue 2
+ fi
+ done
+ fi
+ nolangs="${nolangs} ${lang}"
+ done
+ [[ -n ${nolangs} ]] && ewarn "Sorry, but ${PN} does not support the LINGUAS:" ${nolangs}
+ # install fails when no translation is present (bug 244370)
+ [[ -z $(ls *.qm 2>/dev/null) ]] && gen_translation en
+}
+
+src_install() {
+ # remove unneeded copies of GPL
+ rm -f Copying.txt Copying_BSD.txt
+
+ # remove windows-only files
+ rm "${S}"/*.bat || die
+
+ emake DESTDIR="${D}" install
+}