summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2014-04-14 23:37:14 -0400
committerJustin Riley <justin.t.riley@gmail.com>2014-04-14 23:37:14 -0400
commite4a08c2cb29ac3147f76f618c8d423339349f01e (patch)
tree3c99e235c5fc1833e632e781e09063947a2e2e52
parentcruft clean up (diff)
downloadjtriley-e4a08c2cb29ac3147f76f618c8d423339349f01e.tar.gz
jtriley-e4a08c2cb29ac3147f76f618c8d423339349f01e.tar.bz2
jtriley-e4a08c2cb29ac3147f76f618c8d423339349f01e.zip
key-mon: bump to latest 1.17
Bumped and modified ebuild from armageddon overlay. Moved from dev-python to app-misc category.
-rw-r--r--app-misc/key-mon/Manifest1
-rw-r--r--app-misc/key-mon/key-mon-1.17.ebuild60
-rw-r--r--dev-python/key-mon/Manifest1
-rw-r--r--dev-python/key-mon/key-mon-1.9.ebuild24
4 files changed, 61 insertions, 25 deletions
diff --git a/app-misc/key-mon/Manifest b/app-misc/key-mon/Manifest
new file mode 100644
index 0000000..e69a156
--- /dev/null
+++ b/app-misc/key-mon/Manifest
@@ -0,0 +1 @@
+DIST key-mon-1.17.tar.gz 228847 SHA256 b8d029b375e7f876d44db6b72ed3e7e6c0372a9e9dc21ea85d9055cc7a033fd2 SHA512 16b0a203a4f1df20ad7138f34359c4e0869a88fdaaa7660df891801ae1996572a07d3cf260c41f407d9c57242a2285a71bda26e0957f04e6dce3ea356af2a3e0 WHIRLPOOL 455101de81ff0cff628a483d302436a9b4ece8f5a3cd62b2073752253fa785a337741c04190faebe9f99c7394f0997bb35665d3e320c000d58b111e24aefa4c5
diff --git a/app-misc/key-mon/key-mon-1.17.ebuild b/app-misc/key-mon/key-mon-1.17.ebuild
new file mode 100644
index 0000000..f91c816
--- /dev/null
+++ b/app-misc/key-mon/key-mon-1.17.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_DEPEND="2"
+
+inherit python eutils fdo-mime
+
+DESCRIPTION="Keyboard Status Monitor"
+HOMEPAGE="https://code.google.com/p/key-mon/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ gnome-base/librsvg
+ dev-python/pygtk:2
+ dev-python/python-xlib
+ x11-proto/recordproto
+ x11-libs/gtk+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs 2 src/${PN}
+ python_convert_shebangs 2 src/keymon/*.py
+}
+
+src_install() {
+
+ insinto /usr/share/${PN}
+ doins -r src/*
+ fperms 755 /usr/share/${PN}/${PN}
+ dosym /usr/share/${PN}/${PN} /usr/bin/${PN}
+ doman man/${PN}.1
+ newdoc README.rst README
+ domenu icons/${PN}.desktop
+
+ insinto /usr/share/mime/packages/
+ doins icons/${PN}.xpm
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
diff --git a/dev-python/key-mon/Manifest b/dev-python/key-mon/Manifest
deleted file mode 100644
index c76338a..0000000
--- a/dev-python/key-mon/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST key-mon-1.9.tar.gz 154254 SHA256 e61c5abe35eaffd28cee8b8e7faf8821607c0ffe34a98090652979e9c30eddf8 SHA512 ae9aeb3af44126bed676e466d9d8fa3f86cbd2fee7a7df6b6cecf070c3fff282a9b5e7ad51d0bc1eb8ce6560127923320c2aa61563df2096f8f3702cfe4f28c9 WHIRLPOOL 936ded77720a3b573fed0f2a7074d31cf6495ca5020ae2f2c20e90bc5002c0ab8ad7bbd81fd3ea42bbc28901424f3c036e7a3312c83f0902ba957689dd8d9487
diff --git a/dev-python/key-mon/key-mon-1.9.ebuild b/dev-python/key-mon/key-mon-1.9.ebuild
deleted file mode 100644
index 3e4a3cf..0000000
--- a/dev-python/key-mon/key-mon-1.9.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=3
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils eutils
-
-DESCRIPTION="Utility to show live keyboard and mouse status for teaching and screencasts"
-HOMEPAGE="http://code.google.com/p/key-mon/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE=""
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-REPEND="dev-python/python-xlib
- dev-python/pygtk:2"
-DEPEND="${RDEPEND}"
-