summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2014-03-27 10:37:27 -0400
committerJustin Riley <justin.t.riley@gmail.com>2014-03-27 10:37:27 -0400
commitf5c10b6d0834c24d1f8e1bcb3d75e2c24978ef1a (patch)
tree392beb2354b051bd17d2bc73fc7fd46c24e5f915 /dev-util/cmake/files/cmake-2.8.0-darwin-default-install_name.patch
parentadd patched nmon-14i.ebuild (fixes #505114) (diff)
downloadjtriley-f5c10b6d0834c24d1f8e1bcb3d75e2c24978ef1a.tar.gz
jtriley-f5c10b6d0834c24d1f8e1bcb3d75e2c24978ef1a.tar.bz2
jtriley-f5c10b6d0834c24d1f8e1bcb3d75e2c24978ef1a.zip
cmake-2.8.12.2: fix ncurses tinfo bug #468622
Diffstat (limited to 'dev-util/cmake/files/cmake-2.8.0-darwin-default-install_name.patch')
-rw-r--r--dev-util/cmake/files/cmake-2.8.0-darwin-default-install_name.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-util/cmake/files/cmake-2.8.0-darwin-default-install_name.patch b/dev-util/cmake/files/cmake-2.8.0-darwin-default-install_name.patch
new file mode 100644
index 0000000..4ef0c7b
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.0-darwin-default-install_name.patch
@@ -0,0 +1,20 @@
+The install_name of a library can be compared to the ELF soname, setting
+it to just the library name (libx.1.dylib) is not sufficient on Mach-O,
+as it uses full paths. Most apps have no clue about that, so they don't
+do something like http://www.cmake.org/pipermail/cmake/2006-June/009758.html
+
+Provide a sane default that will allow merging most cmake-based
+packages. If this location is not correct, Portage's QA checks will
+catch that.
+
+--- Source/cmTarget.cxx
++++ Source/cmTarget.cxx
+@@ -974,7 +974,7 @@
+ this->Makefile->IsOn("MINGW"));
+
+ // Setup default property values.
+- this->SetPropertyDefault("INSTALL_NAME_DIR", "");
++ this->SetPropertyDefault("INSTALL_NAME_DIR", "${CMAKE_INSTALL_PREFIX}/lib");
+ this->SetPropertyDefault("INSTALL_RPATH", "");
+ this->SetPropertyDefault("INSTALL_RPATH_USE_LINK_PATH", "OFF");
+ this->SetPropertyDefault("SKIP_BUILD_RPATH", "OFF");