summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2014-03-27 10:37:27 -0400
committerJustin Riley <justin.t.riley@gmail.com>2014-03-27 10:37:27 -0400
commitf5c10b6d0834c24d1f8e1bcb3d75e2c24978ef1a (patch)
tree392beb2354b051bd17d2bc73fc7fd46c24e5f915 /dev-util/cmake/files/cmake-2.8.12.2-FindCurses.patch
parentadd patched nmon-14i.ebuild (fixes #505114) (diff)
downloadjtriley-f5c10b6d0834c24d1f8e1bcb3d75e2c24978ef1a.tar.gz
jtriley-f5c10b6d0834c24d1f8e1bcb3d75e2c24978ef1a.tar.bz2
jtriley-f5c10b6d0834c24d1f8e1bcb3d75e2c24978ef1a.zip
cmake-2.8.12.2: fix ncurses tinfo bug #468622
Diffstat (limited to 'dev-util/cmake/files/cmake-2.8.12.2-FindCurses.patch')
-rw-r--r--dev-util/cmake/files/cmake-2.8.12.2-FindCurses.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/cmake/files/cmake-2.8.12.2-FindCurses.patch b/dev-util/cmake/files/cmake-2.8.12.2-FindCurses.patch
new file mode 100644
index 0000000..17d4f94
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.12.2-FindCurses.patch
@@ -0,0 +1,42 @@
+--- Modules/FindCurses.cmake 2013-11-06 06:07:22.000000000 +1100
++++ Modules/FindCurses.cmake 2014-01-17 21:55:40.630142386 +1100
+@@ -30,7 +30,7 @@
+ find_library(CURSES_NCURSES_LIBRARY NAMES ncurses )
+ set(CURSES_USE_NCURSES FALSE)
+
+-if(CURSES_NCURSES_LIBRARY AND NOT CURSES_CURSES_LIBRARY)
++if(CURSES_NCURSES_LIBRARY AND ((NOT CURSES_CURSES_LIBRARY) OR CURSES_NEED_NCURSES))
+ set(CURSES_USE_NCURSES TRUE)
+ endif()
+ # http://cygwin.com/ml/cygwin-announce/2010-01/msg00002.html
+@@ -125,10 +125,20 @@
+ CACHE FILEPATH "The curses library" ${FORCE_IT})
+ endif()
+
++ CHECK_LIBRARY_EXISTS("${CURSES_NCURSES_LIBRARY}"
++ cbreak "" CURSES_NCURSES_HAS_CBREAK)
++ if(NOT CURSES_NCURSES_HAS_CBREAK)
++ find_library(CURSES_EXTRA_LIBRARY tinfo HINTS "${_cursesLibDir}")
++ find_library(CURSES_EXTRA_LIBRARY tinfo )
++ CHECK_LIBRARY_EXISTS("${CURSES_EXTRA_LIBRARY}"
++ cbreak "" CURSES_TINFO_HAS_CBREAK)
++ endif()
+ endif()
+
+-find_library(CURSES_EXTRA_LIBRARY cur_colr HINTS "${_cursesLibDir}")
+-find_library(CURSES_EXTRA_LIBRARY cur_colr )
++if (NOT CURSES_TINFO_HAS_CBREAK)
++ find_library(CURSES_EXTRA_LIBRARY cur_colr HINTS "${_cursesLibDir}")
++ find_library(CURSES_EXTRA_LIBRARY cur_colr )
++endif()
+
+ find_library(CURSES_FORM_LIBRARY form HINTS "${_cursesLibDir}")
+ find_library(CURSES_FORM_LIBRARY form )
+@@ -172,5 +182,7 @@
+ CURSES_INCLUDE_DIR
+ CURSES_CURSES_HAS_WSYNCUP
+ CURSES_NCURSES_HAS_WSYNCUP
++ CURSES_NCURSES_HAS_CBREAK
++ CURSES_TINFO_HAS_CBREAK
+ )
+