summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/ale/Manifest2
-rw-r--r--media-gfx/ale/ale-0.8.11.2.ebuild34
-rw-r--r--media-gfx/gscan2pdf/Manifest2
-rw-r--r--media-gfx/gscan2pdf/gscan2pdf-0.9.27.ebuild48
-rw-r--r--media-gfx/mumbles/Manifest3
-rw-r--r--media-gfx/mumbles/mumbles-0.4.1.ebuild31
-rw-r--r--media-gfx/xmorph/Manifest2
-rw-r--r--media-gfx/xmorph/xmorph-20090929.ebuild40
8 files changed, 162 insertions, 0 deletions
diff --git a/media-gfx/ale/Manifest b/media-gfx/ale/Manifest
new file mode 100644
index 0000000..a59b748
--- /dev/null
+++ b/media-gfx/ale/Manifest
@@ -0,0 +1,2 @@
+DIST ale-0.8.11.2.tar.gz 1373375 RMD160 f0aaec53befb5e9650fbd9fd2b77828d57b68833 SHA1 93d1e8a29a24d615b6d36868c26436cfe8ccf04e SHA256 bedea6f0d14b149b0b2419626182b7840a66f8bfa715ffddfd72dd57b125eefa
+EBUILD ale-0.8.11.2.ebuild 1186 RMD160 12d04378d1a210753ced3f8041597c749db519a1 SHA1 3263689b360b9d98a02f0c60a4eaad14e5ad643c SHA256 08260ea03d4373fe67ae9beaf82c2ba85430518c6a2091b8473cb96e57cac620
diff --git a/media-gfx/ale/ale-0.8.11.2.ebuild b/media-gfx/ale/ale-0.8.11.2.ebuild
new file mode 100644
index 0000000..6803fb0
--- /dev/null
+++ b/media-gfx/ale/ale-0.8.11.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="ALE (Anti-Lamenessing Engine) is an image-processing program used for tasks such as image mosaicking, super-resolution, deblurring, noise reduction, anti-aliasing, and scene reconstruction."
+HOMEPAGE="http://auricle.dyndns.org/ALE/"
+SRC_URI="http://auricle.dyndns.org/ALE/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="fftw imagemagick doc"
+RDEPEND="fftw? ( =sci-libs/fftw-3* )
+ imagemagick? ( media-gfx/imagemagick )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook-sgml-utils )"
+
+src_compile() {
+ econf $(use_with imagemagick) $(use_with fftw fftw3) --enable-wmx \
+ || die "econf failed"
+ emake || die "emake failed"
+ use doc && (emake -C doc chunk || die "emake chunk failed")
+}
+
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ if use doc; then
+ # I don't know why it creates a .html for index, but it's bad
+ cp -f doc/index/.html doc/index/index.html
+ dohtml doc/index/* || die "dohtml failed"
+ fi
+}
diff --git a/media-gfx/gscan2pdf/Manifest b/media-gfx/gscan2pdf/Manifest
new file mode 100644
index 0000000..13dc6dd
--- /dev/null
+++ b/media-gfx/gscan2pdf/Manifest
@@ -0,0 +1,2 @@
+DIST gscan2pdf-0.9.27.tar.gz 358356 RMD160 f62a4f3cf5f630f425a824c265a6f27f1b6223a0 SHA1 802618c9b0273ac0951ddf5f95c0355e3e2d5fdf SHA256 a28a7ff8a7453d722b0572a2f43a464dbe14971f97190d14a61386221fae439d
+EBUILD gscan2pdf-0.9.27.ebuild 1173 RMD160 481928eee4d416e39c3793ce633f080f7b07c1c2 SHA1 ed1e5bdadd0318cc9ec4e5691a7b4237fe8d6038 SHA256 204c54cbdb486d574eefdc2d5ce7df317b52bc84f8a42169e17eedaeb49b437d
diff --git a/media-gfx/gscan2pdf/gscan2pdf-0.9.27.ebuild b/media-gfx/gscan2pdf/gscan2pdf-0.9.27.ebuild
new file mode 100644
index 0000000..ae3bb80
--- /dev/null
+++ b/media-gfx/gscan2pdf/gscan2pdf-0.9.27.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+inherit perl-app
+
+DESCRIPTION="Create PDF of selected pages with File/Save PDF"
+HOMEPAGE="http://gscan2pdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="adf doc djvu gocr tesseract unpaper +xdg"
+
+DEPEND="dev-lang/perl
+ >=dev-perl/config-general-2.40"
+
+RDEPEND=">=dev-perl/gtk2-perl-1.140-r1
+ dev-perl/PDF-API2
+ dev-perl/Gtk2-Ex-Simple-List
+ dev-perl/Gtk2-ImageView
+ dev-perl/Sane
+ dev-perl/prefork
+ >=dev-perl/Locale-gettext-1.05
+ media-gfx/imagemagick[perl]
+ media-gfx/sane-backends
+ media-libs/tiff
+ xdg? ( x11-misc/xdg-utils )
+ adf? ( media-gfx/sane-frontends )
+ doc? ( dev-perl/Gtk2-Ex-PodViewer )
+ djvu? ( app-text/djvu )
+ gocr? ( app-text/gocr )
+ tesseract? ( app-text/tesseract )
+ unpaper? ( media-gfx/unpaper )"
+
+src_install() {
+ perl-module_src_install
+ dodoc History
+}
+
+pkg_postinst() {
+ ewarn "Thunderbird users can't use the Email to PDF feature"
+ ewarn "because xdg-email doesn't support creating new emails"
+ ewarn "with attachments in Thunderbird."
+}
+
diff --git a/media-gfx/mumbles/Manifest b/media-gfx/mumbles/Manifest
new file mode 100644
index 0000000..fa275a7
--- /dev/null
+++ b/media-gfx/mumbles/Manifest
@@ -0,0 +1,3 @@
+DIST mumbles_0.4-1.tar.gz 78620 RMD160 ed563462242ed55812ac682eb5bb2e899a404488 SHA1 785f8b67c8aecc699750019e97b05a2d5b184bc5 SHA256 c2b741a9a0b54580833fa5a64fd129e964d261f852b34c63d6b42f3744920a94
+EBUILD mumbles-0.4.1.ebuild 858 RMD160 91288dc4feed411e87e90763af3f680dfa0c9c73 SHA1 4a4a6b3bbd9b491a77935b869e075a941ac4ca47 SHA256 c41bb2476843f0b06498fd716dbe597b800d1549d5b86d4afa915bbc45210e04
+MISC mumbles-0.4.1.ebuild~ 858 RMD160 8f15c937f43b5cd51bed302265f2587c5f5d7301 SHA1 3fd8090d2901235c1daeb2dd483a6ec954a348a9 SHA256 4001e4ccd76f6cbf01bb81ebf4e4516ed5d2fb38749558eb5944683b63939b15
diff --git a/media-gfx/mumbles/mumbles-0.4.1.ebuild b/media-gfx/mumbles/mumbles-0.4.1.ebuild
new file mode 100644
index 0000000..c78335a
--- /dev/null
+++ b/media-gfx/mumbles/mumbles-0.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils versionator
+SOURCE_PV=$(replace_version_separator 2 '-')
+UNPACK_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="A modern notification system, similar to libnotify or Growl on OSX"
+HOMEPAGE="http://www.mumbles-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${SOURCE_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${UNPACK_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+#Depends: python-glade2
+
+RDEPEND=" >=dev-python/pygtk-2.8
+ dev-python/pycairo
+ dev-python/dbus-python"
+DEPEND=" dev-python/setuptools"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's@"/usr/share/python-support/mumbles/src/"@"/usr/lib/python2.5/site-packages/src/"@' \
+ bin/mumbles bin/mumbles-send || die "sed failed"
+}
diff --git a/media-gfx/xmorph/Manifest b/media-gfx/xmorph/Manifest
new file mode 100644
index 0000000..9d2c1c7
--- /dev/null
+++ b/media-gfx/xmorph/Manifest
@@ -0,0 +1,2 @@
+DIST xmorph_20090926.tar.gz 1576680 RMD160 9c15f3a0dc72dd76375aa12e05f6068a8d5105ad SHA1 658fd5301c5eb592c4007dddf4b874febf1adf78 SHA256 24b4b8476ca70815a117cf2c440ab118d1ec345f8198aa8869281659908138d9
+EBUILD xmorph-20090929.ebuild 943 RMD160 8aaa5d4c2a5ce63d5c8a90221a436eae4fc5b574 SHA1 9e2e752d08d441caab52473ffb08a3151be59708 SHA256 5293f3ed0e473a09f99a22e4ecba1274609cf2314d7ed7712d1c0cc22a4b6d13
diff --git a/media-gfx/xmorph/xmorph-20090929.ebuild b/media-gfx/xmorph/xmorph-20090929.ebuild
new file mode 100644
index 0000000..340d53c
--- /dev/null
+++ b/media-gfx/xmorph/xmorph-20090929.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Library that implements digital image warping, known as morphing, along with GUIs."
+HOMEPAGE="http://xmorph.sourceforge.net/"
+SRC_URI="http://ftp.de.debian.org/debian/pool/main/x/xmorph/xmorph_20090926.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="gtk nls fftw"
+# Options I'm ignoring:
+# --with-waili --with-xmorph --with-tkmorph
+
+# --disable-gtktest \
+# --without-gtkmorph \
+
+RDEPEND="nls? ( virtual/libintl )
+ gtk? ( x11-libs/gtk+ )"
+
+DEPEND="nls? ( sys-devel/gettext )
+ gtk? ( x11-libs/gtk+ )
+ fftw? ( >=sci-libs/fftw-3 )"
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gtk gtkmorph) \
+ $(use_with fftw) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+}