summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2012-04-12 17:37:03 +0200
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2012-04-12 17:37:03 +0200
commit99c7a989e91ab1f516ef35e489bc8bbf0ea682ba (patch)
tree86c5e4748adbe14bcf0938f8582dcd296c122d5f /sys-apps
parentupdate gpaste (diff)
downloadkeruspe-99c7a989e91ab1f516ef35e489bc8bbf0ea682ba.tar.gz
keruspe-99c7a989e91ab1f516ef35e489bc8bbf0ea682ba.tar.bz2
keruspe-99c7a989e91ab1f516ef35e489bc8bbf0ea682ba.zip
I do not maintain this stuff anymore
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/baselayout/Manifest2
-rw-r--r--sys-apps/baselayout/baselayout-2.1-r1.ebuild221
-rw-r--r--sys-apps/gnome-disk-utility/Manifest1
-rw-r--r--sys-apps/gnome-disk-utility/gnome-disk-utility-9999-r1.ebuild58
-rw-r--r--sys-apps/paludis/Manifest3
-rw-r--r--sys-apps/paludis/files/0001-paludis-sort-world.patch212
-rw-r--r--sys-apps/paludis/files/0002-cave-resolve-ask.patch171
-rw-r--r--sys-apps/paludis/paludis-9999.ebuild138
-rw-r--r--sys-apps/systemd/Manifest1
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild172
10 files changed, 0 insertions, 979 deletions
diff --git a/sys-apps/baselayout/Manifest b/sys-apps/baselayout/Manifest
deleted file mode 100644
index 9ddf43ae..00000000
--- a/sys-apps/baselayout/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST baselayout-2.1.tar.bz2 40398 RMD160 bba874c5d3290848236703125c130107c1244f55 SHA1 84783a773ec050700b3b0ce4c7645ae878f7f7fb SHA256 2ac6f2156513a2820a0eeeecc2cf7e7c0b5e0c750b324f1e21912d5f3cda4956
-EBUILD baselayout-2.1-r1.ebuild 7586 RMD160 6313622f636cec9a22d7447a9771a48885a6ce06 SHA1 2ab68da0981f80362a5d5ac76184d2700b88c5b8 SHA256 4258dacd78aed797d67bac51091c8a6b4296746a8a31c8fe20ca6874c80aaeb7
diff --git a/sys-apps/baselayout/baselayout-2.1-r1.ebuild b/sys-apps/baselayout/baselayout-2.1-r1.ebuild
deleted file mode 100644
index d4c89714..00000000
--- a/sys-apps/baselayout/baselayout-2.1-r1.ebuild
+++ /dev/null
@@ -1,221 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils multilib
-
-DESCRIPTION="Filesystem baselayout and init scripts"
-HOMEPAGE="http://www.gentoo.org/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~vapier/dist/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="build +openrc"
-
-PDEPEND="openrc? ( sys-apps/openrc )
- !openrc? ( sys-apps/systemd )"
-
-pkg_setup() {
- multilib_layout
-}
-
-# Create our multilib dirs - the Makefile has no knowledge of this
-multilib_warn() {
- local syms=$1 dirs=$2 def_libdir=$3
-
- [ -z "${syms}${dirs}" ] && return
-
- ewarn "Your system profile has SYMLINK_LIB=${SYMLINK_LIB}, so that means"
- if [ -z "${syms}" ] ; then
- ewarn "you need to have these paths as symlinks to ${def_libdir}:"
- ewarn "$1"
- fi
-}
-multilib_layout() {
- local libdir libdirs=$(get_all_libdirs) def_libdir=$(get_abi_LIBDIR $DEFAULT_ABI)
- : ${libdirs:=lib} # it isn't that we don't trust multilib.eclass...
-
- [ -z "${def_libdir}" ] && die "your DEFAULT_ABI=$DEFAULT_ABI appears to be invalid"
-
- # figure out which paths should be symlinks and which should be directories
- local dirs syms exp d
- for libdir in ${libdirs} ; do
- exp=( {,usr/,usr/local/}${libdir} )
- for d in "${exp[@]/#/${ROOT}}" ; do
- # most things should be dirs
- if [ "${SYMLINK_LIB}" = "yes" ] && [ "${libdir}" = "lib" ] ; then
- [ ! -h "${d}" ] && [ -e "${d}" ] && dirs+=" ${d}"
- else
- [ -h "${d}" ] && syms+=" ${d}"
- fi
- done
- done
- if [ -n "${syms}${dirs}" ] ; then
- ewarn "Your system profile has SYMLINK_LIB=${SYMLINK_LIB:-no}, so that means you need to"
- ewarn "have these paths configured as follows:"
- [ -n "${dirs}" ] && ewarn "symlinks to '${def_libdir}':${dirs}"
- [ -n "${syms}" ] && ewarn "directories:${syms}"
- ewarn "The ebuild will attempt to fix these, but only for trivial conversions."
- ewarn "If things fail, you will need to manually create/move the directories."
- echo
- fi
-
- # setup symlinks and dirs where we expect them to be; do not migrate
- # data ... just fall over in that case.
- local prefix
- for prefix in "${ROOT}"{,usr/,usr/local/} ; do
- if [ "${SYMLINK_LIB}" = yes ] ; then
- # we need to make sure "lib" points to the native libdir
- if [ -h "${prefix}lib" ] ; then
- # it's already a symlink! assume it's pointing to right place ...
- continue
- elif [ -d "${prefix}lib" ] ; then
- # "lib" is a dir, so need to convert to a symlink
- ewarn "Converting ${prefix}lib from a dir to a symlink"
- rm -f "${prefix}lib"/.keep
- if rmdir "${prefix}lib" 2>/dev/null ; then
- ln -s ${def_libdir} "${prefix}lib" || die
- else
- die "non-empty dir found where we needed a symlink: ${prefix}lib"
- fi
- else
- # nothing exists, so just set it up sanely
- ewarn "Initializing ${prefix}lib as a symlink"
- mkdir -p "${prefix}" || die
- rm -f "${prefix}lib" || die
- ln -s ${def_libdir} "${prefix}lib" || die
- fi
- else
- # we need to make sure "lib" is a dir
- if [ -h "${prefix}lib" ] ; then
- # "lib" is a symlink, so need to convert to a dir
- ewarn "Converting ${prefix}lib from a symlink to a dir"
- rm -f "${prefix}lib" || die
- if [ -d "${prefix}lib32" ] ; then
- ewarn "Migrating ${prefix}lib32 to ${prefix}lib"
- mv "${prefix}lib32" "${prefix}lib" || die
- else
- mkdir -p "${prefix}lib" || die
- fi
- elif [ -d "${prefix}lib" ] ; then
- # make sure the old "lib" ABI location does not exist; we
- # only symlinked the lib dir on systems where we moved it
- # to "lib32" ...
- case ${CHOST} in
- i?86*|x86_64*|powerpc*|sparc*|s390*)
- if [ -d "${prefix}lib32" ] ; then
- rm -f "${prefix}lib32"/.keep
- if ! rmdir "${prefix}lib32" 2>/dev/null ; then
- ewarn "You need to merge ${prefix}lib32 into ${prefix}lib"
- die "non-empty dir found where there should be none: ${prefix}lib32"
- fi
- fi
- ;;
- esac
- else
- # nothing exists, so just set it up sanely
- ewarn "Initializing ${prefix}lib as a dir"
- mkdir -p "${prefix}" || die
- rm -f "${prefix}lib" || die
- ln -s ${def_libdir} "${prefix}lib" || die
- fi
- fi
- done
-}
-
-pkg_preinst() {
- # Bug #217848 - Since the remap_dns_vars() called by pkg_preinst() of
- # the baselayout-1.x ebuild copies all the real configs from the user's
- # /etc/conf.d into ${D}, it makes them all appear to be the default
- # versions. In order to protect them from being unmerged after this
- # upgrade, modify their timestamps.
- touch "${ROOT}"/etc/conf.d/* 2>/dev/null
-
- # This is written in src_install (so it's in CONTENTS), but punt all
- # pending updates to avoid user having to do etc-update (and make the
- # pkg_postinst logic simpler).
- rm -f "${ROOT}"/etc/._cfg????_gentoo-release
-
- # We need to install directories and maybe some dev nodes when building
- # stages, but they cannot be in CONTENTS.
- # Also, we cannot reference $S as binpkg will break so we do this.
- multilib_layout
- if use build ; then
- emake -C "${D}/usr/share/${PN}" DESTDIR="${ROOT}" layout || die
- fi
- rm -f "${D}"/usr/share/${PN}/Makefile
-}
-
-src_install() {
- emake \
- OS=$(usex kernel_FreeBSD BSD Linux) \
- DESTDIR="${D}" \
- install || die
- dodoc ChangeLog.svn
-
- # need the makefile in pkg_preinst
- insinto /usr/share/${PN}
- doins Makefile || die
-
- # handle multilib paths. do it here because we want this behavior
- # regardless of the C library that you're using. we do explicitly
- # list paths which the native ldconfig searches, but this isn't
- # problematic as it doesn't change the resulting ld.so.cache or
- # take longer to generate. similarly, listing both the native
- # path and the symlinked path doesn't change the resulting cache.
- local libdir ldpaths
- for libdir in $(get_all_libdirs) ; do
- ldpaths+=":/${libdir}:/usr/${libdir}:/usr/local/${libdir}"
- done
- echo "LDPATH='${ldpaths#:}'" >> "${D}"/etc/env.d/00basic
-
- # rc-scripts version for testing of features that *should* be present
- echo "Gentoo Base System release ${PV}" > "${D}"/etc/gentoo-release
-}
-
-pkg_postinst() {
- local x
-
- # We installed some files to /usr/share/baselayout instead of /etc to stop
- # (1) overwriting the user's settings
- # (2) screwing things up when attempting to merge files
- # (3) accidentally packaging up personal files with quickpkg
- # If they don't exist then we install them
- for x in master.passwd passwd shadow group fstab ; do
- [ -e "${ROOT}etc/${x}" ] && continue
- [ -e "${ROOT}usr/share/baselayout/${x}" ] || continue
- cp -p "${ROOT}usr/share/baselayout/${x}" "${ROOT}"etc
- done
-
- # Force shadow permissions to not be world-readable #260993
- for x in shadow ; do
- [ -e "${ROOT}etc/${x}" ] && chmod o-rwx "${ROOT}etc/${x}"
- done
-
- # Take care of the etc-update for the user
- if [ -e "${ROOT}"/etc/._cfg0000_gentoo-release ] ; then
- mv "${ROOT}"/etc/._cfg0000_gentoo-release "${ROOT}"/etc/gentoo-release
- fi
-
- # whine about users that lack passwords #193541
- if [[ -e ${ROOT}/etc/shadow ]] ; then
- local bad_users=$(sed -n '/^[^:]*::/s|^\([^:]*\)::.*|\1|p' "${ROOT}"/etc/shadow)
- if [[ -n ${bad_users} ]] ; then
- echo
- ewarn "The following users lack passwords!"
- ewarn ${bad_users}
- fi
- fi
-
- # whine about users with invalid shells #215698
- if [[ -e ${ROOT}/etc/passwd ]] ; then
- local bad_shells=$(awk -F: 'system("test -e " $7) { print $1 " - " $7}' /etc/passwd | sort)
- if [[ -n ${bad_shells} ]] ; then
- echo
- ewarn "The following users have non-existent shells!"
- ewarn "${bad_shells}"
- fi
- fi
-}
diff --git a/sys-apps/gnome-disk-utility/Manifest b/sys-apps/gnome-disk-utility/Manifest
deleted file mode 100644
index 471ffcd2..00000000
--- a/sys-apps/gnome-disk-utility/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-EBUILD gnome-disk-utility-9999-r1.ebuild 1147 RMD160 56430f353794d3b5fa99ea1d7b086ec1b06e713f SHA1 ef582dcaa77258eb996acfeffa314669c5f232fd SHA256 5f69ea2544787cd036f55b7ac385c65a4d15224205b551bc6f3ab44bde5d3a8e
diff --git a/sys-apps/gnome-disk-utility/gnome-disk-utility-9999-r1.ebuild b/sys-apps/gnome-disk-utility/gnome-disk-utility-9999-r1.ebuild
deleted file mode 100644
index 2bda6f56..00000000
--- a/sys-apps/gnome-disk-utility/gnome-disk-utility-9999-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit autotools eutils gnome2-live
-
-DESCRIPTION="Disk Utility for GNOME using devicekit-disks"
-HOMEPAGE="http://git.gnome.org/browse/gnome-disk-utility"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE="doc fat"
-KEYWORDS=""
-
-CDEPEND="
- >=dev-libs/glib-2.22:2
- >=dev-libs/dbus-glib-0.74
- >=dev-libs/libunique-2.90.1:3
- >=x11-libs/gtk+-2.90.7:3
- >=sys-fs/udisks-1.92
- >=dev-libs/libatasmart-0.14
- >=x11-libs/libnotify-0.6.1
-"
-RDEPEND="${CDEPEND}
- x11-misc/xdg-utils
- fat? ( sys-fs/dosfstools )
- !!sys-apps/udisks"
-DEPEND="${CDEPEND}
- sys-devel/gettext
- gnome-base/gnome-common
- app-text/docbook-xml-dtd:4.1.2
- app-text/scrollkeeper
- app-text/gnome-doc-utils
-
- >=dev-util/pkgconfig-0.9
- >=dev-util/intltool-0.35
- >=dev-util/gtk-doc-am-1.13
-
- doc? ( >=dev-util/gtk-doc-1.3 )"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --disable-static"
- DOCS="AUTHORS NEWS README"
-}
-
-src_prepare() {
- if [[ ${PV} != 9999 ]]; then
- intltoolize --force --copy --automake || die
- eautoreconf
- fi
-
- gnome2_src_prepare
-}
diff --git a/sys-apps/paludis/Manifest b/sys-apps/paludis/Manifest
deleted file mode 100644
index 0f9814f2..00000000
--- a/sys-apps/paludis/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX 0001-paludis-sort-world.patch 6309 RMD160 aed7ebcd6584cb48c9078b7b0f25686c8bd7c16a SHA1 ca105295391c8869f4f1a38b7689d08efdcc6a0a SHA256 b1f40b94776ea05d109d6b8c6ae3abf31cb362f5241beac8c3e30adb605f7650
-AUX 0002-cave-resolve-ask.patch 8415 RMD160 a55cb8150249bc233d0efc28d09590d8dd223d6c SHA1 ac8f552a2897b28228e87868f7271a078ee2bd2a SHA256 639174143d6b1d0ba47676f60e767a9b7e5b715eb452e32e8381a818ad3a11b5
-EBUILD paludis-9999.ebuild 3830 RMD160 dcfbd73cfd210b3dcc8df49214712fee3aaba116 SHA1 03cc83dc8df5bd22fd39c2ab1ddc8f49ea647511 SHA256 f2264354d58133b74aed3886dd5221259f6c3baece0c5256d9f851b8f4c38a39
diff --git a/sys-apps/paludis/files/0001-paludis-sort-world.patch b/sys-apps/paludis/files/0001-paludis-sort-world.patch
deleted file mode 100644
index f2f96a82..00000000
--- a/sys-apps/paludis/files/0001-paludis-sort-world.patch
+++ /dev/null
@@ -1,212 +0,0 @@
-From d8c939211426b1754fc8c28f5c6d5f9e11c54842 Mon Sep 17 00:00:00 2001
-From: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
-Date: Mon, 26 Jul 2010 18:17:27 +0200
-Subject: [PATCH 1/2] paludis sort world
-
----
- paludis/environments/paludis/world.cc | 2 +
- paludis/environments/paludis/world_TEST.cc | 4 +-
- paludis/environments/paludis/world_TEST_setup.sh | 4 +-
- paludis/set_file.cc | 56 ++++++++++++++++++++++
- paludis/set_file.hh | 5 ++
- 5 files changed, 67 insertions(+), 4 deletions(-)
-
-diff --git a/paludis/environments/paludis/world.cc b/paludis/environments/paludis/world.cc
-index b546d4f..8d281e9 100644
---- a/paludis/environments/paludis/world.cc
-+++ b/paludis/environments/paludis/world.cc
-@@ -123,6 +123,7 @@ World::_add_string_to_world(const std::string & n) const
- n::type() = sft_simple
- ));
- bool result(world.add(n));
-+ world.sort();
- world.rewrite();
-
- return result;
-@@ -156,6 +157,7 @@ World::_remove_string_from_world(const std::string & n) const
- ));
-
- result = world.remove(n);
-+ world.sort();
- world.rewrite();
- }
-
-diff --git a/paludis/environments/paludis/world_TEST.cc b/paludis/environments/paludis/world_TEST.cc
-index cbb2f7f..237d1df 100644
---- a/paludis/environments/paludis/world_TEST.cc
-+++ b/paludis/environments/paludis/world_TEST.cc
-@@ -47,9 +47,9 @@ TEST(World, Updates)
- SafeIFStream f(*w);
- std::string ff((std::istreambuf_iterator<char>(f)), std::istreambuf_iterator<char>());
- EXPECT_EQ(
-- "cat/unchanged\n"
-+ "cat/after\n"
- "cat/alsounchanged\n"
-- "cat/after\n",
-+ "cat/unchanged\n",
- ff
- );
- }
-diff --git a/paludis/environments/paludis/world_TEST_setup.sh b/paludis/environments/paludis/world_TEST_setup.sh
-index f81a62b..0d8916c 100755
---- a/paludis/environments/paludis/world_TEST_setup.sh
-+++ b/paludis/environments/paludis/world_TEST_setup.sh
-@@ -5,8 +5,8 @@ mkdir world_TEST_dir || exit 2
- cd world_TEST_dir || exit 3
-
- cat <<END > world
--cat/unchanged
--cat/before
- cat/alsounchanged
-+cat/before
-+cat/unchanged
- END
-
-diff --git a/paludis/set_file.cc b/paludis/set_file.cc
-index 646ccf4..f786c5d 100644
---- a/paludis/set_file.cc
-+++ b/paludis/set_file.cc
-@@ -60,12 +60,15 @@ namespace
- protected:
- SetFileHandler();
-
-+ static bool compareNoCase(const std::string &, const std::string &);
-+
- public:
- virtual ~SetFileHandler();
-
- virtual std::shared_ptr<SetSpecTree> contents() const = 0;
- virtual bool add(const std::string &) = 0;
- virtual bool remove(const std::string &) = 0;
-+ virtual void sort() = 0;
- virtual void rewrite() const = 0;
- };
-
-@@ -87,6 +90,7 @@ namespace
- virtual std::shared_ptr<SetSpecTree> contents() const;
- virtual bool add(const std::string &);
- virtual bool remove(const std::string &);
-+ virtual void sort();
- virtual void rewrite() const;
- };
-
-@@ -103,6 +107,7 @@ namespace
- virtual std::shared_ptr<SetSpecTree> contents() const;
- virtual bool add(const std::string &) PALUDIS_ATTRIBUTE((noreturn));
- virtual bool remove(const std::string &) PALUDIS_ATTRIBUTE((noreturn));
-+ virtual void sort() PALUDIS_ATTRIBUTE((noreturn));
- virtual void rewrite() const PALUDIS_ATTRIBUTE((noreturn));
- };
-
-@@ -124,6 +129,7 @@ namespace
- virtual std::shared_ptr<SetSpecTree> contents() const;
- virtual bool add(const std::string &);
- virtual bool remove(const std::string &);
-+ virtual void sort();
- virtual void rewrite() const;
- };
-
-@@ -303,6 +309,22 @@ SetFileHandler::~SetFileHandler()
- {
- }
-
-+bool
-+SetFileHandler::compareNoCase(const std::string & first, const std::string & second)
-+{
-+ for (unsigned int i(0) ; i < first.length() && i < second.length() ; ++i)
-+ {
-+ if (tolower(first[i]) < tolower(second[i]))
-+ return true;
-+ else if (tolower(first[i]) > tolower(second[i]))
-+ return false;
-+ }
-+ if (first.length() < second.length())
-+ return true;
-+ return false;
-+}
-+
-+
- SimpleHandler::SimpleHandler(const SetFileParams & p) :
- _p(p)
- {
-@@ -408,6 +430,17 @@ SimpleHandler::remove(const std::string & p)
- }
-
- void
-+SimpleHandler::sort()
-+{
-+ Lock l(_mutex);
-+
-+ Context context("When sorting simple set file '" + stringify(_p.file_name()) + "':");
-+
-+ _lines.sort(SetFileHandler::compareNoCase);
-+ _contents.reset();
-+}
-+
-+void
- SimpleHandler::rewrite() const
- {
- Lock l(_mutex);
-@@ -501,6 +534,17 @@ PaludisConfHandler::remove(const std::string & p)
- }
-
- void
-+PaludisConfHandler::sort()
-+{
-+ Context context("When sorting paludis conf set file '" + stringify(_p.file_name()) + "':");
-+
-+ Lock l(_mutex);
-+
-+ _lines.sort(SetFileHandler::compareNoCase);
-+ _contents.reset();
-+}
-+
-+void
- PaludisConfHandler::rewrite() const
- {
- Context context("When rewriting paludis conf set file '" + stringify(_p.file_name()) + "':");
-@@ -572,6 +616,12 @@ PaludisBashHandler::remove(const std::string & p)
- }
-
- void
-+PaludisBashHandler::sort()
-+{
-+ throw SetFileError(_p.file_name(), "Cannot modify bash script '" + stringify(_p.file_name()) + "'");
-+}
-+
-+void
- PaludisBashHandler::rewrite() const
- {
- throw SetFileError(_p.file_name(), "Cannot modify bash script '" + stringify(_p.file_name()) + "'");
-@@ -609,6 +659,12 @@ SetFile::contents() const
- }
-
- void
-+SetFile::sort()
-+{
-+ _imp->handler->sort();
-+}
-+
-+void
- SetFile::rewrite() const
- {
- _imp->handler->rewrite();
-diff --git a/paludis/set_file.hh b/paludis/set_file.hh
-index e3a853c..019ccbb 100644
---- a/paludis/set_file.hh
-+++ b/paludis/set_file.hh
-@@ -132,6 +132,11 @@ namespace paludis
- const std::shared_ptr<const SetSpecTree> contents() const;
-
- /**
-+ * Sort our contents.
-+ */
-+ void sort();
-+
-+ /**
- * Rewrite our contents.
- */
- void rewrite() const;
---
-1.7.6.rc2.8.g28eb.dirty
-
diff --git a/sys-apps/paludis/files/0002-cave-resolve-ask.patch b/sys-apps/paludis/files/0002-cave-resolve-ask.patch
deleted file mode 100644
index f37cef54..00000000
--- a/sys-apps/paludis/files/0002-cave-resolve-ask.patch
+++ /dev/null
@@ -1,171 +0,0 @@
-From e579288be34f2effad95c854c6e5cd2d2cf4b7ab Mon Sep 17 00:00:00 2001
-From: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
-Date: Mon, 26 Jul 2010 18:38:14 +0200
-Subject: [PATCH 2/2] cave resolve ask
-
----
- doc/faq/misfunctionality.html.part | 9 ---------
- src/clients/cave/cmd_execute_resolution.cc | 28 +++++++++++++++++++++++++++-
- src/clients/cave/cmd_resolve.cc | 6 +++---
- src/clients/cave/resolve_cmdline.cc | 1 +
- src/clients/cave/resolve_cmdline.hh | 1 +
- src/clients/cave/resolve_common.cc | 2 ++
- zsh-completion/_cave | 1 +
- 7 files changed, 35 insertions(+), 13 deletions(-)
-
-diff --git a/doc/faq/misfunctionality.html.part b/doc/faq/misfunctionality.html.part
-index a43287f..ef6ba64 100644
---- a/doc/faq/misfunctionality.html.part
-+++ b/doc/faq/misfunctionality.html.part
-@@ -6,7 +6,6 @@
- <li><a href="misfunctionality.html#wgetresume">wget Resume Support</a></li>
- <li><a href="misfunctionality.html#skipfirst">Build Resume / Skip First Support</a></li>
- <li><a href="misfunctionality.html#nice">No Automatic Niceness Support</a></li>
-- <li><a href="misfunctionality.html#ask">No Ask Support</a></li>
- <li><a href="misfunctionality.html#xtermtitles">Restoring XTerm Titles</a></li>
- <li><a href="misfunctionality.html#ecompress">No Automatic Manpage / Documentation Compression</a></li>
- </ul>
-@@ -63,14 +62,6 @@ elegant.</p>
- <p>Rationale: Learn how to use <code>nice</code>. There's no
- <code>GCC_NICENESS</code> or <code>VIM_NICENESS</code> either.</p>
-
--<h2 id="ask">No Ask Support</h2>
--
--<p>Non-Problem: There's nothing like <code>emerge --ask</code>.</p>
--
--<p>Rationale: the <code>paludis</code> client is non-interactive. If someone is
--making an interactive client, there are much better ways of doing it than
--the limited functionality that <code>emerge --ask</code> provides.</p>
--
- <h2 id="xtermtitles">Restoring XTerm Titles</h2>
-
- <p>Non-Problem: Paludis doesn't restore the xterm title on exit.</p>
-diff --git a/src/clients/cave/cmd_execute_resolution.cc b/src/clients/cave/cmd_execute_resolution.cc
-index b9b71c1..568af40 100644
---- a/src/clients/cave/cmd_execute_resolution.cc
-+++ b/src/clients/cave/cmd_execute_resolution.cc
-@@ -104,7 +104,8 @@ namespace
- CaveCommandCommandLine
- {
- args::ArgsGroup g_general_options;
-- args::SwitchArg a_pretend;
-+ mutable args::SwitchArg a_pretend;
-+ args::SwitchArg a_ask;
- args::SwitchArg a_set;
- args::StringSetArg a_world_specs;
- args::StringSetArg a_removed_if_dependent_names;
-@@ -116,6 +117,7 @@ namespace
- ExecuteResolutionCommandLine() :
- g_general_options(main_options_section(), "General Options", "General options."),
- a_pretend(&g_general_options, "pretend", '\0', "Only carry out the pretend action", false),
-+ a_ask(&g_general_options, "ask", '\0', "Ask before executing", false),
- a_set(&g_general_options, "set", '\0', "Our target is a set rather than package specs", false),
- a_world_specs(&g_general_options, "world-specs", '\0', "Use the specified spec or set name for updating world"),
- a_removed_if_dependent_names(&g_general_options, "removed-if-dependent-names", '\0',
-@@ -304,6 +306,26 @@ namespace
- return 0 == retcode;
- }
-
-+ bool do_ask()
-+ {
-+ Context context("When asking to execute :");
-+ std::string answer;
-+ cout << std::endl;
-+ cout << "Do you really want to do this ? [Y/n] ... ";
-+ while (true)
-+ {
-+ getline(std::cin, answer);
-+ for (unsigned i(0) ; i < answer.length() ; ++i)
-+ answer[i] = tolower(answer[i]);
-+ if (answer == "no" || answer == "n")
-+ return false;
-+ else if (answer == "yes" || answer == "ye" || answer == "y" || answer == "")
-+ return true;
-+ cout << endl;
-+ cout << "Unknown answer : " + answer + " [Y/n] ... ";
-+ }
-+ }
-+
- std::string maybe_replacing(
- const std::shared_ptr<Environment> & env,
- const std::shared_ptr<const Sequence<PackageDepSpec> > & id_specs,
-@@ -1586,6 +1608,10 @@ namespace
- int retcode(0);
-
- retcode |= execute_pretends(env, lists, cmdline);
-+
-+ if ((! cmdline.a_pretend.specified()) && cmdline.a_ask.specified() && lists->execute_job_list()->length() != 0 && (! do_ask()))
-+ cmdline.a_pretend.set_specified(args::aos_specified);
-+
- if (0 != retcode || cmdline.a_pretend.specified())
- return retcode;
-
-diff --git a/src/clients/cave/cmd_resolve.cc b/src/clients/cave/cmd_resolve.cc
-index e0a7f2a..9985df5 100644
---- a/src/clients/cave/cmd_resolve.cc
-+++ b/src/clients/cave/cmd_resolve.cc
-@@ -49,9 +49,9 @@ namespace
- graph_jobs_options(this),
- program_options(this)
- {
-- add_usage_line("[ -x|--execute ] [ -z|--lazy or -c|--complete or -e|--everything ] spec ...");
-- add_usage_line("[ -x|--execute ] [ -z|--lazy or -c|--complete or -e|--everything ] set");
-- add_usage_line("[ -x|--execute ] !spec ...");
-+ add_usage_line("[ -x|--execute ] [ -?|--ask ] [ -z|--lazy or -c|--complete or -e|--everything ] spec ...");
-+ add_usage_line("[ -x|--execute ] [ -?|--ask ] [ -z|--lazy or -c|--complete or -e|--everything ] set");
-+ add_usage_line("[ -x|--execute ] [ -?|--ask ] !spec ...");
- }
-
- std::string app_name() const
-diff --git a/src/clients/cave/resolve_cmdline.cc b/src/clients/cave/resolve_cmdline.cc
-index 82abf30..7033c28 100644
---- a/src/clients/cave/resolve_cmdline.cc
-+++ b/src/clients/cave/resolve_cmdline.cc
-@@ -46,6 +46,7 @@ ResolveCommandLineResolutionOptions::ResolveCommandLineResolutionOptions(args::A
- ArgsSection(h, "Resolution Options"),
- g_execution_options(this, "Execution Options", "Control execution."),
- a_execute(&g_execution_options, "execute", 'x', "Execute the suggested actions", true),
-+ a_ask(&g_execution_options, "ask", '?', "Ask before executing", true),
-
- g_convenience_options(this, "Convenience Options", "Broad behaviour options. These options are simply "
- "a convenient way of selecting common groups of other options; see individual option descriptions "
-diff --git a/src/clients/cave/resolve_cmdline.hh b/src/clients/cave/resolve_cmdline.hh
-index 8bdd0b4..589230c 100644
---- a/src/clients/cave/resolve_cmdline.hh
-+++ b/src/clients/cave/resolve_cmdline.hh
-@@ -36,6 +36,7 @@ namespace paludis
-
- args::ArgsGroup g_execution_options;
- args::SwitchArg a_execute;
-+ args::SwitchArg a_ask;
-
- args::ArgsGroup g_convenience_options;
- args::SwitchArg a_lazy;
-diff --git a/src/clients/cave/resolve_common.cc b/src/clients/cave/resolve_common.cc
-index 3ddbddb..2770932 100644
---- a/src/clients/cave/resolve_common.cc
-+++ b/src/clients/cave/resolve_common.cc
-@@ -427,6 +427,8 @@ namespace
-
- if (pretend_only || ! resolution_options.a_execute.specified())
- args->push_back("--pretend");
-+ else if (resolution_options.a_ask.specified())
-+ args->push_back("--ask");
-
- for (Sequence<std::string>::ConstIterator p(world_specs->begin()), p_end(world_specs->end()) ;
- p != p_end ; ++p)
-diff --git a/zsh-completion/_cave b/zsh-completion/_cave
-index 2ca9fce..f70f669 100644
---- a/zsh-completion/_cave
-+++ b/zsh-completion/_cave
-@@ -664,6 +664,7 @@ _cave_cmd_report()
- _cave_resolve_arguments=(
- '(--help -h)'{--help,-h}'[Display help messsage]' \
- '(--execute -x --no-execute +x)'{--execute,-x,--no-execute,+x}'[Execute the suggested actions]' \
-+ '(--ask -? --no-ask +?)'{--ask,-?,--no-ask,+?}'[Ask before executing]' \
- '(--lazy -z --complete -c --everything -e --no-lazy +z --no-complete +c --no-everything +e)'{--lazy,-z,--no-lazy,+z}'[Do as little work as possible]' \
- '(--lazy -z --complete -c --everything -e --no-lazy +z --no-complete +c --no-everything +e)'{--complete,-c,--no-complete,+c}'[Do all optional work]' \
- '(--lazy -z --complete -c --everything -e --no-lazy +z --no-complete +c --no-everything +e)'{--everything,-e,--no-everything,+e}'[Do all optional work, and also reinstall]' \
---
-1.7.7.419.g87009.dirty
-
diff --git a/sys-apps/paludis/paludis-9999.ebuild b/sys-apps/paludis/paludis-9999.ebuild
deleted file mode 100644
index 16682cb8..00000000
--- a/sys-apps/paludis/paludis-9999.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2011 Ciaran McCreesh
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="paludis-1"
-inherit bash-completion-r1 eutils git-2
-
-DESCRIPTION="paludis, the other package mangler"
-HOMEPAGE="http://paludis.exherbo.org/"
-SRC_URI=""
-EGIT_REPO_URI="git://git.exherbo.org/paludis/paludis.git"
-
-IUSE="ask doc gemcutter pbins pink portage python-bindings ruby-bindings search-index sort-world vim-syntax visibility xml zsh-completion"
-LICENSE="GPL-2 vim-syntax? ( vim )"
-SLOT="0"
-KEYWORDS=""
-
-COMMON_DEPEND="
- >=app-admin/eselect-1.2_rc1
- >=app-shells/bash-3.2
- dev-libs/libpcre[cxx]
- pbins? ( >=app-arch/libarchive-2.8.4 )
- ruby-bindings? ( dev-ruby/rubygems )
- python-bindings? ( >=dev-lang/python-2.6:= >=dev-libs/boost-1.41.0[python] )
- gemcutter? ( >=dev-libs/jansson-1.3 )
- xml? ( >=dev-libs/libxml2-2.6 )
- search-index? ( dev-db/sqlite:3 )"
-
-DEPEND="${COMMON_DEPEND}
- >=app-text/asciidoc-8.6.3
- app-text/xmlto
- sys-devel/autoconf:2.5
- sys-devel/automake:1.11
- doc? (
- || ( >=app-doc/doxygen-1.5.3 <=app-doc/doxygen-1.5.1 )
- media-gfx/imagemagick
- python-bindings? ( dev-python/epydoc dev-python/pygments )
- ruby-bindings? ( dev-ruby/syntax dev-ruby/allison )
- )
- dev-util/pkgconfig
- dev-cpp/gtest[threads]"
-
-RDEPEND="${COMMON_DEPEND}
- sys-apps/sandbox"
-
-# Keep syntax as a PDEPEND. It avoids issues when Paludis is used as the
-# default virtual/portage provider.
-PDEPEND="
- vim-syntax? ( >=app-editors/vim-core-7 )
- app-admin/eselect-package-manager
- suggested:
- dev-vcs/git
- dev-vcs/subversion
- dev-vcs/cvs
- dev-vcs/darcs
- net-misc/rsync
- net-misc/wget"
-
-create-paludis-user() {
- enewgroup "paludisbuild"
- enewuser "paludisbuild" -1 -1 "/var/tmp/paludis" "paludisbuild,tty"
-}
-
-pkg_setup() {
- if use pbins && \
- built_with_use app-arch/libarchive xattr; then
- eerror "With USE pbins you need libarchive build without the xattr"
- eerror "use flag."
- die "Rebuild app-arch/libarchive without USE xattr"
- fi
- create-paludis-user
-}
-
-src_unpack() {
- git-2_src_unpack
- cd "${S}"
- use sort-world && epatch ${FILESDIR}/0001-paludis-sort-world.patch
- use ask && epatch ${FILESDIR}/0002-cave-resolve-ask.patch
- ./autogen.bash || die "autogen.bash failed"
-}
-
-src_compile() {
- format_list() { echo $@ | tr -s \ ,; }
- local repositories="default repository unavailable unpackaged $(usev gemcutter)"
- local environments="default $(usev portage)"
- econf \
- $(use_enable doc doxygen ) \
- $(use_enable pink ) \
- $(use_enable pbins ) \
- $(use_enable ruby-bindings ruby ) \
- $(useq ruby-bindings && useq doc && echo --enable-ruby-doc ) \
- $(use_enable python-bindings python ) \
- $(useq python-bindings && useq doc && echo --enable-python-doc ) \
- $(use_enable search-index) \
- $(use_enable vim-syntax vim ) \
- $(use_enable visibility ) \
- $(use_enable xml ) \
- --with-vim-install-dir=/usr/share/vim/vimfiles \
- --with-repositories=$(format_list ${repositories}) \
- --with-environments=$(format_list ${environments}) \
- --with-git-head="$(git rev-parse HEAD)" \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS README NEWS
-
- dobashcomp bash-completion/cave
- if use zsh-completion ; then
- insinto /usr/share/zsh/site-functions
- doins zsh-completion/_cave
- fi
- find ${D} -name '*.la' -exec rm -f {} +
-}
-
-src_test() {
- # Work around Portage bugs
- export PALUDIS_DO_NOTHING_SANDBOXY="portage sucks"
- export BASH_ENV=/dev/null
-
- if [[ `id -u` == 0 ]] ; then
- # hate
- export PALUDIS_REDUCED_UID=0
- export PALUDIS_REDUCED_GID=0
- fi
-
- if ! emake check ; then
- eerror "Tests failed. Looking for files for you to add to your bug report..."
- find "${S}" -type f -name '*.epicfail' -or -name '*.log' | while read a ; do
- eerror " $a"
- done
- die "Make check failed"
- fi
-}
-
diff --git a/sys-apps/systemd/Manifest b/sys-apps/systemd/Manifest
deleted file mode 100644
index f991eaea..00000000
--- a/sys-apps/systemd/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-EBUILD systemd-9999.ebuild 4663 RMD160 791793530a2e3836aeb402f588966f95872672a8 SHA1 c0bd9b76b2e7fb260512f1c678ded8ee72b1ae8d SHA256 85232b94bf95a8c447c84f9bd33e776f22674f7d8a44b07dd9d4b2f7029021db
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
deleted file mode 100644
index 959dceda..00000000
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-WANT_AUTOMAKE=1.11
-
-inherit autotools bash-completion-r1 git-2 linux-info pam systemd
-
-DESCRIPTION="System and service manager for Linux"
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/systemd"
-EGIT_REPO_URI="git://anongit.freedesktop.org/systemd/systemd"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="acl audit cryptsetup gtk lzma +pam python plymouth selinux symlinks +tcpd"
-
-COMMON_DEPEND=">=sys-apps/dbus-1.4.10
- >=sys-apps/util-linux-2.19
- >=sys-fs/udev-172
- sys-libs/libcap
- acl? ( sys-apps/acl )
- audit? ( >=sys-process/audit-2 )
- cryptsetup? ( sys-fs/cryptsetup )
- gtk? (
- dev-libs/dbus-glib
- >=dev-libs/glib-2.26
- dev-libs/libgee:0
- x11-libs/gtk+:2
- >=x11-libs/libnotify-0.7 )
- lzma? ( app-arch/xz-utils )
- pam? ( virtual/pam )
- python? ( dev-python/dbus-python
- dev-python/pycairo )
- symlinks? ( !!sys-apps/sysvinit )
- plymouth? ( sys-boot/plymouth )
- selinux? ( sys-libs/libselinux )
- tcpd? ( sys-apps/tcp-wrappers )"
-
-# Vala-0.10 doesn't work with libnotify 0.7.1
-VALASLOT="0.14"
-# A little higher than upstream requires
-# but I had real trouble with 2.6.37 and systemd.
-MINKV="2.6.38"
-
-# dbus, udev versions because of systemd units
-# blocker on old packages to avoid collisions with above
-# openrc blocker to avoid udev rules starting openrc scripts
-RDEPEND="${COMMON_DEPEND}
- app-admin/syslog-ng
- sys-apps/baselayout-systemd
- sys-apps/lsb-release
- sys-apps/systemd-units
- sys-auth/nss-myhostname
- !<sys-apps/openrc-0.8.3"
-DEPEND="${COMMON_DEPEND}
- app-arch/xz-utils
- dev-util/gperf
- dev-util/intltool
- dev-lang/vala:${VALASLOT}
- >=sys-kernel/linux-headers-${MINKV}"
-
-pkg_setup() {
- enewgroup lock # used by var-lock.mount
- enewgroup tty 5 # used by mount-setup for /dev/pts
-}
-
-src_unpack() {
- git-2_src_unpack
-}
-
-src_prepare() {
- intltoolize --force --copy --automake
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --with-distro=gentoo
- # install everything to /usr
- --with-rootprefix=/usr
- --with-rootlibdir=/usr/$(get_libdir)
- # but pam modules have to lie in /lib*
- --with-pamlibdir=/$(get_libdir)/security
- --localstatedir=/var
- $(use_enable acl)
- $(use_enable audit)
- $(use_enable cryptsetup libcryptsetup)
- $(use_enable gtk)
- $(use_enable lzma xz)
- $(use_enable pam)
- $(use_enable plymouth)
- $(use_enable selinux)
- $(use_enable tcpd tcpwrap)
- )
-
- if use gtk; then
- export VALAC="$(type -p valac-${VALASLOT})"
- fi
-
- econf ${myeconfargs}
-}
-
-rename_mans() {
- cd ${ED}/usr/share/man/man8/
- for i in halt poweroff reboot runlevel shutdown telinit; do
- mv ${i}.8 systemd.${i}.8
- done
-}
-
-do_symlinks() {
- dosym /usr/$(get_libdir)/systemd/systemd /sbin/init
- for i in poweroff halt reboot shutdown; do
- dosym /usr/bin/systemctl /sbin/${i}
- done
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
- # move files as necessary
- newbashcomp "${S}"/src/systemd-bash-completion.sh systemd
- dodoc "${ED}"/usr/share/doc/systemd/*
- rm -rf "${ED}"/usr/share/doc/systemd
-
- keepdir /run
- if use symlinks; then
- do_symlinks
- else
- rename_mans
- fi
- find ${ED} -name '*.la' -exec rm -f {} +
-}
-
-pkg_preinst() {
- local CONFIG_CHECK="~AUTOFS4_FS ~CGROUPS ~DEVTMPFS ~FANOTIFY ~IPV6"
- kernel_is -ge ${MINKV//./ } || ewarn "Kernel version at least ${MINKV} required"
- check_extra_config
-}
-
-optfeature() {
- elog " [\e[1m$(has_version ${1} && echo I || echo ' ')\e[0m] ${1} (${2})"
-}
-
-pkg_postinst() {
- mkdir -p "${ROOT}"/run || ewarn "Unable to mkdir /run, this could mean trouble."
- if [[ ! -L "${ROOT}"/etc/mtab ]]; then
- ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
- ewarn "It is known to cause users being unable to unmount user mounts. If you don't"
- ewarn "require that specific feature, please call:"
- ewarn " $ ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
- ewarn
- fi
-
- elog "You may need to perform some additional configuration for some programs"
- elog "to work, see the systemd manpages for loading modules and handling tmpfiles:"
- elog " $ man modules-load.d"
- elog " $ man tmpfiles.d"
- elog
-
- elog "To get additional features, a number of optional runtime dependencies may"
- elog "be installed:"
- optfeature 'dev-python/dbus-python' 'for systemd-analyze'
- optfeature 'dev-python/pycairo[svg]' 'for systemd-analyze plotting ability'
- elog
-
- ewarn "Please note this is a work-in-progress and many packages in Gentoo"
- ewarn "do not supply systemd unit files yet. You are testing it on your own"
- ewarn "responsibility. Please remember than you can pass:"
- ewarn " init=/sbin/init"
- ewarn "to your kernel to boot using sysvinit / OpenRC."
-}