summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@gmail.com>2009-04-12 17:49:25 +0200
committerHenry Gebhardt <hsggebhardt@gmail.com>2009-04-12 17:49:25 +0200
commitb1a02b7fef8c69a5f29b196b74bd5cbdf8f83683 (patch)
tree325803bffeaa1cc5499731209f7923bfdaab0d13 /sci-astronomy
parentsci-astronomy/ftools-6.6.1-r1: Portage knows about heasoft. (diff)
downloadkork-b1a02b7fef8c69a5f29b196b74bd5cbdf8f83683.tar.gz
kork-b1a02b7fef8c69a5f29b196b74bd5cbdf8f83683.tar.bz2
kork-b1a02b7fef8c69a5f29b196b74bd5cbdf8f83683.zip
sci-astronomy/ftools-6.6.1-r1: Add /etc/env.d/99headas
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/ftools/Manifest2
-rw-r--r--sci-astronomy/ftools/ftools-6.6.1-r1.ebuild39
2 files changed, 21 insertions, 20 deletions
diff --git a/sci-astronomy/ftools/Manifest b/sci-astronomy/ftools/Manifest
index f572083..137a4f7 100644
--- a/sci-astronomy/ftools/Manifest
+++ b/sci-astronomy/ftools/Manifest
@@ -8,5 +8,5 @@ AUX lhea-fixpfiles-destdir.patch 562 RMD160 fd1af4e68bb7885652a6e81404371bba5fe8
AUX no-tk-docs.patch 738 RMD160 d69e261c402d2e545f109495be999eaeb5d37620 SHA1 35ff2466c06df162e584b76ad3ef15d05b9e2f42 SHA256 0782fe89fc4d29eb4ba2c01f8d6420762060a156db7cb7cf7847f3a5a366f44c
AUX par2-destdir.patch 580 RMD160 56efb9a0049486f7736fe6bcd08947de45599ffa SHA1 97e12b9bb9feccf1be3d3bc1b83a6e79d4078f37 SHA256 aba4b7ba28204b6863c5e8ade5528874ef0606e15d03b1ea167ab9732ac481d4
DIST heasoft6.6.1src.tar.gz 41783649 RMD160 b03d23ad61023d9f9d8df247a448c8ad4d66f98d SHA1 58376bd6ce4dbc9cdb3a901c977602d120d0609e SHA256 f73e78e5a5b6af8b9db0aee66957bf450980455fc78a8d7aa056e6013b49285d
-EBUILD ftools-6.6.1-r1.ebuild 1815 RMD160 fcf6d1cef381a1d3183746c6c5ae46333d8adb6b SHA1 6462c2cb4d8de9f90c8f7ee44231706e8bdb92a1 SHA256 741da322af2497f96060529b0bbe8b59fdb275b066a2dba7945678bcd0af1646
+EBUILD ftools-6.6.1-r1.ebuild 1901 RMD160 0250e5f1dee0b3418352a668fc6044e5daf87215 SHA1 265bb95ab24f1caf6d33a65fa5ff46f2a991ed1f SHA256 9bafb92df06351a6fe4c402762d2954359c0305f66df7d2a10cd40470f5197c1
EBUILD ftools-6.6.1.ebuild 1911 RMD160 ba849617b62ddbac13c1fab45157d1bbd05db7bf SHA1 078a2aa8bf1a5e5af3b2da31c835f2c630f677e9 SHA256 4e389dd716cb9e4e9243178c4c067b96f2839ced5ea5446b57c163f918069be7
diff --git a/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild b/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild
index 33e1d7d..31ab5b3 100644
--- a/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild
+++ b/sci-astronomy/ftools/ftools-6.6.1-r1.ebuild
@@ -15,57 +15,58 @@ KEYWORDS="~x86"
IUSE=""
RESTRICT="test"
-DEPEND="x11-base/xorg-server"
+DEPEND="x11-base/xorg-server
+ >=dev-lang/perl-5.6.0"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/heasoft-${PV}/"
+S="${WORKDIR}/heasoft-${PV}/BUILD_DIR"
PREFIX="/usr/heasoft-${PV}"
MSG="The HEASOFT General-Use FTools have been installed into
-$PREFIX.
+${PREFIX}.
-To use the HEASOFT, you need to set the HEADAS environment
-variable, and source the headas init script, like so
- export HEADAS=\"${PREFIX}/<arch-dependent-dir>\"
+To use the HEASOFT, you need to source the headas init script,
+like so
. \${HEADAS}/headas-init.sh
if you are using a bourne-shell. There is also an initscript
-for C-shells in the same directory as the one for bourne-shells."
+for C-shells in the same directory as the one for bourne-shells.
+The environment vairable \${HEADAS} has been defined for you."
+
+pkg_setup() {
+ [[ -d "${PREFIX}" ]] && die "Please unmerge previous installation."
+ ewarn "This ebuild works but doesn't do things as god intended..."
+}
src_prepare() {
for subdir in tcl tk; do
- cd "${S}"/tcltk/${subdir}/unix
+ cd "${S}"/../tcltk/${subdir}/unix
epatch "${FILESDIR}"/installManPage-S-namecollision.patch \
|| die "epatch failed"
done
}
src_configure() {
- [[ -d "${PREFIX}" ]] && die "Please unmerge previous installation."
- ewarn "This ebuild is no good."
- cd BUILD_DIR
econf --prefix="${PREFIX}" || die "econf failed"
}
-src_compile() {
- cd BUILD_DIR
- emake || die "emake failed"
-
- echo "${MSG}" > WTF
-}
-
src_install() {
# The heasoft install scripts don't allow for $DESTDIR. Thus we
# must let headas install itself. This is very, very bad.
addwrite "${PREFIX}"
einfo "Installing into ${PREFIX} directly..."
- cd BUILD_DIR
# Hell knows why we need -j1 here. But we sure need it.
emake -j1 install || die "emake install failed"
einfo "Moving ${PREFIX} to image directory..."
mkdir "${D}"/usr
mv "${PREFIX}" "${D}"/usr
+ echo "${MSG}" > WTF
dodoc WTF
+ echo "HEADAS=\"`grep "HD_TOP_EXEC_PFX.*= " Makefile | sed "s#^HD_TOP_EXEC_PFX.*= ##"`\"" > 99headas
+ doenvd 99headas
+}
+
+pkg_postinst() {
elog "${MSG}"
}