summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/bup/bup-0.14a.ebuild')
-rw-r--r--app-backup/bup/bup-0.14a.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-backup/bup/bup-0.14a.ebuild b/app-backup/bup/bup-0.14a.ebuild
new file mode 100644
index 0000000..4472c72
--- /dev/null
+++ b/app-backup/bup/bup-0.14a.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2100 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+inherit eutils
+
+TARFILE="apenwarr-${PN}-${P}-0-gddf85b1.tar.gz"
+UNPACKDIR="apenwarr-${PN}-8333243"
+
+DESCRIPTION="It backs things up based on the git packfile format"
+HOMEPAGE="http://github.com/apenwarr/bup"
+SRC_URI="http://download.github.com/${TARFILE}"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="|| (
+ dev-lang/python:2.4
+ dev-lang/python:2.5
+ dev-lang/python:2.6
+ dev-lang/python:2.7
+ )
+ dev-vcs/git
+ app-arch/par2cmdline
+ dev-python/fuse-python
+ app-text/pandoc"
+
+S="${WORKDIR}/${UNPACKDIR}"
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/s/bup$/${P}/" Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc README DESIGN
+}
+
+src_test() {
+ emake test || die "emake test failed"
+}