summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/bup/bup-9999.ebuild')
-rw-r--r--app-backup/bup/bup-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-backup/bup/bup-9999.ebuild b/app-backup/bup/bup-9999.ebuild
index f3b7fa6..ac8e3f1 100644
--- a/app-backup/bup/bup-9999.ebuild
+++ b/app-backup/bup/bup-9999.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
+EAPI=5
EGIT_REPO_URI="git://github.com/bup/${PN}.git
http://github.com/bup/${PN}.git"
-inherit git-2 eutils
+inherit git-2 eutils python
DESCRIPTION="It backs things up based on the git packfile format"
HOMEPAGE="http://github.com/bup/bup"
@@ -30,8 +30,14 @@ DEPEND="|| (
doc? ( app-text/pandoc )"
RDEPEND="${DEPEND}"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
epatch_user
+ python_convert_shebangs -r 2 .
}
src_configure() {