aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2018-11-05 21:51:49 +0000
committerPaul Healy <lmiphay@gmail.com>2018-11-05 21:51:49 +0000
commit2aa1a0c437d06b86ad5537ffa92d1a81f32592fc (patch)
tree65398868bec3ac16f80805bfb86b9e53e6267cbb /app-emulation
parentrevbump requests (for opengrok) (diff)
downloadlmiphay-2aa1a0c437d06b86ad5537ffa92d1a81f32592fc.tar.gz
lmiphay-2aa1a0c437d06b86ad5537ffa92d1a81f32592fc.tar.bz2
lmiphay-2aa1a0c437d06b86ad5537ffa92d1a81f32592fc.zip
add ebuild for docker-link
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker-link/Manifest2
-rw-r--r--app-emulation/docker-link/docker-link-0.1.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/docker-link/Manifest b/app-emulation/docker-link/Manifest
new file mode 100644
index 0000000..64e7614
--- /dev/null
+++ b/app-emulation/docker-link/Manifest
@@ -0,0 +1,2 @@
+DIST docker-link-0.1.tar.gz 8521 BLAKE2B 980d96eb9e81011ef09578aaac62fbbc3a8faf71d5f3dd21eb8466ce4de55c308806ade18fd6d20ef74e9f161c148c761e3ef4f793cf3ea284a358f5fa9028bd SHA512 80266c8489541d47dab1b088d82da35cbec52d553d82ba81582dd2073b371a12f37fd65c04f16ec979af7269d5249ca74e3aeb36a43b702643b9a813e45ec980
+EBUILD docker-link-0.1.ebuild 821 BLAKE2B 03a4bea8e48590af76d76b5e033a79ff47121e7e08140b138c8b9323d44351985699b85233f7726799db7cc39ab7b523e3d83d156976c305b47cbe21a7fd44de SHA512 248da08cd199529a7bb1a828bb8d3b584e277b77ca8c268c1f98c165760cc040c8d44adce640fbcbef50247ee9cf25271473419ad0f26a850b999ce0c152165b
diff --git a/app-emulation/docker-link/docker-link-0.1.ebuild b/app-emulation/docker-link/docker-link-0.1.ebuild
new file mode 100644
index 0000000..d310017
--- /dev/null
+++ b/app-emulation/docker-link/docker-link-0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="Bridging docker containers to an external network"
+HOMEPAGE="https://github.com/lmiphay/docker-link"
+SRC_URI="https://github.com/lmiphay/docker-link/archive/v0.1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+"
+RDEPEND="${DEPEND}
+ app-shells/bash
+"
+
+DISABLE_AUTOFORMATTING=1
+FORCE_PRINT_ELOG=1
+DOC_CONTENTS="
+ This is an experimental attempt at bridging docker containers to an external network
+
+ Please report issues at the bug tracker: https://github.com/lmiphay/docker-link/issues
+"
+
+src_install() {
+ dobin docker-link
+ dodoc README.md
+
+ readme.gentoo_create_doc
+
+ default
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}