aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2017-09-23 18:27:51 +0100
committerPaul Healy <lmiphay@gmail.com>2017-09-23 18:27:51 +0100
commit824a56bf872ed27b1d641c456df427d42f504ad1 (patch)
treedcf7fef2961ef3e097dee7d2cd0357be30520c7e /app-oam
parentcleaning up oam ebuild (diff)
downloadlmiphay-824a56bf872ed27b1d641c456df427d42f504ad1.tar.gz
lmiphay-824a56bf872ed27b1d641c456df427d42f504ad1.tar.bz2
lmiphay-824a56bf872ed27b1d641c456df427d42f504ad1.zip
move to app-oam category
Diffstat (limited to 'app-oam')
-rw-r--r--app-oam/oam/Manifest1
-rw-r--r--app-oam/oam/oam-9999.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-oam/oam/Manifest b/app-oam/oam/Manifest
new file mode 100644
index 0000000..3d4aec2
--- /dev/null
+++ b/app-oam/oam/Manifest
@@ -0,0 +1 @@
+EBUILD oam-9999.ebuild 1277 SHA256 e4923919956716c7ea0ff379cc159f5e4f8862e34c80ec89e99bae570f5ce3ca SHA512 1eae71a25de9acebd812b9d91c28c1facf64f4e9313b6e6bd9995ad6d6d8d60d7e2591cdf0b42ad113178d0161882d586296a2a78e0e396e5bd49e61eda8cd62 WHIRLPOOL 0dddc1dcf2e34062e709df3a5849f085138f3e5dbdd9819a5240881a162f54861484b830fe9beab980d55b4253f9368948ebaeab6722d33f31b8ecb1d2c03f69
diff --git a/app-oam/oam/oam-9999.ebuild b/app-oam/oam/oam-9999.ebuild
new file mode 100644
index 0000000..fdc6bc1
--- /dev/null
+++ b/app-oam/oam/oam-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit user distutils-r1 bash-completion-r1 git-r3
+
+DESCRIPTION="Operations and maintenance automation for gentoo servers"
+HOMEPAGE="https://github.com/lmiphay/oam"
+EGIT_REPO_URI="https://github.com/lmiphay/${PN}.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+lnav +ranger"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ lnav? ( app-admin/lnav )
+ app-admin/logrotate
+ ranger? ( app-misc/ranger )
+ app-portage/genlop
+ app-portage/gentoolkit
+ app-portage/portage-utils
+ app-text/multitail
+ dev-python/attrdict[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/eliot[${PYTHON_USEDEP}]
+ dev-python/eliot-tree[${PYTHON_USEDEP}]
+ dev-python/inotifyx[${PYTHON_USEDEP}]
+ >=dev-python/invoke-0.21.0[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}
+"
+
+DOCS="README.md"
+
+pkg_setup() {
+ enewgroup oam
+}
+
+python_install_all() {
+ dodoc ${DOCS}
+ newbashcomp etc/bash.completion oam
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ true
+}