aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2022-07-16 14:56:43 +0100
committerPaul Healy <lmiphay@gmail.com>2022-07-16 14:56:43 +0100
commite36f9a509f8d72ee4a9a83f99b2d99e8af537198 (patch)
treef0751e17b32e04b6456953d3bb11d40a5e5acbe8 /media-gfx
parentremove old firestorm ebuilds (diff)
downloadlmiphay-e36f9a509f8d72ee4a9a83f99b2d99e8af537198.tar.gz
lmiphay-e36f9a509f8d72ee4a9a83f99b2d99e8af537198.tar.bz2
lmiphay-e36f9a509f8d72ee4a9a83f99b2d99e8af537198.zip
gyazo: update ruby version; add doc and config file
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gyazo/Manifest3
-rw-r--r--media-gfx/gyazo/files/gyazo.config.yml11
-rw-r--r--media-gfx/gyazo/gyazo-1.3.1.ebuild48
3 files changed, 62 insertions, 0 deletions
diff --git a/media-gfx/gyazo/Manifest b/media-gfx/gyazo/Manifest
new file mode 100644
index 0000000..ff1e732
--- /dev/null
+++ b/media-gfx/gyazo/Manifest
@@ -0,0 +1,3 @@
+AUX gyazo.config.yml 210 BLAKE2B 7de37f0a8a3024765b2b0da9efcef56c7eb2f8562970ae7d4c8372a12129be97574d4e795d090bdffaf33d7408f5514fae1f9508d8e156bdc652f578bdf5c0da SHA512 9161875d5aca1484b5b93ae2fc206e992267c5649fd1933d4b54baae446f6d3c8b11b7e12099c76132dfe6ce5831ee4db1abf0ab7e36267f4e3874fc332ac6c6
+DIST gyazo-1.3.1.tar.gz 11097 BLAKE2B 6cdbc7c4cdc73fff7d1f118fe23529e99e7cc972a0d4f296874f29d1ed93bc8404871cf0fe225ddeacd77c74ceb1d41a206a0df7ae7fc7282516df1e76b6de46 SHA512 5a049ebe72bdcf0405f6588684c21f480750967525e3626c43058f13ac0fbf709aac980a54bf8fac7109a06503c2b3b80a6b0c40fe2dbe20d9eeb8d9f6f032af
+EBUILD gyazo-1.3.1.ebuild 1251 BLAKE2B 8000ea2696e8ba60a7d971d7b24cfdb7e1c57e54faded931b3868978833ce349d6d1e6d44a18a4611cdbe69017b81c0dbeadf7846ec607a4c24c9b982ecdbc37 SHA512 7d2151da8a5acd48d844ae6c7de904e608032ad3da9372dbf74870d2e71bfe3d73a510ec71e73ebbe4f3558c45cc2f33d91e036162757d139ff234d8d694f29e
diff --git a/media-gfx/gyazo/files/gyazo.config.yml b/media-gfx/gyazo/files/gyazo.config.yml
new file mode 100644
index 0000000..85ffaea
--- /dev/null
+++ b/media-gfx/gyazo/files/gyazo.config.yml
@@ -0,0 +1,11 @@
+#
+# copy this to $HOME/.gyazo.config.yml
+#
+#browser_cmd: xdg-open
+#clipboard_cmd: xclip
+#clipboard_opt: "-sel clip"
+#host: upload.gyazo.com
+#cgi: "/upload.cgi"
+#ua: "Gyazo/1.3.1"
+#http_port: 443
+#use_ssl: true
diff --git a/media-gfx/gyazo/gyazo-1.3.1.ebuild b/media-gfx/gyazo/gyazo-1.3.1.ebuild
new file mode 100644
index 0000000..25e3f46
--- /dev/null
+++ b/media-gfx/gyazo/gyazo-1.3.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+inherit desktop ruby-single
+
+DESCRIPTION="Seriously Instant Screen-Grabbing"
+HOMEPAGE="https://gyazo.com"
+if [[ ${PV} == 9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gyazo/Gyazo-for-Linux.git"
+else
+ SRC_URI="https://github.com/gyazo/Gyazo-for-Linux/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S="${WORKDIR}/Gyazo-for-Linux-${PV}"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+DEPEND="media-gfx/imagemagick"
+RDEPEND="${DEPEND}
+ x11-misc/xclip
+"
+BDEPEND="${RUBY_DEPS}"
+
+src_configure() {
+ # Version is verion of the "Desktop Entry Specification" - not the application version
+ # see: https://specifications.freedesktop.org/desktop-entry-spec/latest/ar01s06.html
+ sed -i 's/Version=1.3.1/Version=1.5/' "src/${PN}.desktop"
+}
+
+src_install(){
+ newbin src/${PN}.rb ${PN}
+ domenu src/${PN}.desktop
+ doicon icons/${PN}.png
+ dodoc README.md ${FILESDIR}/gyazo.config.yml
+}
+
+pkg_postinst(){
+ elog "Usage: Just launch the Gyazo app, and then, drag your mouse to grab the screen."
+ elog ""
+ elog "The \$HOME/.gyazo.config.yml can be used to configure brower, clipboard command... etc"
+}