aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2015-03-24 23:01:56 +0000
committerPaul Healy <lmiphay@gmail.com>2015-03-24 23:01:56 +0000
commit5379f61e1cbe9fac45e24b663ab4e6e1e48ca1a7 (patch)
tree831f987476d157ce551b7c98de041bb839f90a4c /media-sound/shairport
parentadd davmail-bin ebuild (diff)
downloadlmiphay-5379f61e1cbe9fac45e24b663ab4e6e1e48ca1a7.tar.gz
lmiphay-5379f61e1cbe9fac45e24b663ab4e6e1e48ca1a7.tar.bz2
lmiphay-5379f61e1cbe9fac45e24b663ab4e6e1e48ca1a7.zip
initial commit of vanilla shaiport
Diffstat (limited to 'media-sound/shairport')
-rw-r--r--media-sound/shairport/Manifest3
-rw-r--r--media-sound/shairport/files/shairport.confd9
-rwxr-xr-xmedia-sound/shairport/files/shairport.initd24
-rw-r--r--media-sound/shairport/shairport-9999.ebuild32
4 files changed, 68 insertions, 0 deletions
diff --git a/media-sound/shairport/Manifest b/media-sound/shairport/Manifest
new file mode 100644
index 0000000..f629421
--- /dev/null
+++ b/media-sound/shairport/Manifest
@@ -0,0 +1,3 @@
+AUX shairport.confd 213 SHA256 0d406be8c8dfd6d5d7bee6ec1dce2e2d211c47bcb3a67b64002d22f7e018c1d7 SHA512 fa7c3630d62f22905b13df59d61168d11ed34ccd4bc286b4902f582a4cc55556da93607cf2b58c0fafd03a83274f94cb4ff178422ac98caca6aaf4dba42bc3f5 WHIRLPOOL 4ee4dae5e1ed418ecb3dbd7955010e06c79bb8885b89fc719ccd8abcd785206e084488fece6723f82d06aec35a498e144906cfe7ecf50ac0f9587deb230692fb
+AUX shairport.initd 495 SHA256 9b246436c1edb40fc2a312dea89978f3c324b36ded0cca890f7eaacad1bb3fd4 SHA512 33c1a09b82340ecec637854ba204b1c36f1937355aab0dfe8d9b907062c5dfd1a328bd6ec9184ba27778ae94b1f906b20b87b2e9c67ce3f159c6a33d14c6dffc WHIRLPOOL ed14b986c05d9c006283697e0a3767729591984e25ae6f456ef2d8106bb2cb33be9ca80ea913c5c9289144bec521e23dc7fa4ad9c77afbb4a9f55c5aad524715
+EBUILD shairport-9999.ebuild 651 SHA256 d72deba4b17e3fcbc8c684a2dd72f80d6a84fe12750cfca9f572ec4236aebcd3 SHA512 67723ba10bebbc2ffb6afcab4882b2f39df4922b43109d96faab55ba8441d68392184459fb7c37417d67e19cb687ee199235cd6ddaa49642a4bc31caf15788a2 WHIRLPOOL 3783a3d90e0f0cca416ba40f5354ba741ed8d216e0fc807a742aab043c90c52a41ffd5c7effed96f6c9ffa5cc2f6c31b50ca226ac7e3214b4c11d6e518f184d0
diff --git a/media-sound/shairport/files/shairport.confd b/media-sound/shairport/files/shairport.confd
new file mode 100644
index 0000000..5ba6e9e
--- /dev/null
+++ b/media-sound/shairport/files/shairport.confd
@@ -0,0 +1,9 @@
+# /etc/conf.d/shairport: config file for /etc/init.d/shairport
+
+# default shairport options:
+#shairport_opts=""
+#
+# 'shairport --help' for available options e.g.
+#
+#shairport_opts="--output=pulse --mdns=avahi"
+#
diff --git a/media-sound/shairport/files/shairport.initd b/media-sound/shairport/files/shairport.initd
new file mode 100755
index 0000000..767fa5b
--- /dev/null
+++ b/media-sound/shairport/files/shairport.initd
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+description="emulates an AirPort Express to stream music from i-devices"
+start_stop_daemon_args="
+ --background
+ --make-pidfile
+ --pidfile /run/shairport.pid
+ --user shairport:audio
+"
+
+command="/usr/bin/shairport"
+command_args="
+ --log=/var/log/shairport.log
+ --name=$HOSTNAME/shairport
+ $shairport_opts
+"
+
+depend() {
+ need net
+ use avahi-daemon
+}
diff --git a/media-sound/shairport/shairport-9999.ebuild b/media-sound/shairport/shairport-9999.ebuild
new file mode 100644
index 0000000..c247979
--- /dev/null
+++ b/media-sound/shairport/shairport-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit eutils user git-r3
+
+DESCRIPTION="Emulates an AirPort Express to stream music from i-devices"
+HOMEPAGE="http://www.mafipulation.org"
+EGIT_REPO_URI="https://github.com/abrasive/shairport.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ media-libs/libao"
+RDEPEND="${DEPEND}
+ net-dns/avahi"
+
+pkg_setup() {
+ enewuser shairport -1 -1 -1 audio
+}
+
+src_install() {
+ dobin shairport
+ dodoc README.md
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}