aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Healy <lmiphay@gmail.com>2022-02-19 13:01:50 +0000
committerPaul Healy <lmiphay@gmail.com>2022-02-19 13:01:50 +0000
commitc85c6419da4c9f9d9c31d5fe3f822edafce4d590 (patch)
tree1f35efe285a7444fbbd2006c8eb6678574fd5401 /x11-misc
parentdont call gcc directly (diff)
downloadlmiphay-c85c6419da4c9f9d9c31d5fe3f822edafce4d590.tar.gz
lmiphay-c85c6419da4c9f9d9c31d5fe3f822edafce4d590.tar.bz2
lmiphay-c85c6419da4c9f9d9c31d5fe3f822edafce4d590.zip
dont call gcc directly
Signed-off-by: Paul Healy <lmiphay@gmail.com>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xphoon/Manifest4
-rw-r--r--x11-misc/xphoon/xphoon-20140814.ebuild14
2 files changed, 9 insertions, 9 deletions
diff --git a/x11-misc/xphoon/Manifest b/x11-misc/xphoon/Manifest
index 4ff13cc..6e08cfc 100644
--- a/x11-misc/xphoon/Manifest
+++ b/x11-misc/xphoon/Manifest
@@ -1,2 +1,2 @@
-DIST xphoon_14Aug2014.tar.gz 103903 SHA256 64da210d4b2614b5ce442c8271d4b384fbe10026e813776c878b09a2c10fa1ba SHA512 6f0cf53b305cbf15d3b28fdfbcf49ff78689d49fb7b95815b590f3d42f43bda31df1bfd515eefa849579f9055f004cc7bf901741d98e2a10ac4841cc4ed95a00 WHIRLPOOL 6d4500aa1a951df31dc1ce5af859f47f4f0515617854a95443b65b52acedbfc0162d47fc76a01f0a90f3e6652d8bad0e75890e80e5e041af539ff2aea4e30214
-EBUILD xphoon-20140814.ebuild 788 SHA256 051e761325947456a891d4dfc7f535fc3e0f6b30c75d0e87c69941ae46063b61 SHA512 2a41c851644f9daa70e52669e17434fcb357a6df1f5e8cc150c9df7029274228c46061b8c4ca1d5159180c5ea6cdbc5535f58adfc700e786bf7ef09deb2fece7 WHIRLPOOL 08f110f4564de52e7de64c6bb4c05c61527914f23ea5ff508648767218a49f1f99609b1df9430ffb539dbd43b4791dc257c871e5cf678d2ba52e0a501d573a19
+DIST xphoon_14Aug2014.tar.gz 103903 BLAKE2B fa1287790d408a62279d11d67a4b67f957c1c43a31a19388bed20801e1814c3c10001017e45d78d31452d3549d220ddcd400ed7d4367d620ca3a3dc1b91c24d9 SHA512 6f0cf53b305cbf15d3b28fdfbcf49ff78689d49fb7b95815b590f3d42f43bda31df1bfd515eefa849579f9055f004cc7bf901741d98e2a10ac4841cc4ed95a00
+EBUILD xphoon-20140814.ebuild 761 BLAKE2B 765858cecd9624014e46a28ad049fb7dda9c3e4d49b8074d0b0984af5d32f8554aa193791132f1af110f007a910b6f2d250aeccdc10d964dd50f4126cbcaf911 SHA512 421f22b487647bb4782fb558d711c18231dff82a70f5c11cae04d46cd42a93f258a6daa0f612c5c2c24878535b3652a4faf79cc598d3a2f6a888c1b8d37e9ecf
diff --git a/x11-misc/xphoon/xphoon-20140814.ebuild b/x11-misc/xphoon/xphoon-20140814.ebuild
index 5fd86f2..4234266 100644
--- a/x11-misc/xphoon/xphoon-20140814.ebuild
+++ b/x11-misc/xphoon/xphoon-20140814.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -29,14 +28,15 @@ S="${WORKDIR}/${PN}"
src_configure() {
xmkmf || die
+ sed -i '/ CC = gcc/d' "Makefile"
}
src_compile() {
- emake CC="$(tc-getCC)" CCOPTIONS="${CFLAGS}" EXTRA_LDOPTIONS="${LDFLAGS}" || die
+ emake CCOPTIONS="${CFLAGS}" EXTRA_LDOPTIONS="${LDFLAGS}"
}
src_install() {
- dobin ${PN} || die
- newman ${PN}.man ${PN}.1 || die
- dodoc README || die
+ dobin ${PN}
+ newman ${PN}.man ${PN}.1
+ dodoc README
}