summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre PIGNÉ <alex@freesenses.net>2012-02-15 00:20:18 +0100
committerAlexandre PIGNÉ <alex@freesenses.net>2012-02-15 00:20:18 +0100
commitdd927416d989d16d404f2576bbecbccef9f24c45 (patch)
tree751d8fd139da66c144e9505bc940b786f69c83e6
parentFirst ebuild of netzob including 3 other not existing dependencies. (diff)
downloadlootr-dd927416d989d16d404f2576bbecbccef9f24c45.tar.gz
lootr-dd927416d989d16d404f2576bbecbccef9f24c45.tar.bz2
lootr-dd927416d989d16d404f2576bbecbccef9f24c45.zip
dev-python/impacket created.
ebuilds simplified, useless sections removed.
-rw-r--r--bitarray-0.5.1.ebuild15
-rw-r--r--impacket-0.9.6.0.ebuild22
-rw-r--r--netzob-0.3.1.ebuild25
-rw-r--r--pcapy-0.10.5.ebuild16
4 files changed, 36 insertions, 42 deletions
diff --git a/bitarray-0.5.1.ebuild b/bitarray-0.5.1.ebuild
index 8728a8f..48c5870 100644
--- a/bitarray-0.5.1.ebuild
+++ b/bitarray-0.5.1.ebuild
@@ -1,6 +1,7 @@
EAPI=4
-PYTHON_SUPPORT="2:2.5 3:3.2"
+
+PYTHON_DEPEND="2:2.5 3"
SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -13,15 +14,3 @@ LICENSE="PSF-2"
SLOT="0"
KEYWORD="~amd64 ~x86"
IUSE=""
-
-pkg_setup() {
- python_pkg_setup
-}
-
-src_compile() {
- distutils_src_compile
-}
-
-src_install() {
- distutils_src_install
-}
diff --git a/impacket-0.9.6.0.ebuild b/impacket-0.9.6.0.ebuild
new file mode 100644
index 0000000..772db9b
--- /dev/null
+++ b/impacket-0.9.6.0.ebuild
@@ -0,0 +1,22 @@
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Python Impacket extension"
+HOMEPAGE="http://oss.coresecurity.com/projects/impacket.html"
+MY_PN="Impacket"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz
+ http://oss.coresecurity.com/repo/${MY_P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORD="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
diff --git a/netzob-0.3.1.ebuild b/netzob-0.3.1.ebuild
index 0dae41a..fcda0c7 100644
--- a/netzob-0.3.1.ebuild
+++ b/netzob-0.3.1.ebuild
@@ -16,13 +16,14 @@ SLOT="0"
KEYWORD="~x86"
IUSE="doc"
-RDEPEND=">=dev-python/ptrace-0.4.1
+RDEPEND=">=dev-python/python-ptrace-0.4.1
app-misc/hachoir-subfile
dev-python/matplotlib
dev-util/strace
sys-process/lsof
>=dev-python/lxml-2.3
dev-python/bitarray
+ dev-python/impacket
net-libs/nfqueue-bindings[python]"
# python-pcapy
DEPEND="${RDEPEND}
@@ -31,23 +32,15 @@ DEPEND="${RDEPEND}
RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
-DOCS="README.txt AUTHORS.txt NEWS.txt COPYING.txt PKG-INFO.txt"
-
-pkg_setup() {
- python_pkg_setup
-}
+DOCS="README.txt AUTHORS.txt NEWS.txt COPYING.txt"
src_compile() {
distutils_src_compile
-# if use doc; then
-# einfo "Generation of documentation"
-# pushd docs >/dev/null
-# emake html || die "Generation of documentation failed"
-# popd >/dev/null
-# fi
-}
-
-src_install() {
- distutils_src_install
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs >/dev/null
+ #emake html || die "Generation of documentation failed"
+ popd >/dev/null
+ fi
}
diff --git a/pcapy-0.10.5.ebuild b/pcapy-0.10.5.ebuild
index b45f1fa..9c750f9 100644
--- a/pcapy-0.10.5.ebuild
+++ b/pcapy-0.10.5.ebuild
@@ -1,7 +1,9 @@
EAPI=4
-PYTHON_SUPPORT="2:2.5 3:3.2"
+
+PYTHON_DEPEND="2:2.0"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
@@ -14,15 +16,3 @@ LICENSE="Apache-1.1"
SLOT="0"
KEYWORD="~amd64 ~x86"
IUSE=""
-
-pkg_setup() {
- python_pkg_setup
-}
-
-src_compile() {
- distutils_src_compile
-}
-
-src_install() {
- distutils_src_install
-}