summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukas Elsner <lukas.elsner@freifalt.com>2011-06-14 13:41:45 +0200
committerLukas Elsner <lukas.elsner@freifalt.com>2011-06-14 13:41:45 +0200
commit53053637c1ca9600cbe9f0745e46da65305d5da6 (patch)
treeb5bf57981a70706de6712250808f81790004b445 /app-misc
parentadded fxp-one (diff)
downloadluman-53053637c1ca9600cbe9f0745e46da65305d5da6.tar.gz
luman-53053637c1ca9600cbe9f0745e46da65305d5da6.tar.bz2
luman-53053637c1ca9600cbe9f0745e46da65305d5da6.zip
added sparkleshare
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/sparkleshare/sparkleshare-0.2.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/sparkleshare/sparkleshare-0.2.1.ebuild b/app-misc/sparkleshare/sparkleshare-0.2.1.ebuild
new file mode 100644
index 0000000..f9fdbbc
--- /dev/null
+++ b/app-misc/sparkleshare/sparkleshare-0.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/banshee-community-extensions/banshee-community-extensions-1.6.1.ebuild,v 1.3 2010/07/12 20:28:24 fauli Exp $
+
+EAPI=3
+
+inherit base mono
+
+MY_PV="${PV/_beta/-beta}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SparkleShare is a file sharing and collaboration tool inspired by
+Dropbox"
+HOMEPAGE="http://www.sparkleshare.org"
+SRC_URI="http://www.sparkleshare.org/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-2.2
+ >=dev-util/monodevelop-2.0
+ >=dev-dotnet/gtk-sharp-2.12.7
+ >=dev-dotnet/webkit-sharp-0.3"
+RDEPEND="${DEPEND}
+ >=dev-vcs/git-1.7
+ net-misc/openssh
+ >=gnome-base/gvfs-1.3
+ dev-util/intltool
+ dev-python/nautilus-python"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README COPYING
+}
+