summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authormaciag.artur <maciag.artur@0805d722-a2c2-11dd-9b86-41075523de00>2009-04-30 22:26:58 +0000
committermaciag.artur <maciag.artur@0805d722-a2c2-11dd-9b86-41075523de00>2009-04-30 22:26:58 +0000
commit5b80313b97b1ac192dc973aeabf467179d0467f4 (patch)
treeea682045bcc2397fb0d40b3794f1e9445b327cee /net-im
parenttlen ebuild: new version bump (diff)
downloadpiczu-5b80313b97b1ac192dc973aeabf467179d0467f4.tar.gz
piczu-5b80313b97b1ac192dc973aeabf467179d0467f4.tar.bz2
piczu-5b80313b97b1ac192dc973aeabf467179d0467f4.zip
tlen linux version bump
git-svn-id: http://piczu-overlay.googlecode.com/svn/trunk@56 0805d722-a2c2-11dd-9b86-41075523de00
Diffstat (limited to 'net-im')
-rw-r--r--net-im/tlenlinux/Manifest3
-rw-r--r--net-im/tlenlinux/tlenlinux-7.0.1.31.ebuild75
2 files changed, 78 insertions, 0 deletions
diff --git a/net-im/tlenlinux/Manifest b/net-im/tlenlinux/Manifest
index 1c4f290..34b8fc0 100644
--- a/net-im/tlenlinux/Manifest
+++ b/net-im/tlenlinux/Manifest
@@ -1,3 +1,6 @@
DIST tlenlinux-7.0.1.28.bin 16345949 RMD160 2a5bfb82971d4757f1030add2e1b5f3b57cf5ddc SHA1 1efd0363f9f30edea31d3544d30d77f2c53a947a SHA256 2c34fe2c174454b83d3423153c3d0347dc4bd293f3381ba1216aa9f5b8b609f1
+DIST tlenlinux-7.0.1.31.bin 16463404 RMD160 7a65e0877a04bde899f55577a337984fb0a5ac66 SHA1 b6f219b29e107309f6c2f1ecc3988bc14b4e3c78 SHA256 b96b63eb094c6cd028a0fd88cd2938ff2ff7a6284b1e9b5fcb28f2579fc9779a
DIST tlenlinux64-7.0.1.28.bin 16981478 RMD160 1dc5f71959e600759a894794b0a8f7d96cb234d8 SHA1 e0a4b12ebcd4f4ef2fa19018fd5f7e2842498b60 SHA256 3bfdd013795555748c856e60e2591095e4478bcacb970f371e5527f4e0dac3b9
+DIST tlenlinux64-7.0.1.31.bin 17100274 RMD160 ff5c1f9bc0c169fb1e5619f087a32cacb40d5362 SHA1 f56b4677633f5970aeefe4de07a4db6919b0e604 SHA256 7f8f3c21735bdfd935a66c66d46e18223602f4433184b19a280cce586ec7a5b9
EBUILD tlenlinux-7.0.1.28.ebuild 1704 RMD160 ed4826035825927888cf57c3ecf15787bee95031 SHA1 85cd7e5fc81950ac0723f21278de3885f1a5c8a6 SHA256 a788fb9ecace8340ab2482059b9126a11ef775f9a695c0ba19bddfb4be2722f8
+EBUILD tlenlinux-7.0.1.31.ebuild 1704 RMD160 ed4826035825927888cf57c3ecf15787bee95031 SHA1 85cd7e5fc81950ac0723f21278de3885f1a5c8a6 SHA256 a788fb9ecace8340ab2482059b9126a11ef775f9a695c0ba19bddfb4be2722f8
diff --git a/net-im/tlenlinux/tlenlinux-7.0.1.31.ebuild b/net-im/tlenlinux/tlenlinux-7.0.1.31.ebuild
new file mode 100644
index 0000000..631dece
--- /dev/null
+++ b/net-im/tlenlinux/tlenlinux-7.0.1.31.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Tlen IM client"
+HOMEPAGE="http://tlen.pl"
+SRC_URI="
+ amd64? ( http://j.o2.pl/idi/${PN}64-${PV}.bin )
+ x86? ( http://j.o2.pl/idi/${P}.bin )"
+
+LICENSE="tlen"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="phonon"
+PROPERTIES="interactive"
+RESTRICT="strip"
+
+RDEPEND="x11-libs/qt-gui:4
+ phonon? ( x11-libs/qt-phonon:4 )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+TLEN_DIR="/opt/tlen"
+STATIC_FILES="./imageformats/* ./phonon_backend/* ./qt_libs/*"
+SHARED_FILES="tlen_libs/libgg.so tlen-bin updater"
+
+src_unpack() {
+ unpack_makeself
+ cd ${S}/data
+ # Fix RPATH
+ if use phonon; then
+ # Change RPATH
+ ./chrpath -r ${TLEN_DIR}/tlen_libs ${SHARED_FILES} > /dev/null
+ # Disable unset
+ sed -i "s:unset:# unset:" tlen
+ # Remove unneeded libs
+ rm -rf qt_libs imageformats phonon_backend
+ else
+ # Change RPATH
+ ./chrpath -r ${TLEN_DIR}/qt_libs:${TLEN_DIR}/tlen_libs ${SHARED_FILES} > /dev/null
+ ./chrpath -r ${TLEN_DIR}/qt_libs ${STATIC_FILES} > /dev/null
+ fi
+ # Desktop icon fix
+ sed -i "s:.jpg:.png:" ${S}/tlen.desktop
+}
+
+src_install() {
+ # Prepare directory
+ dodir ${TLEN_DIR}
+ # Copy data
+ cp -r data/* ${D}/${TLEN_DIR} || die "cp failed"
+ # Install desktop file
+ insinto /usr/share/applications/
+ doins tlen.desktop
+ # Install symlink
+ dodir /usr/bin
+ dosym ${TLEN_DIR}/tlen /usr/bin/tlen
+}
+
+pkg_preinst() {
+ check_license ${S}/data/license.txt
+}
+
+pkg_postinst() {
+ ### @todo deactivate auto-update by default
+ elog "It is not recommended to use Updater plugin."
+ elog "You should deselect Updater in:"
+ elog "\"Tlen\" -> \"Preferences\" -> \"Plugins\"."
+ elog
+}