summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-evolution/django-evolution-9999.ebuild')
-rw-r--r--dev-python/django-evolution/django-evolution-9999.ebuild21
1 files changed, 16 insertions, 5 deletions
diff --git a/dev-python/django-evolution/django-evolution-9999.ebuild b/dev-python/django-evolution/django-evolution-9999.ebuild
index ad44634..0bdc3ac 100644
--- a/dev-python/django-evolution/django-evolution-9999.ebuild
+++ b/dev-python/django-evolution/django-evolution-9999.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
+# $Header: $
+
+EAPI="2"
ESVN_REPO_URI="http://django-evolution.googlecode.com/svn/trunk/"
-inherit distutils eutils subversion
+inherit distutils subversion
DESCRIPTION="Schema Evolution for the Django Project"
HOMEPAGE="http://code.google.com/p/django-evolution/"
@@ -14,7 +16,16 @@ KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
IUSE=""
RDEPEND=">=dev-python/django-1.0"
-DEPEND="${RDEPEND}"
+DEPEND="dev-python/setuptools"
+
+PYTHON_MODNAME="django_evolution"
-DOCS="docs/* AUTHORS README"
+src_test() {
+ python setup.py test || die "tests failed"
+}
+src_install () {
+ distutils_src_install
+ rm -fr "${D}"usr/lib*/python*/site-packages/tests
+ dodoc docs/*
+}