summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2022-03-22 13:36:09 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2022-03-22 13:36:09 +0800
commit975a657fc4b6b2ae6126d6ad3479d1807ada5ca8 (patch)
tree472d5a505f2185ec7913b8e30c82201967cbc36c
parent[net-vpn/cloudflared] apply new go-module guideline (diff)
downloadpigfoot-975a657fc4b6b2ae6126d6ad3479d1807ada5ca8.tar.gz
pigfoot-975a657fc4b6b2ae6126d6ad3479d1807ada5ca8.tar.bz2
pigfoot-975a657fc4b6b2ae6126d6ad3479d1807ada5ca8.zip
[dev-go/athena-cli] upstream has accepted this patch
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
-rw-r--r--dev-go/athena-cli/athena-cli-9999.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-go/athena-cli/athena-cli-9999.ebuild b/dev-go/athena-cli/athena-cli-9999.ebuild
index 8ede726..6f33900 100644
--- a/dev-go/athena-cli/athena-cli-9999.ebuild
+++ b/dev-go/athena-cli/athena-cli-9999.ebuild
@@ -38,9 +38,11 @@ SLOT="0/${PVR}"
RESTRICT="mirror"
IUSE="+pie"
+if [[ ${PV} != *9999* ]]; then
PATCHES=(
"${FILESDIR}/00-feature-workgroup.patch"
)
+fi
src_compile() {
# -buildmode=pie forces external linking mode, even CGO_ENABLED=0