summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-16 22:22:05 -0400
committerRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-16 22:22:05 -0400
commit418cbab157947dba9230ad609b930936701e4b15 (patch)
tree7ccf1927127706cb73f8ab78b09bf4a75c9ee9fd /gnome-extra
parent20100702 - Cambio automático (diff)
downloadrubenqba-418cbab157947dba9230ad609b930936701e4b15.tar.gz
rubenqba-418cbab157947dba9230ad609b930936701e4b15.tar.bz2
rubenqba-418cbab157947dba9230ad609b930936701e4b15.zip
20100716 - Cambio automático
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/nautilus-dropbox/nautilus-dropbox-0.6.2-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnome-extra/nautilus-dropbox/nautilus-dropbox-0.6.2-r2.ebuild b/gnome-extra/nautilus-dropbox/nautilus-dropbox-0.6.2-r2.ebuild
new file mode 100644
index 0000000..d9021e8
--- /dev/null
+++ b/gnome-extra/nautilus-dropbox/nautilus-dropbox-0.6.2-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+DESCRIPTION="Dropbox client"
+HOMEPAGE="http://www.dropbox.com"
+SRC_URI="https://www.dropbox.com/download?dl=packages/${PN}-${PV}.tar.bz2
+ x86? ( http://dl-web.dropbox.com/u/17/dropbox-lnx.x86-0.7.110.tar.gz )
+ amd64? ( http://dl-web.dropbox.com/u/17/dropbox-lnx.x86_64-0.7.110.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libnotify
+ gnome-base/nautilus
+ dev-libs/dbus-glib
+ x11-libs/libSM"
+
+DEPEND="${RDEPEND}
+ dev-python/docutils"
+
+src_compile() {
+ gnome2_src_prepare
+}
+
+pkg_setup() {
+ arch=${ARCH}
+ use amd64 && arch="x86_64"
+}
+
+src_unpack() {
+ unpack dropbox-lnx.${arch}-0.7.110.tar.gz
+ mv ${WORKDIR}/.dropbox-dist ${WORKDIR}/dropbox
+ unpack ${PN}-${PV}.tar.bz2
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm ${D}/usr/bin/dropbox
+ insinto /opt
+ doins -r ../dropbox || die
+ chmod +x ${D}/opt/dropbox/dropboxd
+ chmod +x ${D}/opt/dropbox/dropbox
+ dosym /opt/dropbox/dropboxd /usr/bin
+ dosym /opt/dropbox/dropbox /usr/bin
+}
+