summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-16 22:52:39 -0400
committerRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-07-16 22:52:39 -0400
commite91365ce54d0b310482822a8d27349743a6da568 (patch)
tree10292a3d6faec129fc61cafc1c46e8006947c48e /x11-libs
parent20100716 - Cambio automático (diff)
downloadrubenqba-e91365ce54d0b310482822a8d27349743a6da568.tar.gz
rubenqba-e91365ce54d0b310482822a8d27349743a6da568.tar.bz2
rubenqba-e91365ce54d0b310482822a8d27349743a6da568.zip
adicionando pango-1.29.0
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/Manifest3
-rw-r--r--x11-libs/pango/files/pango-1.26.0-lib64.patch20
-rw-r--r--x11-libs/pango/pango-1.29.0.ebuild82
3 files changed, 105 insertions, 0 deletions
diff --git a/x11-libs/pango/Manifest b/x11-libs/pango/Manifest
new file mode 100644
index 0000000..436daff
--- /dev/null
+++ b/x11-libs/pango/Manifest
@@ -0,0 +1,3 @@
+AUX pango-1.26.0-lib64.patch 499 RMD160 0056b738ff517c2b1eb1a6b8e8173d91af0ebeaf SHA1 d514148e6ffced2b4f350abe25cd41282dbb3aae SHA256 1bb2671d49c54caf70e9df104ca26af4e76a536db14150a472b093d05d9f6347
+DIST pango-1.29.0.tar.bz2 8030734 RMD160 eb50d235b1b9f644e7a003b8c677bf7332373f60 SHA1 d9beeb71b3b9af9c40293e7402e3c99cb442b58c SHA256 0e437c6819358221295b5cd117fcacf53066baa69b2d1febca8d5b793090cf38
+EBUILD pango-1.29.0.ebuild 1942 RMD160 26e36de946c5fbb1db04c073df5c049ae54240b6 SHA1 3fd36b9b03fc22a38ade546aaf4354560b41d3bd SHA256 cf484957a495c176b0f552b0579ab763d059319cfffa6590c3e8986440ba36b2
diff --git a/x11-libs/pango/files/pango-1.26.0-lib64.patch b/x11-libs/pango/files/pango-1.26.0-lib64.patch
new file mode 100644
index 0000000..cdbdd50
--- /dev/null
+++ b/x11-libs/pango/files/pango-1.26.0-lib64.patch
@@ -0,0 +1,20 @@
+--- pango/Makefile.am
++++ pango/Makefile.am
+@@ -16,6 +16,7 @@
+ -DPANGO_ENABLE_BACKEND \
+ -DPANGO_ENABLE_ENGINE \
+ -DSYSCONFDIR=\"$(sysconfdir)\" \
++ -DHOST=\"$(host_triplet)\" \
+ -DLIBDIR=\"$(libdir)\" \
+ -DMODULE_VERSION=\"$(PANGO_MODULE_VERSION)\" \
+ -DG_DISABLE_DEPRECATED \
+--- pango/modules.c
++++ pango/modules.c
+@@ -353,6 +353,7 @@
+
+ if (!file_str)
+ file_str = g_build_filename (pango_get_sysconf_subdirectory (),
++ HOST,
+ "pango.modules",
+ NULL);
+
diff --git a/x11-libs/pango/pango-1.29.0.ebuild b/x11-libs/pango/pango-1.29.0.ebuild
new file mode 100644
index 0000000..fb77181
--- /dev/null
+++ b/x11-libs/pango/pango-1.29.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.28.1.ebuild,v 1.3 2010/06/23 15:09:33 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="yes"
+
+inherit autotools eutils gnome2 multilib toolchain-funcs
+
+DESCRIPTION="Internationalized text layout and rendering library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X doc +introspection test"
+
+RDEPEND=">=dev-libs/glib-2.24.0
+ >=media-libs/fontconfig-2.5.0
+ media-libs/freetype:2
+ >=x11-libs/cairo-1.7.6[X?]
+ X? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/gtk-doc-am-1.13
+ doc? (
+ >=dev-util/gtk-doc-1.13
+ ~app-text/docbook-xml-dtd-4.1.2
+ x11-libs/libXft )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+ test? (
+ >=dev-util/gtk-doc-1.13
+ ~app-text/docbook-xml-dtd-4.1.2
+ x11-libs/libXft )
+ X? ( x11-proto/xproto )"
+
+DOCS="AUTHORS ChangeLog* NEWS README THANKS"
+
+function multilib_enabled() {
+ has_multilib_profile || ( use x86 && [ "$(get_libdir)" = "lib32" ] )
+}
+
+pkg_setup() {
+ tc-export CXX
+ G2CONF="${G2CONF}
+ $(use_enable introspection)
+ $(use_with X x)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system. Fix building for
+ # emul-linux-x86-gtklibs
+ if multilib_enabled ; then
+ epatch "${FILESDIR}/${PN}-1.26.0-lib64.patch"
+ fi
+
+ eautoreconf
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ] ; then
+ einfo "Generating modules listing..."
+
+ local PANGO_CONFDIR=
+
+ if multilib_enabled ; then
+ PANGO_CONFDIR="/etc/pango/${CHOST}"
+ else
+ PANGO_CONFDIR="/etc/pango"
+ fi
+
+ mkdir -p ${PANGO_CONFDIR}
+
+ pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+ fi
+}