summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/totem/files')
-rw-r--r--media-video/totem/files/totem-2.26.1-smclient-target-detection.patch46
-rw-r--r--media-video/totem/files/totem-2.30.1-fix-gmp-plugin.patch87
-rw-r--r--media-video/totem/files/totem-2.30.1-fix-pygtk-include.patch41
-rw-r--r--media-video/totem/files/totem-2.30.1-fix-qt-eos.patch30
-rw-r--r--media-video/totem/files/totem-2.90.0-smclient-target-detection.patch39
5 files changed, 243 insertions, 0 deletions
diff --git a/media-video/totem/files/totem-2.26.1-smclient-target-detection.patch b/media-video/totem/files/totem-2.26.1-smclient-target-detection.patch
new file mode 100644
index 0000000..6be089a
--- /dev/null
+++ b/media-video/totem/files/totem-2.26.1-smclient-target-detection.patch
@@ -0,0 +1,46 @@
+---
+ Fixing passing any kind of argument to --with-smclient
+
+ configure.in | 23 +++++++++++++++++------
+ 1 file changed, 17 insertions(+), 6 deletions(-)
+
+Index: b/configure.in
+===================================================================
+--- a/configure.in
++++ b/configure.in
+@@ -226,18 +226,29 @@ GDK_TARGET="$($PKG_CONFIG --variable tar
+ SMCLIENT_PKGS=
+ AC_MSG_CHECKING([which smclient backend to use])
+ AC_ARG_WITH([smclient],
+- [AS_HELP_STRING([--with-smclient],[which smclient backend to use (xsmp/win32/quartz)])],
++ [AS_HELP_STRING([--with-smclient],[which smclient backend to use @<:@xsmp/win32/quartz/auto@:>@])],
+ [],
+- [case "$GDK_TARGET" in
+- x11) with_smclient=xsmp SMCLIENT_PKGS="sm" ;;
++ [$with_smclient=auto])
++
++
++if test "$with_smclient" != "no"; then
++
++ if test "$with_smclient" != "auto" -a "$with_smclient" != "yes"; then
++ GDK_TARGET="$with_smclient"
++ fi
++
++ case "$GDK_TARGET" in
++ x11|xsmp) with_smclient=xsmp SMCLIENT_PKGS="sm" ;;
+ win32|quartz) with_smclient=$GDK_TARGET ;;
+ *) with_smclient=no ;;
+- esac])
+-AC_MSG_RESULT([$with_smclient])
++ esac
++
++ AC_MSG_RESULT([$with_smclient])
+
+-if test "$with_smclient" != "no"; then
+ PKG_CHECK_MODULES([SMCLIENT],[$SMCLIENT_PKGS])
+ AC_DEFINE([WITH_SMCLIENT],[1],[Define if smclient is enabled])
++else
++ AC_MSG_RESULT([$with_smclient])
+ fi
+
+ AM_CONDITIONAL([WITH_SMCLIENT],[test "$with_smclient" != "no"])
diff --git a/media-video/totem/files/totem-2.30.1-fix-gmp-plugin.patch b/media-video/totem/files/totem-2.30.1-fix-gmp-plugin.patch
new file mode 100644
index 0000000..df13ef1
--- /dev/null
+++ b/media-video/totem/files/totem-2.30.1-fix-gmp-plugin.patch
@@ -0,0 +1,87 @@
+From d3b494595f7be012c400a4426bc89dcca1528f66 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Wed, 05 May 2010 16:50:52 +0000
+Subject: Fix URL parameter usage in GMP plugin
+
+The URL parameter is never the baseURI, it's the same as the SRC
+parameter, so some websites use both.
+
+Add support for the actual "baseURL" parameter instead.
+
+Fixes playback at:
+http://www.ta3.com/sk/relacie/23_hlavne-spravy/9167_hlavne-spravy-z-27-aprila
+
+https://bugzilla.gnome.org/show_bug.cgi?id=617639
+---
+diff --git a/browser-plugin/totemPlugin.cpp b/browser-plugin/totemPlugin.cpp
+index a30ffcc..25cf7ff 100644
+--- a/browser-plugin/totemPlugin.cpp
++++ b/browser-plugin/totemPlugin.cpp
+@@ -1042,7 +1042,6 @@ totemPlugin::RequestStream (bool aForceViewer)
+ /* Prefer filename over src */
+ if (mURLURI) {
+ requestURI = mURLURI;
+- baseURI = mSrcURI; /* FIXME: that correct? */
+ }
+ #endif /* TOTEM_GMP_PLUGIN */
+
+@@ -1655,7 +1654,23 @@ totemPlugin::SetURL (const char* aURL)
+
+ mURLURI = g_strdup (aURL);
+
+- /* FIXME: what is the correct base for the URL param? mSrcURI or mBaseURI? */
++ /* FIXME: security checks? */
++ /* FIXMEchpe: resolve the URI here? */
++}
++
++void
++totemPlugin::SetBaseURL (const char *aBaseURL)
++{
++ g_free (mBaseURI);
++
++ /* Don't allow empty URL */
++ if (!aBaseURL || !aBaseURL[0]) {
++ mBaseURI = NULL;
++ return;
++ }
++
++ mBaseURI = g_strdup (aBaseURL);
++
+ /* FIXME: security checks? */
+ /* FIXMEchpe: resolve the URI here? */
+ }
+@@ -2006,6 +2021,12 @@ totemPlugin::Init (NPMIMEType mimetype,
+ if (filename) {
+ SetURL (filename);
+ }
++
++ /* http://msdn.microsoft.com/en-us/library/dd564090(v=VS.85).aspx */
++ const char *base = (const char *) g_hash_table_lookup (args, "baseurl");
++ if (base)
++ SetBaseURL (base);
++
+ #endif /* TOTEM_GMP_PLUGIN */
+
+ #ifdef TOTEM_NARROWSPACE_PLUGIN
+@@ -2141,6 +2162,7 @@ totemPlugin::Init (NPMIMEType mimetype,
+
+ /* Dump some disagnostics */
+ D ("mSrcURI: %s", mSrcURI ? mSrcURI : "");
++ D ("mBaseURI: %s", mBaseURI ? mBaseURI : "");
+ D ("mCache: %d", mCache);
+ D ("mControllerHidden: %d", mControllerHidden);
+ D ("mShowStatusbar: %d", mShowStatusbar);
+diff --git a/browser-plugin/totemPlugin.h b/browser-plugin/totemPlugin.h
+index 1cd33d1..d42b9e1 100644
+--- a/browser-plugin/totemPlugin.h
++++ b/browser-plugin/totemPlugin.h
+@@ -284,6 +284,7 @@ class totemPlugin {
+ #ifdef TOTEM_GMP_PLUGIN
+ public:
+ void SetURL (const char* aURL);
++ void SetBaseURL (const char* aBaseURL);
+ const char* URL() const { return mURLURI; }
+
+ private:
+--
+cgit v0.8.3.1
diff --git a/media-video/totem/files/totem-2.30.1-fix-pygtk-include.patch b/media-video/totem/files/totem-2.30.1-fix-pygtk-include.patch
new file mode 100644
index 0000000..8980dad
--- /dev/null
+++ b/media-video/totem/files/totem-2.30.1-fix-pygtk-include.patch
@@ -0,0 +1,41 @@
+From aeeb165117a80080b044d54d5dc8b64df3128c26 Mon Sep 17 00:00:00 2001
+From: Jonathan Matthew <jonathan@kaolin.wh9.net>
+Date: Fri, 07 May 2010 12:23:17 +0000
+Subject: Fix version requirements for PyGTK
+
+pygtk.require() actually needs the major GTK+ version, and
+doesn't use the minor version in the require.
+
+Also make sure to check for the return value to avoid surprises.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=617821
+---
+diff --git a/src/plugins/totem-python-module.c b/src/plugins/totem-python-module.c
+index 5db787d..7eee97c 100644
+--- a/src/plugins/totem-python-module.c
++++ b/src/plugins/totem-python-module.c
+@@ -151,7 +151,7 @@ totem_python_module_init_python (void)
+
+ PySys_SetArgv (1, argv);
+
+- /* pygtk.require("2.8") */
++ /* pygtk.require("2.0") */
+ pygtk = PyImport_ImportModule ("pygtk");
+ if (pygtk == NULL) {
+ g_warning ("Could not import pygtk, check your installation");
+@@ -161,7 +161,12 @@ totem_python_module_init_python (void)
+
+ mdict = PyModule_GetDict (pygtk);
+ require = PyDict_GetItemString (mdict, "require");
+- PyObject_CallObject (require, Py_BuildValue ("(S)", PyString_FromString ("2.8")));
++ PyObject_CallObject (require, Py_BuildValue ("(S)", PyString_FromString ("2.0")));
++ if (PyErr_Occurred ()) {
++ g_warning ("Could not get required pygtk version, check your installation");
++ PyErr_Print();
++ return;
++ }
+
+ /* import gobject */
+ init_pygobject ();
+--
+cgit v0.8.3.1
diff --git a/media-video/totem/files/totem-2.30.1-fix-qt-eos.patch b/media-video/totem/files/totem-2.30.1-fix-qt-eos.patch
new file mode 100644
index 0000000..36147aa
--- /dev/null
+++ b/media-video/totem/files/totem-2.30.1-fix-qt-eos.patch
@@ -0,0 +1,30 @@
+From f6fa6e869330bb2e64b67f966f6873412c3ca081 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Fri, 07 May 2010 09:10:55 +0000
+Subject: Fix position when QT gets to EOS
+
+When QuickTime reaches the end of a stream, the expected behaviour
+is for the position to stay at the end of the file, rather than
+back at 0.
+---
+diff --git a/browser-plugin/totemPlugin.cpp b/browser-plugin/totemPlugin.cpp
+index 25cf7ff..5382bb2 100644
+--- a/browser-plugin/totemPlugin.cpp
++++ b/browser-plugin/totemPlugin.cpp
+@@ -1276,9 +1276,12 @@ totemPlugin::TickCallback (DBusGProxy *proxy,
+ scriptable->mPluginState = totemNarrowSpacePlayer::eState_Playable;
+ break;
+ case TOTEM_STATE_STOPPED:
+- if (scriptable->mPluginState == totemNarrowSpacePlayer::eState_Playable)
++ if (scriptable->mPluginState == totemNarrowSpacePlayer::eState_Playable) {
+ scriptable->mPluginState = totemNarrowSpacePlayer::eState_Complete;
+- else
++ /* The QuickTime plugin expects the duration to be the
++ * length of the file on EOS */
++ plugin->mTime = plugin->mDuration;
++ } else
+ scriptable->mPluginState = totemNarrowSpacePlayer::eState_Waiting;
+ break;
+ default:
+--
+cgit v0.8.3.1
diff --git a/media-video/totem/files/totem-2.90.0-smclient-target-detection.patch b/media-video/totem/files/totem-2.90.0-smclient-target-detection.patch
new file mode 100644
index 0000000..ad6cc69
--- /dev/null
+++ b/media-video/totem/files/totem-2.90.0-smclient-target-detection.patch
@@ -0,0 +1,39 @@
+diff -pur totem-2.90.0.orig/configure.in totem-2.90.0/configure.in
+--- totem-2.90.0.orig/configure.in 2010-06-19 14:22:16.000000000 -0400
++++ totem-2.90.0/configure.in 2010-06-25 20:52:05.720211025 -0400
+@@ -153,18 +153,29 @@ GDK_TARGET="$($PKG_CONFIG --variable tar
+ SMCLIENT_PKGS=
+ AC_MSG_CHECKING([which smclient backend to use])
+ AC_ARG_WITH([smclient],
+- [AS_HELP_STRING([--with-smclient],[which smclient backend to use (xsmp/win32/quartz)])],
++ [AS_HELP_STRING([--with-smclient],[which smclient backend to use @<:@xsmp/win32/quartz/auto@:>@])],
+ [],
+- [case "$GDK_TARGET" in
+- x11) with_smclient=xsmp SMCLIENT_PKGS="sm ice" ;;
++ [$with_smclient=auto])
++
++
++if test "$with_smclient" != "no"; then
++
++ if test "$with_smclient" != "auto" -a "$with_smclient" != "yes"; then
++ GDK_TARGET="$with_smclient"
++ fi
++
++ case "$GDK_TARGET" in
++ x11|xsmp) with_smclient=xsmp SMCLIENT_PKGS="sm ice" ;;
+ win32|quartz) with_smclient=$GDK_TARGET ;;
+ *) with_smclient=no ;;
+- esac])
+-AC_MSG_RESULT([$with_smclient])
++ esac
++
++ AC_MSG_RESULT([$with_smclient])
+
+-if test "$with_smclient" != "no"; then
+ PKG_CHECK_MODULES([SMCLIENT],[$SMCLIENT_PKGS])
+ AC_DEFINE([WITH_SMCLIENT],[1],[Define if smclient is enabled])
++else
++ AC_MSG_RESULT([$with_smclient])
+ fi
+
+ AM_CONDITIONAL([WITH_SMCLIENT],[test "$with_smclient" != "no"])