summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2019-10-27 23:39:02 +0100
committerSven Eden <sven.eden@gmx.de>2019-10-27 23:39:02 +0100
commit53550b72332f1e0505cd6483c05db17c88e32571 (patch)
tree9e429a68f79501d5561f23997b67c892c3427a18 /games-strategy
parentFix a stupid typo when doing perl -p -i -e replace... (diff)
downloadseden-53550b72332f1e0505cd6483c05db17c88e32571.tar.gz
seden-53550b72332f1e0505cd6483c05db17c88e32571.tar.bz2
seden-53550b72332f1e0505cd6483c05db17c88e32571.zip
games-startegy/widelands: Removed, the portage tree caught up.
Signed-off-by: Sven Eden <sven.eden@gmx.de>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/widelands/Manifest1
-rw-r--r--games-strategy/widelands/files/widelands-0.19-fix_icu-61.1.patch14
-rw-r--r--games-strategy/widelands/files/widelands-0.19-fix_maybe_uninitialized.patch21
-rw-r--r--games-strategy/widelands/files/widelands-0.19-remove_doc_file_install.patch42
-rw-r--r--games-strategy/widelands/metadata.xml11
-rw-r--r--games-strategy/widelands/widelands-0.19-r3.ebuild90
6 files changed, 0 insertions, 179 deletions
diff --git a/games-strategy/widelands/Manifest b/games-strategy/widelands/Manifest
deleted file mode 100644
index 9943c2a..0000000
--- a/games-strategy/widelands/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST widelands-build19-src.tar.bz2 181609391 SHA256 e511f9d26828a2b71b64cdfc6674e6e847543b2da73961ab882acca36c7c01a6 SHA512 80d70542f30c47498c38c5066ecbfa094cfa16fa3c8c75a950420b334cc019766a90a9f715d326506ce425848da1d75fa6f87e33e3551019c0dd8a4ccf99d666 WHIRLPOOL 3a218fa0ed3965af939fa79c73c1b03ed83ad563b507fe5125c4efbe56bc75904140b8a1006c87119c07cb5c6696f9f5248d681aa8a24f9262777304d7e66a65
diff --git a/games-strategy/widelands/files/widelands-0.19-fix_icu-61.1.patch b/games-strategy/widelands/files/widelands-0.19-fix_icu-61.1.patch
deleted file mode 100644
index 74446ac..0000000
--- a/games-strategy/widelands/files/widelands-0.19-fix_icu-61.1.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/src/graphic/text/bidi.h 2018-09-29 19:19:14.884233816 +0200
-+++ b/src/graphic/text/bidi.h 2018-09-29 19:22:30.742229163 +0200
-@@ -40,7 +40,11 @@
- // True if a string contains a character from the script's code blocks
- bool has_script_character(const char* input, UI::FontSets::Selector script);
- UI::FontSet const* find_fontset(const char* word, const UI::FontSets& fontsets);
-+#if U_ICU_VERSION_MAJOR_NUM > 60
-+std::string icustring2string(const icu::UnicodeString& convertme);
-+#else
- std::string icustring2string(const UnicodeString& convertme);
-+#endif // >=icu-61.1
- std::string icuchar2string(const UChar& convertme);
- bool cannot_start_line(const UChar& c);
- bool cannot_end_line(const UChar& c);
diff --git a/games-strategy/widelands/files/widelands-0.19-fix_maybe_uninitialized.patch b/games-strategy/widelands/files/widelands-0.19-fix_maybe_uninitialized.patch
deleted file mode 100644
index 8080b94..0000000
--- a/games-strategy/widelands/files/widelands-0.19-fix_maybe_uninitialized.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/src/network/netclient.cc 2017-09-07 17:03:04.532134374 +0200
-+++ b/src/network/netclient.cc 2017-09-07 17:10:54.603125955 +0200
-@@ -477,6 +477,8 @@
- // This might happen, if a users connects after the game starts.
- if (number == d->settings.users.size()) {
- UserSettings newuser;
-+ newuser.position = number;
-+ newuser.ready = false;
- d->settings.users.push_back(newuser);
- }
-
---- a/src/network/nethost.cc 2017-09-07 17:11:58.924124804 +0200
-+++ b/src/network/nethost.cc 2017-09-07 17:13:37.339123041 +0200
-@@ -1612,6 +1612,7 @@
- if (client.usernum == -1) {
- client.usernum = d->settings.users.size();
- UserSettings newuser;
-+ newuser.position = client.usernum;
- newuser.result = Widelands::PlayerEndResult::UNDEFINED;
- newuser.ready = true;
- d->settings.users.push_back(newuser);
diff --git a/games-strategy/widelands/files/widelands-0.19-remove_doc_file_install.patch b/games-strategy/widelands/files/widelands-0.19-remove_doc_file_install.patch
deleted file mode 100644
index 254f11c..0000000
--- a/games-strategy/widelands/files/widelands-0.19-remove_doc_file_install.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- a/CMakeLists.txt 2018-09-29 21:16:38.841066459 +0200
-+++ b/CMakeLists.txt 2018-09-29 21:18:21.132064028 +0200
-@@ -242,13 +242,6 @@
- DEPENDS wl_tests
- )
-
--install (
-- FILES ${CMAKE_CURRENT_BINARY_DIR}/VERSION
-- DESTINATION ${WL_INSTALL_BASEDIR}
-- CONFIGURATIONS Debug;Release;Gentoo
-- COMPONENT CoreVersionFile
--)
--
- # Installation.
- add_subdirectory(doc)
- if(OPTION_BUILD_TRANSLATIONS)
-@@ -289,25 +282,6 @@
- COMPONENT MusicFiles
- )
-
--install(
-- FILES
-- COPYING
-- CREDITS
-- ChangeLog
-- DESTINATION ${WL_INSTALL_BASEDIR}
-- CONFIGURATIONS Debug;Release;Gentoo
-- COMPONENT CoreLicenseFiles
--)
--
--install(
-- DIRECTORY
-- doc
-- DESTINATION ${WL_INSTALL_BASEDIR}
-- CONFIGURATIONS Debug
-- COMPONENT DocFiles
-- PATTERN "CMakeLists.txt" EXCLUDE
--)
--
- set_directory_properties(PROPERTIES ADDITIONAL_MAKE_CLEAN_FILES ${WL_INSTALL_DATADIR}/locale)
-
- install(
diff --git a/games-strategy/widelands/metadata.xml b/games-strategy/widelands/metadata.xml
deleted file mode 100644
index 8910ce0..0000000
--- a/games-strategy/widelands/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <upstream>
- <remote-id type="launchpad">widelands</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/games-strategy/widelands/widelands-0.19-r3.ebuild b/games-strategy/widelands/widelands-0.19-r3.ebuild
deleted file mode 100644
index f5c7c4b..0000000
--- a/games-strategy/widelands/widelands-0.19-r3.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit cmake-utils eapi7-ver gnome2-utils xdg-utils
-
-MY_PV=build$(ver_cut 2)
-MY_P=${PN}-${MY_PV}-src
-DESCRIPTION="A game similar to Settlers 2"
-HOMEPAGE="http://www.widelands.org/"
-SRC_URI="https://launchpad.net/widelands/${MY_PV}/${MY_PV}/+download/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-lang/lua:0
- >=dev-libs/boost-1.48
- dev-libs/icu:=
- media-libs/glew:0
- media-libs/libpng:0
- media-libs/libsdl2[video]
- media-libs/sdl2-image[jpeg,png]
- media-libs/sdl2-mixer[vorbis]
- media-libs/sdl2-net
- media-libs/sdl2-ttf
- sys-libs/zlib[minizip]"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix_icu-61.1.patch
- "${FILESDIR}"/${P}-fix_maybe_uninitialized.patch
- "${FILESDIR}"/${P}-remove_doc_file_install.patch
-)
-
-src_prepare() {
- # This only works if uppercase
- sed -i \
- -e 's:__ppc__:__PPC__:' \
- src/map_io/s2map.cc || die
- # Stupid build system has no general rules
- sed -i \
- -e 's:RelWithDebInfo:Gentoo:' \
- CMakeLists.txt || die
- # They only install with Debug and Release, not even with RelWithDebInfo
- sed -i \
- -e '/CONFIGURATIONS Debug;Release/ s/$/;Gentoo/' \
- CMakeLists.txt || die
- # Fix some path issues
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr/bin
- -DWL_INSTALL_BASEDIR="${EPREFIX}"/usr/bin
- -DWL_INSTALL_DATADIR="${EPREFIX}"/usr/share/${PN}
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-src_install() {
- cmake-utils_src_install
- newicon data/images/logos/wl-ico-128.png ${PN}.png
- make_desktop_entry ${PN} Widelands
- dodoc ChangeLog CREDITS
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}