summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2021-06-01 14:16:28 +0200
committerSven Eden <sven.eden@prydeworx.com>2021-06-01 14:16:28 +0200
commitfe10dd253d2a2d0024e78833ff36c226afd3b4bc (patch)
tree9e52acd9dc9bc9de52fbab198313f624ab19a350 /net-im
parentsys-cluster/mpich-3.3-r2: Build with gcc-10 hotfix (diff)
downloadseden-fe10dd253d2a2d0024e78833ff36c226afd3b4bc.tar.gz
seden-fe10dd253d2a2d0024e78833ff36c226afd3b4bc.tar.bz2
seden-fe10dd253d2a2d0024e78833ff36c226afd3b4bc.zip
net-im/teams-insiders: Bump to 1.4.00.13653
Signed-off-by: Sven Eden <sven.eden@prydeworx.com>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/teams-insiders/Manifest1
-rw-r--r--net-im/teams-insiders/teams-insiders-1.4.00.13653.ebuild131
2 files changed, 132 insertions, 0 deletions
diff --git a/net-im/teams-insiders/Manifest b/net-im/teams-insiders/Manifest
index 0ac1cdf..4772709 100644
--- a/net-im/teams-insiders/Manifest
+++ b/net-im/teams-insiders/Manifest
@@ -1,2 +1,3 @@
+DIST teams-insiders_1.4.00.13653_amd64.deb 83235690 SHA256 8d853978a7c61adfeadc5987c79ccabbdaa3b644e0e2a2ff9afc83cae57d1913 SHA512 23e3c7e4dc9fedec58be0ac9293e9f5808d70367b22f96aa6eeb0a5ec0cf31532d5575324f56a34ea29f04fcd9b55a243e68c99ec58aba1ff79b4b097e883f27 WHIRLPOOL e80ceac02aa2bfe6362b7f8cfb97a9392fd586cba1e9a178ad6aac45bc216a7ab0a7ab0a2b8bda9087e378b67e5ed756184b5066de83e665fd118593a6b5a01f
DIST teams-insiders_1.4.00.4855_amd64.deb 76578824 SHA256 36f7055f1cc7d4ec6dee040a49798cd18c8b0bb4e519372230561ef06302cc7e SHA512 c87cb9702b53464e158f29bf763cf38e6f171c07b5a4a5d4a0dfc15fa6e2cff9d258c61576c7931fb6cd026266b00e40a6e89677b1d57295814e222bf5e7f45a WHIRLPOOL 30310ee4e9006d390d943a64ebc75fd6e5ff69fdbc4a1fcedd16f9f2561106d99853a1d67df3033a3c53cb5ebd79a3cc67683daab612d6a970af121ed52ebd23
DIST teams-insiders_1.4.00.7556_amd64.deb 77243112 SHA256 c16201f0683feb034d05be679627cc4d65d5f5f165dd97bb3b7847eb81fe29c5 SHA512 1a9dd0882d4aa93a69fc8fed0c40d57ba64432a8a32d727963702e0c49bfdd2b13be9d7a5e65efc271ba26af0708fbbebcb123581ec6d2d39793331da082e7df WHIRLPOOL ee68e86cf03cc1a7d8748c9a4b6384e52cd30d967fc8704174f1e4732238b3a0a637e84c1a03b3585ae9d6902ce1cf39b624a934690c03c2ea4a52fb113f32d0
diff --git a/net-im/teams-insiders/teams-insiders-1.4.00.13653.ebuild b/net-im/teams-insiders/teams-insiders-1.4.00.13653.ebuild
new file mode 100644
index 0000000..fb630aa
--- /dev/null
+++ b/net-im/teams-insiders/teams-insiders-1.4.00.13653.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit chromium-2 desktop unpacker xdg-utils
+
+DESCRIPTION="Microsoft Teams Linux Client (Insiders Build)"
+HOMEPAGE="https://teams.microsoft.com/"
+SRC_URI="https://packages.microsoft.com/repos/ms-teams/pool/main/t/${PN}/${PN}_${PV}_amd64.deb"
+
+LICENSE="ms-teams-pre"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist mirror splitdebug test"
+IUSE="system-ffmpeg system-mesa"
+
+QA_PREBUILT="*"
+
+RDEPEND="
+ !net-im/teams
+ app-accessibility/at-spi2-atk
+ app-crypt/libsecret
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libxcb
+ x11-libs/libxkbfile
+ x11-libs/pango
+ system-ffmpeg? ( <media-video/ffmpeg-4.3[chromium] )
+ system-mesa? ( media-libs/mesa[egl,gles2] )
+"
+
+S="${WORKDIR}"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ local dest=/usr
+
+ # Remove keytar3, it needs libgnome-keyring. keytar4 uses libsecret and is used instead
+ rm -rf "${WORKDIR}/usr/share/teams-insiders/resources/app.asar.unpacked/node_modules/keytar3" || die
+
+ insinto ${dest}/share
+ doins -r "${S}"${dest}/share/applications
+ doins -r "${S}"${dest}/share/pixmaps
+ doins -r "${S}"${dest}/share/${PN}
+
+ exeinto ${dest}/bin
+ doexe "${S}"${dest}/bin/${PN}
+
+ exeinto ${dest}/share/${PN}
+ doexe "${S}"${dest}/share/${PN}/${PN}
+ doexe "${S}"${dest}/share/${PN}/chrome-sandbox
+
+ # Use system ffmpeg, if wanted. Might crash MS Teams!
+ if use system-ffmpeg; then
+ rm -f "${D}"/${dest}/share/${PN}/libffmpeg.so
+ dosym "${dest}/$(get_libdir)/chromium/libffmpeg.so" "${dest}/share/${PN}/libffmpeg.so"
+ elog "Using system ffmpeg. This is experimental and may lead to crashes."
+ else
+ # Otherwise keep the executable bit on the bundled lib
+ doexe "${S}"${dest}/share/${PN}/libffmpeg.so
+ fi
+
+ # Use system mesa, if wanted. Might Crash MS Teams!
+ if use system-mesa; then
+ rm -f "${D}"/${dest}/share/${PN}/libEGL.so
+ rm -f "${D}"/${dest}/share/${PN}/libGLESv2.so
+ elog "Using system mesa. This is experimental and may lead to crashes."
+ else
+ # Otherwise keep original executable flag
+ doexe "${S}"/${dest}/share/${PN}/libEGL.so
+ doexe "${S}"/${dest}/share/${PN}/libGLESv2.so
+ fi
+
+ # Keep swiftshader, used in GPU-/Head-less systems
+ exeinto ${dest}/share/${PN}/swiftshader
+ doexe "${S}"/${dest}/share/${PN}/swiftshader/libEGL.so
+ doexe "${S}"/${dest}/share/${PN}/swiftshader/libGLESv2.so
+
+ # The overlay handler seems to need executable bits
+ # See: https://microsoftteams.uservoice.com/forums/908686-bug-reports/suggestions/40805257-screen-sharing-broken-on-linux-with-1-3-00-16851#comments
+ exeinto ${dest}/share/${PN}/resources/app.asar.unpacked/node_modules/slimcore/bin
+ doexe "${S}"/${dest}/share/${PN}/resources/app.asar.unpacked/node_modules/slimcore/bin/platform.node
+ doexe "${S}"/${dest}/share/${PN}/resources/app.asar.unpacked/node_modules/slimcore/bin/rect-overlay
+ doexe "${S}"/${dest}/share/${PN}/resources/app.asar.unpacked/node_modules/slimcore/bin/sharing-indicator.node
+ doexe "${S}"/${dest}/share/${PN}/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+ doexe "${S}"/${dest}/share/${PN}/resources/app.asar.unpacked/node_modules/slimcore/bin/trouter-client.node
+
+ sed -i '/OnlyShowIn=/d' "${S}"${dest}/share/applications/${PN}.desktop
+ domenu "${S}"${dest}/share/applications/${PN}.desktop
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}