summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2017-02-21 12:15:47 +0100
committerSven Eden <sven.eden@gmx.de>2017-02-21 12:15:47 +0100
commit5fc7ffa9114513782fe5390a36784621b5f0f983 (patch)
tree6ad4b0db1d9f1221fa78a3850678e3f5783f3b36 /net-misc
parentsys-auth/elogind : fixed elogind docs patch name. (diff)
downloadseden-5fc7ffa9114513782fe5390a36784621b5f0f983.tar.gz
seden-5fc7ffa9114513782fe5390a36784621b5f0f983.tar.bz2
seden-5fc7ffa9114513782fe5390a36784621b5f0f983.zip
Add elogind support to NetworkManager (s.b.)
- net-misc/networkmanager-1.4.4-r11 : Add elogind support - kde-frameworks/networkmanager-qt-5.29.0-r1 kde-frameworks/networkmanager-qt-5.31.0-r1 : Allow networkmanager[elogind]
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/networkmanager/Manifest1
-rw-r--r--net-misc/networkmanager/files/01-org.freedesktop.NetworkManager.settings.modify.system.rules7
-rw-r--r--net-misc/networkmanager/files/10-openrc-status-r435
-rw-r--r--net-misc/networkmanager/files/conf.d.NetworkManager4
-rw-r--r--net-misc/networkmanager/files/init.d.NetworkManager-r158
-rw-r--r--net-misc/networkmanager/files/networkmanager-1.4.4-enable-elogind.patch185
-rw-r--r--net-misc/networkmanager/metadata.xml36
-rw-r--r--net-misc/networkmanager/networkmanager-1.4.4-r11.ebuild355
8 files changed, 681 insertions, 0 deletions
diff --git a/net-misc/networkmanager/Manifest b/net-misc/networkmanager/Manifest
new file mode 100644
index 0000000..e8f8d2a
--- /dev/null
+++ b/net-misc/networkmanager/Manifest
@@ -0,0 +1 @@
+DIST NetworkManager-1.4.4.tar.xz 3762664 SHA256 829378f318cc008d138a23ca6a9191928ce75344e7e47a2f2c35f4ac82133309 SHA512 a73e423e88b0e2694a46dc04f492a656d766796aa987b2e4644147a5939a6fdeb22ff5d8b36c723444bc0ab3d8740b80fa82c2f5e07f073998841695978d6e14 WHIRLPOOL d5e4ca3868c2aa8bceec2029c573b61ccc2fbc9f9a84cb8360ecf7d7503011f0501e9bffd54b163de8e84606ad7977b3c187adb78beed3a44bf2a3ee9821631f
diff --git a/net-misc/networkmanager/files/01-org.freedesktop.NetworkManager.settings.modify.system.rules b/net-misc/networkmanager/files/01-org.freedesktop.NetworkManager.settings.modify.system.rules
new file mode 100644
index 0000000..d00b268
--- /dev/null
+++ b/net-misc/networkmanager/files/01-org.freedesktop.NetworkManager.settings.modify.system.rules
@@ -0,0 +1,7 @@
+// Let users in plugdev group modify NetworkManager
+polkit.addRule(function(action, subject) {
+ if (action.id == "org.freedesktop.NetworkManager.settings.modify.system" &&
+ subject.isInGroup("plugdev") && subject.active) {
+ return "yes";
+ }
+});
diff --git a/net-misc/networkmanager/files/10-openrc-status-r4 b/net-misc/networkmanager/files/10-openrc-status-r4
new file mode 100644
index 0000000..e195ccc
--- /dev/null
+++ b/net-misc/networkmanager/files/10-openrc-status-r4
@@ -0,0 +1,35 @@
+#!/bin/sh
+# Copyright (c) 2012 Alexandre Rostovtsev
+# Released under the 2-clause BSD license.
+
+# Ensures that the NetworkManager OpenRC service is marked as started and
+# providing net only when it has a successful connection.
+
+if [ ! -e "/run/openrc/softlevel" ]; then
+ # OpenRC is not running
+ exit 0
+fi
+
+# Ensure rc-service is in PATH
+PATH="${PATH}:@EPREFIX@/sbin:@EPREFIX@/usr/sbin"
+
+# Exit if the NetworkManager OpenRC service is not running
+rc-service NetworkManager status 2>&1 | grep -Eq "status: (starting|started|inactive|stopping)" || exit 0
+
+# Call rc-service in background mode so that the start/stop functions update
+# NetworkManager service status to started or inactive instead of actually
+# starting or stopping the daemon
+export IN_BACKGROUND=YES
+
+case "$2" in
+ up) nm-online -t 0 -x &&
+ ! rc-service NetworkManager status 2>&1 | grep -q started &&
+ exec rc-service NetworkManager start ;;
+ down) nm-online -t 0 -x ||
+ rc-service NetworkManager status 2>&1 | grep -q stopped ||
+ exec rc-service NetworkManager stop ;;
+ pre-sleep) rc-service NetworkManager status 2>&1 | grep -q stopped ||
+ exec rc-service NetworkManager stop ;;
+esac
+exit 0
+# vim: set ts=4:
diff --git a/net-misc/networkmanager/files/conf.d.NetworkManager b/net-misc/networkmanager/files/conf.d.NetworkManager
new file mode 100644
index 0000000..4a99229
--- /dev/null
+++ b/net-misc/networkmanager/files/conf.d.NetworkManager
@@ -0,0 +1,4 @@
+# If NetworkManager does not establish a connection within $INACTIVE_TIMEOUT
+# seconds after starting, the service will be marked as inactive, and it will
+# continue to wait for a connection in background mode.
+INACTIVE_TIMEOUT=1
diff --git a/net-misc/networkmanager/files/init.d.NetworkManager-r1 b/net-misc/networkmanager/files/init.d.NetworkManager-r1
new file mode 100644
index 0000000..fbb8973
--- /dev/null
+++ b/net-misc/networkmanager/files/init.d.NetworkManager-r1
@@ -0,0 +1,58 @@
+#!/sbin/openrc-run
+# Copyright (c) 2008 Saleem Abdulrasool <compnerd@compnerd.org>
+# Distributed under the terms of the GNU General Purpose License v2
+# $Id$
+
+description="NetworkManager daemon. The service is marked as started only \
+when a network connection is established."
+
+depend() {
+ need dbus
+ use consolekit
+ provide net
+}
+
+start() {
+ # If we are re-called by a dispatcher event, we want to mark the service
+ # as started without starting the daemon again
+ yesno "${IN_BACKGROUND}" && return 0
+
+ [ -z "${INACTIVE_TIMEOUT}" ] && INACTIVE_TIMEOUT="1"
+
+ ebegin "Starting NetworkManager"
+ start-stop-daemon --start --quiet --pidfile /run/NetworkManager/NetworkManager.pid \
+ --exec /usr/sbin/NetworkManager -- --pid-file /run/NetworkManager/NetworkManager.pid
+ local _retval=$?
+ eend "${_retval}"
+ if [ "x${_retval}" = 'x0' ] && ! nm-online -t "${INACTIVE_TIMEOUT}"; then
+ einfo "Marking NetworkManager as inactive. It will automatically be marked"
+ einfo "as started after a network connection has been established."
+ mark_service_inactive
+ fi
+ return "${_retval}"
+}
+
+stop() {
+ # If we are re-called by a dispatcher event, we want to mark the service
+ # as inactive without stopping the daemon
+ if yesno "${IN_BACKGROUND}"; then
+ mark_service_inactive "${SVCNAME}"
+ return 0
+ fi
+
+ ebegin "Stopping NetworkManager"
+ local pidfile=/run/NetworkManager/NetworkManager.pid
+ if [ ! -e "${pidfile}" ] && [ -e /var/run/NetworkManager.pid ]; then
+ # Try stopping the pid file used by <0.9.7
+ pidfile=/var/run/NetworkManager.pid
+ start-stop-daemon --stop --quiet --pidfile "${pidfile}"
+ ret=$?
+ [ ${ret} = 0 ] && [ -e "${pidfile}" ] && rm "${pidfile}"
+ eend ${ret}
+ else
+ start-stop-daemon --stop --quiet --pidfile "${pidfile}"
+ eend $?
+ fi
+}
+
+# vim: set ft=gentoo-init-d ts=4 :
diff --git a/net-misc/networkmanager/files/networkmanager-1.4.4-enable-elogind.patch b/net-misc/networkmanager/files/networkmanager-1.4.4-enable-elogind.patch
new file mode 100644
index 0000000..c7fc131
--- /dev/null
+++ b/net-misc/networkmanager/files/networkmanager-1.4.4-enable-elogind.patch
@@ -0,0 +1,185 @@
+--- a/config.h.in 2017-02-14 09:53:41.124245372 +0100
++++ b/config.h.in 2017-02-14 09:59:04.886255092 +0100
+@@ -207,6 +207,9 @@
+ /* Define to 1 if libsystemd-login is available */
+ #undef SESSION_TRACKING_SYSTEMD
+
++/* Define to 1 if libelogin is available */
++#undef SESSION_TRACKING_ELOGIND
++
+ /* The size of `dev_t', as computed by sizeof. */
+ #undef SIZEOF_DEV_T
+
+@@ -219,6 +222,9 @@
+ /* Define to 1 to use systemd suspend api */
+ #undef SUSPEND_RESUME_SYSTEMD
+
++/* Define to 1 to use elogind suspend api */
++#undef SUSPEND_RESUME_ELOGIND
++
+ /* Define to 1 to use UPower suspend api */
+ #undef SUSPEND_RESUME_UPOWER
+
+--- a/configure.ac 2017-02-14 09:28:51.529200651 +0100
++++ b/configure.ac 2017-02-14 09:48:25.376235892 +0100
+@@ -426,14 +426,15 @@
+ [Support systemd session tracking]))
+ AC_ARG_WITH(consolekit, AS_HELP_STRING([--with-consolekit=yes|no],
+ [Support consolekit session tracking]))
+-AC_ARG_WITH(session-tracking, AS_HELP_STRING([--with-session-tracking=systemd|consolekit|no],
++AC_ARG_WITH(session-tracking, AS_HELP_STRING([--with-session-tracking=systemd|elogind|consolekit|no],
+ [Compatibility option to choose one session tracking module]))
+ # backwards compatibility
+-AS_IF([test "$with_session_tracking" = "ck"], [use_consolekit="yes" use_systemd_logind="no"])
+-AS_IF([test "$with_session_tracking" = "consolekit"], [use_consolekit="yes" use_systemd_logind="no"])
+-AS_IF([test "$with_session_tracking" = "systemd"], [use_consolekit="no" use_systemd_logind="yes"])
+-AS_IF([test "$with_session_tracking" = "no"], [use_consolekit="no" use_systemd_logind="no"])
+-AS_IF([test "$with_session_tracking" = "none"], [use_consolekit="no" use_systemd_logind="no"])
++AS_IF([test "$with_session_tracking" = "ck"], [use_consolekit="yes" use_systemd_logind="no" use_elogind="no"])
++AS_IF([test "$with_session_tracking" = "consolekit"], [use_consolekit="yes" use_systemd_logind="no" use_elogind="no"])
++AS_IF([test "$with_session_tracking" = "systemd"], [use_consolekit="no" use_systemd_logind="yes" use_elogind="no"])
++AS_IF([test "$with_session_tracking" = "elogind"], [use_consolekit="no" use_systemd_logind="no" use_elogind="yes"])
++AS_IF([test "$with_session_tracking" = "no"], [use_consolekit="no" use_systemd_logind="no" use_elogind="no"])
++AS_IF([test "$with_session_tracking" = "none"], [use_consolekit="no" use_systemd_logind="no" use_elogind="no"])
+ # current options
+ AS_IF([test -n "$with_systemd_logind" ], [use_systemd_logind="$with_systemd_logind"])
+ AS_IF([test -n "$with_consolekit" ], [use_consolekit="$with_consolekit"])
+@@ -454,6 +455,20 @@
+ AC_DEFINE([SESSION_TRACKING_SYSTEMD], 1, [Define to 1 if libsystemd-login is available])
+ session_tracking="$session_tracking, systemd-logind"
+ fi
++
++if test "$use_elogind" = "yes" -o "$use_elogind" = "auto"; then
++ PKG_CHECK_MODULES(SYSTEMD_LOGIN, [libelogind], [have_elogind=yes], [PKG_CHECK_MODULES(SYSTEMD_LOGIN, [libelogind], [have_elogind=yes], [have_elogind=no])])
++else
++ have_elogind=no
++fi
++if test "$use_elogind" = "yes" -a "$have_elogind" = "no"; then
++ AC_MSG_ERROR([You must have libelogind installed to build with elogind support.])
++fi
++if test "$have_elogind" = "yes"; then
++ AC_DEFINE([SESSION_TRACKING_ELOGIND], 1, [Define to 1 if libelogin is available])
++ session_tracking="$session_tracking, elogind"
++fi
++
+ if test "$use_consolekit" = "yes"; then
+ AC_DEFINE([SESSION_TRACKING_CONSOLEKIT], 1, [Define to 1 if ConsoleKit is available])
+ AC_DEFINE([CKDB_PATH], "/var/run/ConsoleKit/database", [Path to ConsoleKit database])
+@@ -461,7 +476,7 @@
+ fi
+ session_tracking="$(printf '%s' "${session_tracking}" | sed 's/^, //')"
+
+-AC_ARG_WITH(suspend-resume, AS_HELP_STRING([--with-suspend-resume=upower|systemd|consolekit], [Build NetworkManager with specific suspend/resume support]))
++AC_ARG_WITH(suspend-resume, AS_HELP_STRING([--with-suspend-resume=upower|systemd|elogind|consolekit], [Build NetworkManager with specific suspend/resume support]))
+ if test "z$with_suspend_resume" = "z"; then
+ PKG_CHECK_EXISTS([libsystemd >= 209], [have_systemd_inhibit=yes],
+ [PKG_CHECK_EXISTS([libsystemd-login >= 183], [have_systemd_inhibit=yes], [have_systemd_inhibit=no])])
+@@ -469,6 +484,12 @@
+ # Use systemd if it's new enough
+ with_suspend_resume="systemd"
+ else
++ PKG_CHECK_EXISTS([libelogind >= 219], [have_elogind_inhibit=yes],
++ [PKG_CHECK_EXISTS([libelogind >= 219], [have_elogind_inhibit=yes], [have_elogind_inhibit=no])])
++ if test "z${have_elogind_inhibit}" = "zyes"; then
++ # Use elogind if it's new enough
++ with_suspend_resume="elogind"
++ else
+ if test "$use_consolekit" = "yes"; then
+ # Use consolekit suspend if session tracking is consolekit
+ with_suspend_resume="consolekit"
+@@ -478,6 +499,7 @@
+ fi
+ fi
+ fi
++fi
+
+ case $with_suspend_resume in
+ upower)
+@@ -488,11 +510,16 @@
+ [PKG_CHECK_MODULES(SYSTEMD_INHIBIT, [libsystemd-login >= 183])])
+ AC_DEFINE([SUSPEND_RESUME_SYSTEMD], 1, [Define to 1 to use systemd suspend api])
+ ;;
++ elogind)
++ PKG_CHECK_MODULES(ELOGIND_INHIBIT, [libelogind >= 219],,
++ [PKG_CHECK_MODULES(ELOGIND_INHIBIT, [libelogind >= 219])])
++ AC_DEFINE([SUSPEND_RESUME_ELOGIND], 1, [Define to 1 to use elogind suspend api])
++ ;;
+ consolekit)
+ AC_DEFINE([SUSPEND_RESUME_CONSOLEKIT], 1, [Define to 1 to use ConsoleKit2 suspend api])
+ ;;
+ *)
+- AC_MSG_ERROR(--with-suspend-resume must be one of [upower, systemd, consolekit])
++ AC_MSG_ERROR(--with-suspend-resume must be one of [upower, systemd, elogind, consolekit])
+ ;;
+ esac
+
+--- a/src/nm-sleep-monitor.c 2017-02-14 09:57:16.963251852 +0100
++++ b/src/nm-sleep-monitor.c 2017-02-14 09:58:01.855253200 +0100
+@@ -38,7 +38,7 @@
+ #define USE_UPOWER 1
+ #define _NMLOG_PREFIX_NAME "sleep-monitor-up"
+
+-#elif defined (SUSPEND_RESUME_SYSTEMD)
++#elif defined (SUSPEND_RESUME_SYSTEMD) || defined (SUSPEND_RESUME_ELOGIND)
+
+ #define SUSPEND_DBUS_NAME "org.freedesktop.login1"
+ #define SUSPEND_DBUS_PATH "/org/freedesktop/login1"
+@@ -60,7 +60,7 @@
+
+ #else
+
+-#error define one of SUSPEND_RESUME_SYSTEMD, SUSPEND_RESUME_CONSOLEKIT, or SUSPEND_RESUME_UPOWER
++#error define one of SUSPEND_RESUME_SYSTEMD, SUSPEND_RESUME_ELOGIND, SUSPEND_RESUME_CONSOLEKIT, or SUSPEND_RESUME_UPOWER
+
+ #endif
+
+--- a/src/nm-session-monitor.c 2017-02-14 09:49:08.645237191 +0100
++++ b/src/nm-session-monitor.c 2017-02-14 09:56:48.680251003 +0100
+@@ -32,6 +32,11 @@
+ #ifdef SESSION_TRACKING_SYSTEMD
+ #include <systemd/sd-login.h>
+ #endif
++#ifdef SESSION_TRACKING_ELOGIND
++#include <elogind/sd-login.h>
++/* Re-Use SESSION_TRACKING_SYSTEMD as elogind substitutes systemd-login */
++#define SESSION_TRACKING_SYSTEMD 1
++#endif
+
+ /********************************************************************/
+
+@@ -103,7 +108,11 @@
+ status = sd_uid_get_sessions (uid, active, NULL);
+
+ if (status < 0)
++#ifdef SESSION_TRACKING_ELOGIND
++ _LOGE ("failed to get elogind sessions for uid %d: %d", uid, status);
++#else
+ _LOGE ("failed to get systemd sessions for uid %d: %d", uid, status);
++#endif /* SESSION_TRACKING_ELOGIND */
+
+ return status > 0;
+ }
+@@ -130,7 +139,11 @@
+ return;
+
+ if ((status = sd_login_monitor_new (NULL, &monitor->sd.monitor)) < 0) {
++#ifdef SESSION_TRACKING_ELOGIND
++ _LOGE ("failed to create elogind monitor: %d", status);
++#else
+ _LOGE ("failed to create systemd login monitor: %d", status);
++#endif /* SESSION_TRACKING_ELOGIND */
+ return;
+ }
+
+@@ -375,7 +388,11 @@
+ {
+ #ifdef SESSION_TRACKING_SYSTEMD
+ st_sd_init (monitor);
++#ifdef SESSION_TRACKING_ELOGIND
++ _LOGD ("using elogind session tracking");
++#else
+ _LOGD ("using systemd-logind session tracking");
++#endif /* SESSION_TRACKING_ELOGIND */
+ #endif
+
+ #ifdef SESSION_TRACKING_CONSOLEKIT
diff --git a/net-misc/networkmanager/metadata.xml b/net-misc/networkmanager/metadata.xml
new file mode 100644
index 0000000..5603207
--- /dev/null
+++ b/net-misc/networkmanager/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+ </maintainer>
+ <use>
+ <flag name="connection-sharing">Use <pkg>net-dns/dnsmasq</pkg> and
+ <pkg>net-firewall/iptables</pkg> for connection sharing</flag>
+ <flag name="consolekit">Use <pkg>sys-auth/consolekit</pkg> for session
+ tracking</flag>
+ <flag name="dhclient">Use dhclient from <pkg>net-misc/dhcp</pkg> for
+ getting ip</flag>
+ <flag name="json">Enable JSON validation via <pkg>dev-libs/jansson</pkg>
+ in libnm.</flag>
+ <flag name="modemmanager">Enable support for mobile broadband devices
+ using <pkg>net-misc/modemmanager</pkg></flag>
+ <flag name="nss">Use <pkg>dev-libs/nss</pkg> for cryptography</flag>
+ <flag name="ofono">Use <pkg>net-misc/ofono</pkg> for telephony support.</flag>
+ <flag name="ppp">Enable support for mobile broadband and PPPoE
+ connections using <pkg>net-dialup/ppp</pkg></flag>
+ <flag name="resolvconf">Use <pkg>net-dns/openresolv</pkg> for managing
+ DNS information</flag>
+ <flag name="teamd">Enable Teamd control support</flag>
+ <flag name="wifi">Enable support for wifi and 802.1x security using
+ <pkg>net-wireless/wpa_supplicant</pkg></flag>
+ <flag name="wext">Enable support for the deprecated Wext (Wireless
+ Extensions) API; needed for some older drivers (e.g. ipw2200,
+ ndiswrapper)</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-misc/networkmanager/networkmanager-1.4.4-r11.ebuild b/net-misc/networkmanager/networkmanager-1.4.4-r11.ebuild
new file mode 100644
index 0000000..f827dbf
--- /dev/null
+++ b/net-misc/networkmanager/networkmanager-1.4.4-r11.ebuild
@@ -0,0 +1,355 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME_ORG_MODULE="NetworkManager"
+GNOME2_LA_PUNT="yes"
+VALA_USE_DEPEND="vapigen"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+# Patch in elogind support
+# Bug #607352
+GNOME2_EAUTORECONF="yes"
+
+inherit bash-completion-r1 gnome2 linux-info multilib python-any-r1 systemd \
+ user readme.gentoo-r1 toolchain-funcs vala versionator virtualx udev multilib-minimal
+
+DESCRIPTION="A set of co-operative tools that make networking simple and straightforward"
+HOMEPAGE="https://wiki.gnome.org/Projects/NetworkManager"
+
+LICENSE="GPL-2+"
+SLOT="0" # add subslot if libnm-util.so.2 or libnm-glib.so.4 bumps soname version
+
+IUSE="audit bluetooth connection-sharing consolekit +dhclient elogind gnutls \
++introspection json kernel_linux +nss +modemmanager ncurses ofono +ppp \
+resolvconf selinux systemd teamd test vala +wext +wifi"
+
+REQUIRED_USE="
+
+ modemmanager? ( ppp )
+ vala? ( introspection )
+ wext? ( wifi )
+ ^^ ( nss gnutls )
+ ?? ( consolekit elogind systemd )
+"
+
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+# gobject-introspection-0.10.3 is needed due to gnome bug 642300
+# wpa_supplicant-0.7.3-r3 is needed due to bug 359271
+# TODO: need multilib janson (linked to libnm.so)
+COMMON_DEPEND="
+ >=sys-apps/dbus-1.2[${MULTILIB_USEDEP}]
+ >=dev-libs/dbus-glib-0.100[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.37.6:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libnl-3.2.8:3=
+ >=sys-auth/polkit-0.106
+ net-libs/libndp
+ >=net-libs/libsoup-2.40:2.4=
+ net-misc/iputils
+ sys-apps/util-linux[${MULTILIB_USEDEP}]
+ sys-libs/readline:0=
+ >=virtual/libgudev-165:=[${MULTILIB_USEDEP}]
+ audit? ( sys-process/audit )
+ bluetooth? ( >=net-wireless/bluez-5 )
+ connection-sharing? (
+ net-dns/dnsmasq[dhcp]
+ net-firewall/iptables )
+ consolekit? ( >=sys-auth/consolekit-1.0.0 )
+ dhclient? ( >=net-misc/dhcp-4[client] )
+ elogind? ( sys-auth/elogind )
+ gnutls? (
+ dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
+ >=net-libs/gnutls-2.12:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-0.10.3:= )
+ json? ( dev-libs/jansson )
+ modemmanager? ( >=net-misc/modemmanager-0.7.991:0= )
+ ncurses? ( >=dev-libs/newt-0.52.15 )
+ nss? ( >=dev-libs/nss-3.11:=[${MULTILIB_USEDEP}] )
+ ofono? ( net-misc/ofono )
+ ppp? ( >=net-dialup/ppp-2.4.5:=[ipv6] )
+ resolvconf? ( net-dns/openresolv )
+ selinux? ( sys-libs/libselinux )
+ systemd? ( >=sys-apps/systemd-209:0= )
+ teamd? ( >=net-misc/libteam-1.9 )
+"
+RDEPEND="${COMMON_DEPEND}
+ wifi? ( >=net-wireless/wpa_supplicant-0.7.3-r3[dbus] )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ >=sys-kernel/linux-headers-2.6.29
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ vala? ( $(vala_depend) )
+ test? (
+ $(python_gen_any_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ )
+"
+
+PATCHES=(
+ # Patch in elogind support
+ # Bug #607352
+ "${FILESDIR}"/${P}-enable-elogind.patch
+)
+
+python_check_deps() {
+ if use test; then
+ has_version "dev-python/dbus-python[${PYTHON_USEDEP}]" &&
+ has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
+ else
+ return 0
+ fi
+}
+
+sysfs_deprecated_check() {
+ ebegin "Checking for SYSFS_DEPRECATED support"
+
+ if { linux_chkconfig_present SYSFS_DEPRECATED_V2; }; then
+ eerror "Please disable SYSFS_DEPRECATED_V2 support in your kernel config and recompile your kernel"
+ eerror "or NetworkManager will not work correctly."
+ eerror "See https://bugs.gentoo.org/333639 for more info."
+ die "CONFIG_SYSFS_DEPRECATED_V2 support detected!"
+ fi
+ eend $?
+}
+
+pkg_pretend() {
+ if use kernel_linux; then
+ get_version
+ if linux_config_exists; then
+ sysfs_deprecated_check
+ else
+ ewarn "Was unable to determine your kernel .config"
+ ewarn "Please note that if CONFIG_SYSFS_DEPRECATED_V2 is set in your kernel .config, NetworkManager will not work correctly."
+ ewarn "See https://bugs.gentoo.org/333639 for more info."
+ fi
+
+ fi
+}
+
+pkg_setup() {
+ if use connection-sharing; then
+ CONFIG_CHECK="~NF_NAT_IPV4 ~NF_NAT_MASQUERADE_IPV4"
+ linux-info_pkg_setup
+ fi
+ enewgroup plugdev
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ DOC_CONTENTS="To modify system network connections without needing to enter the
+ root password, add your user account to the 'plugdev' group."
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local myconf=()
+
+ # Same hack as net-dialup/pptpd to get proper plugin dir for ppp, bug #519986
+ if use ppp; then
+ local PPPD_VER=`best_version net-dialup/ppp`
+ PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
+ myconf+=( --with-pppd-plugin-dir=/usr/$(get_libdir)/pppd/${PPPD_VER} )
+ fi
+
+ # unit files directory needs to be passed only when systemd is enabled,
+ # otherwise systemd support is not disabled completely, bug #524534
+ use systemd && myconf+=( --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" )
+
+ if multilib_is_native_abi; then
+ # work-around man out-of-source brokenness, must be done before configure
+ mkdir man || die
+ find "${S}"/man -name '*.?' -exec ln -s {} man/ ';' || die
+ else
+ # libnl, libndp are only used for executables, not libraries
+ myconf+=( LIB{NL,NDP}_{CFLAGS,LIBS}=' ' )
+ fi
+
+ # ifnet plugin always disabled until someone volunteers to actively
+ # maintain and fix it
+ # Also disable dhcpcd support as it's also completely unmaintained
+ # and facing bugs like #563938 and many others
+ #
+ # We need --with-libnm-glib (and dbus-glib dep) as reverse deps are
+ # still not ready for removing that lib
+ ECONF_SOURCE=${S} \
+ runstatedir="/run" \
+ gnome2_src_configure \
+ --disable-more-warnings \
+ --disable-static \
+ --localstatedir=/var \
+ --disable-lto \
+ --disable-config-plugin-ibft \
+ --disable-ifnet \
+ --disable-qt \
+ --without-netconfig \
+ --with-dbus-sys-dir=/etc/dbus-1/system.d \
+ --with-libnm-glib \
+ --with-nmcli=yes \
+ --with-udev-dir="$(get_udevdir)" \
+ --with-config-plugins-default=keyfile \
+ --with-iptables=/sbin/iptables \
+ $(multilib_native_with libsoup) \
+ $(multilib_native_enable concheck) \
+ --with-crypto=$(usex nss nss gnutls) \
+ --with-session-tracking=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind $(multilib_native_usex consolekit consolekit no))) \
+ --with-suspend-resume=$(multilib_native_usex systemd systemd $(multilib_native_usex elogind elogind consolekit)) \
+ $(multilib_native_use_with audit libaudit) \
+ $(multilib_native_use_enable bluetooth bluez5-dun) \
+ $(multilib_native_use_enable introspection) \
+ $(multilib_native_use_enable json json-validation) \
+ $(multilib_native_use_enable ppp) \
+ $(use_with dhclient) \
+ --without-dhcpcd \
+ $(multilib_native_use_with modemmanager modem-manager-1) \
+ $(multilib_native_use_with ncurses nmtui) \
+ $(multilib_native_use_with ofono) \
+ $(multilib_native_use_with resolvconf) \
+ $(multilib_native_use_with selinux) \
+ $(multilib_native_use_with systemd systemd-journal) \
+ $(multilib_native_use_enable teamd teamdctl) \
+ $(multilib_native_use_enable test tests) \
+ $(multilib_native_use_enable vala) \
+ --without-valgrind \
+ $(multilib_native_use_with wext) \
+ $(multilib_native_use_enable wifi) \
+ "${myconf[@]}"
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ local d
+ for d in api libnm libnm-util libnm-glib; do
+ ln -s "${S}"/docs/${d}/html docs/${d}/html || die
+ done
+ fi
+
+ # Disable examples
+ # https://bugzilla.gnome.org/show_bug.cgi?id=769711
+ cat > examples/Makefile <<-EOF
+ .PHONY: all check install
+ all:
+ check:
+ install:
+ EOF
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ emake
+ else
+ emake all-am
+ emake -C shared
+ emake -C introspection # generated headers, needed for libnm
+ emake -C libnm-core
+ emake -C libnm
+ emake -C libnm-util
+ emake -C libnm-glib
+ fi
+}
+
+multilib_src_test() {
+ if use test && multilib_is_native_abi; then
+ python_setup
+ virtx emake check
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ # Install completions at proper place, bug #465100
+ gnome2_src_install completiondir="$(get_bashcompdir)"
+ else
+ emake DESTDIR="${D}" install-am
+ emake DESTDIR="${D}" install -C shared
+ emake DESTDIR="${D}" install -C introspection
+ emake DESTDIR="${D}" install -C libnm-core
+ emake DESTDIR="${D}" install -C libnm
+ emake DESTDIR="${D}" install -C libnm-util
+ emake DESTDIR="${D}" install -C libnm-glib
+ fi
+}
+
+multilib_src_install_all() {
+ ! use systemd && readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/init.d.NetworkManager-r1" NetworkManager
+ newconfd "${FILESDIR}/conf.d.NetworkManager" NetworkManager
+
+ # Need to keep the /etc/NetworkManager/dispatched.d for dispatcher scripts
+ keepdir /etc/NetworkManager/dispatcher.d
+
+ # Provide openrc net dependency only when nm is connected
+ exeinto /etc/NetworkManager/dispatcher.d
+ newexe "${FILESDIR}/10-openrc-status-r4" 10-openrc-status
+ sed -e "s:@EPREFIX@:${EPREFIX}:g" \
+ -i "${ED}/etc/NetworkManager/dispatcher.d/10-openrc-status" || die
+
+ keepdir /etc/NetworkManager/system-connections
+ chmod 0600 "${ED}"/etc/NetworkManager/system-connections/.keep* # bug #383765, upstream bug #754594
+
+ # Allow users in plugdev group to modify system connections
+ insinto /usr/share/polkit-1/rules.d/
+ doins "${FILESDIR}/01-org.freedesktop.NetworkManager.settings.modify.system.rules"
+
+ # Remove empty /run/NetworkManager
+ rmdir "${D}"/run/NetworkManager "${D}"/run || die
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ ! use systemd && readme.gentoo_print_elog
+
+ if [[ -e "${EROOT}etc/NetworkManager/nm-system-settings.conf" ]]; then
+ ewarn "The ${PN} system configuration file has moved to a new location."
+ ewarn "You must migrate your settings from ${EROOT}/etc/NetworkManager/nm-system-settings.conf"
+ ewarn "to ${EROOT}etc/NetworkManager/NetworkManager.conf"
+ ewarn
+ ewarn "After doing so, you can remove ${EROOT}etc/NetworkManager/nm-system-settings.conf"
+ fi
+
+ # The polkit rules file moved to /usr/share
+ old_rules="${EROOT}etc/polkit-1/rules.d/01-org.freedesktop.NetworkManager.settings.modify.system.rules"
+ if [[ -f "${old_rules}" ]]; then
+ case "$(md5sum ${old_rules})" in
+ 574d0cfa7e911b1f7792077003060240* )
+ # Automatically delete the old rules.d file if the user did not change it
+ elog
+ elog "Removing old ${old_rules} ..."
+ rm -f "${old_rules}" || eerror "Failed, please remove ${old_rules} manually"
+ ;;
+ * )
+ elog "The ${old_rules}"
+ elog "file moved to /usr/share/polkit-1/rules.d/ in >=networkmanager-0.9.4.0-r4"
+ elog "If you edited ${old_rules}"
+ elog "without changing its behavior, you may want to remove it."
+ ;;
+ esac
+ fi
+
+ # NM fallbacks to plugin specified at compile time (upstream bug #738611)
+ # but still show a warning to remember people to have cleaner config file
+ if [[ -e "${EROOT}etc/NetworkManager/NetworkManager.conf" ]]; then
+ if grep plugins "${EROOT}etc/NetworkManager/NetworkManager.conf" | grep -q ifnet; then
+ ewarn
+ ewarn "You seem to use 'ifnet' plugin in ${EROOT}etc/NetworkManager/NetworkManager.conf"
+ ewarn "Since it won't be used, you will need to stop setting ifnet plugin there."
+ ewarn
+ fi
+ fi
+
+ # NM shows lots of errors making nmcli neither unusable, bug #528748 upstream bug #690457
+ if grep -r "psk-flags=1" "${EROOT}"/etc/NetworkManager/; then
+ ewarn "You have psk-flags=1 setting in above files, you will need to"
+ ewarn "either reconfigure affected networks or, at least, set the flag"
+ ewarn "value to '0'."
+ fi
+}