summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2017-08-31 17:56:42 +0200
committerSven Eden <sven.eden@gmx.de>2017-08-31 17:56:42 +0200
commit642b4708667c96d1087e85c57f5563640b60b9b6 (patch)
tree069165aa2b5bcb59df3d4a65f791519c25d6c50b /sys-auth/elogind
parentsys-auth/elogind-9999 : New live ebuild to test new meson build in master. (diff)
downloadseden-642b4708667c96d1087e85c57f5563640b60b9b6.tar.gz
seden-642b4708667c96d1087e85c57f5563640b60b9b6.tar.bz2
seden-642b4708667c96d1087e85c57f5563640b60b9b6.zip
sys-auth/elogind-9999 : Adapt init and config file to the new 235+ scheme
Diffstat (limited to 'sys-auth/elogind')
-rw-r--r--sys-auth/elogind/elogind-9999.ebuild4
-rw-r--r--sys-auth/elogind/files/elogind-235.conf.in7
-rw-r--r--sys-auth/elogind/files/elogind-235.init25
3 files changed, 34 insertions, 2 deletions
diff --git a/sys-auth/elogind/elogind-9999.ebuild b/sys-auth/elogind/elogind-9999.ebuild
index 5066319..99c34c9 100644
--- a/sys-auth/elogind/elogind-9999.ebuild
+++ b/sys-auth/elogind/elogind-9999.ebuild
@@ -78,9 +78,9 @@ src_configure() {
src_install() {
meson_src_install
- newinitd "${FILESDIR}"/${PN}.init ${PN}
+ newinitd "${FILESDIR}"/${PN}-235.init ${PN}
- sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}-235.conf.in > ${PN}.conf || die
newconfd ${PN}.conf ${PN}
}
diff --git a/sys-auth/elogind/files/elogind-235.conf.in b/sys-auth/elogind/files/elogind-235.conf.in
new file mode 100644
index 0000000..d6dd2f1
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-235.conf.in
@@ -0,0 +1,7 @@
+# /etc/conf.d/elogind: config file for /etc/init.d/elogind
+
+# this is the elogind executable
+ELOGIND_EXEC="/@libdir@/libexec/elogind"
+
+# this is where elogind will store its pid file
+ELOGIND_PIDFILE="/run/elogind.pid"
diff --git a/sys-auth/elogind/files/elogind-235.init b/sys-auth/elogind/files/elogind-235.init
new file mode 100644
index 0000000..293aac6
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-235.init
@@ -0,0 +1,25 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need dbus
+
+ # Make sure elogind is up before xdm starts any dm
+ before xdm
+}
+
+start() {
+ ebegin "Starting elogind"
+
+ start-stop-daemon --start --quiet \
+ --pidfile "${ELOGIND_PIDFILE}" \
+ --exec "${ELOGIND_EXEC} --daemon"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping elogind"
+ start-stop-daemon --stop --quiet --pidfile "${ELOGIND_PIDFILE}"
+ eend $?
+}